summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-10-07 23:11:24 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-10-07 23:11:24 +0000
commitc774c64b5f004c8783e17bba88b66e10bf25ac60 (patch)
tree9a862870f6ef20ccfbaa3b52c0b5dbe39382b269 /app-text
parentFix build-time dependencies. (diff)
downloadgentoo-2-c774c64b5f004c8783e17bba88b66e10bf25ac60.tar.gz
gentoo-2-c774c64b5f004c8783e17bba88b66e10bf25ac60.tar.bz2
gentoo-2-c774c64b5f004c8783e17bba88b66e10bf25ac60.zip
Stop using a patch to fix the problem of linking to the original poppler library, just use sed. This way we also don't have to use the kludgy workaround of linking to the libpoppler.la file which was a consequence of the patch not having been updated. Also, this makes us not a bug sieve for people who have somehow unlinked their lib from their lib64.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc8 x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler-bindings/ChangeLog10
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild82
-rw-r--r--app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild8
3 files changed, 13 insertions, 87 deletions
diff --git a/app-text/poppler-bindings/ChangeLog b/app-text/poppler-bindings/ChangeLog
index 0e23c0b5678e..cf5d28954c85 100644
--- a/app-text/poppler-bindings/ChangeLog
+++ b/app-text/poppler-bindings/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/poppler-bindings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.105 2008/10/07 12:09:46 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/ChangeLog,v 1.106 2008/10/07 23:11:24 loki_val Exp $
+
+ 07 Oct 2008; Peter Alfredsen <loki_val@gentoo.org>
+ -poppler-bindings-0.8.5.ebuild, poppler-bindings-0.8.7.ebuild:
+ Stop using a patch to fix the problem of linking to the original poppler
+ library, just use sed. This way we also don't have to use the kludgy
+ workaround of linking to the libpoppler.la file which was a consequence of
+ the patch not having been updated. This way, we're also not a bug sieve
+ for people who have somehow unlinked their lib from their lib64.
07 Oct 2008; nixnut <nixnut@gentoo.org> poppler-bindings-0.8.7.ebuild:
Stable on ppc wrt bug 239414
diff --git a/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild b/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild
deleted file mode 100644
index 2caf7c05a27a..000000000000
--- a/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.5.ebuild,v 1.1 2008/08/03 19:48:49 loki_val Exp $
-
-EAPI="1"
-
-inherit autotools eutils multilib
-
-MY_P=${P/-bindings/}
-DESCRIPTION="rendering bindings for GUI toolkits for poppler"
-HOMEPAGE="http://poppler.freedesktop.org/"
-
-# Creating the testsuite tarball (must be done for every release)
-#
-# git clone git://anongit.freedesktop.org/git/poppler/test
-# rm -rf test/.git
-# tar czf poppler-test-${PV}.tar.gz test
-# upload to d.g.o/space/distfiles-local
-
-SRC_URI="http://poppler.freedesktop.org/${MY_P}.tar.gz
- test? ( mirror://gentoo/poppler-test-${PV}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gtk qt3 cairo qt4 test"
-
-RDEPEND="~app-text/poppler-${PV}
- cairo? ( >=x11-libs/cairo-1.4 )
- gtk? (
- >=x11-libs/gtk+-2.8
- >=gnome-base/libglade-2
- )
- qt3? ( =x11-libs/qt-3* )
- qt4? ( || ( ( x11-libs/qt-core:4
- x11-libs/qt-gui:4
- x11-libs/qt-test:4 )
- =x11-libs/qt-4.3*:4 ) )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/poppler-0.6-bindings.patch
-
- AT_M4DIR="m4" eautoreconf
- cd poppler
- ln -s /usr/lib/libpoppler.la
-}
-
-src_compile() {
- # Configure needs help finding qt libs on multilib systems
- export QTLIB="${QTDIR}/$(get_libdir)"
- echo $QTLIB
-
- econf $(use_enable cairo cairo-output) \
- $(use_enable gtk poppler-glib) \
- $(use_enable qt3 poppler-qt) \
- $(use_enable qt4 poppler-qt4) \
- || die "configuration failed"
- cd poppler
- if use cairo; then
- emake libpoppler-cairo.la || die "cairo failed"
- fi
- if use qt4; then
- emake libpoppler-arthur.la || die "arthur failed"
- fi
- cd ..
- emake || die "compilation failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
-
-pkg_postinst() {
- ewarn "You need to rebuild everything depending on poppler, use revdep-rebuild"
-}
diff --git a/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild b/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild
index cb99f7053b9e..d386c5e29678 100644
--- a/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild
+++ b/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild,v 1.6 2008/10/07 12:09:46 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler-bindings/poppler-bindings-0.8.7.ebuild,v 1.7 2008/10/07 23:11:24 loki_val Exp $
EAPI="1"
@@ -45,11 +45,11 @@ src_unpack(){
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/poppler-0.6-bindings.patch
+ sed -i \
+ -e 's:$(top_builddir)/poppler/libpoppler.la:-lpoppler:' \
+ $(find . -name 'Makefile.am' ) || die "404"
AT_M4DIR="m4" eautoreconf
- cd poppler
- ln -s /usr/lib/libpoppler.la
}
src_compile() {