summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2014-04-24 01:23:57 +0000
committerMart Raudsepp <leio@gentoo.org>2014-04-24 01:23:57 +0000
commitefba9da0e2a2c32f5404e6d7020c6a936e0171ca (patch)
tree043ca7c863621a27e6da6a08162a08bbe1cdc88b /app-text
parentAutomated update. (diff)
downloadgentoo-2-efba9da0e2a2c32f5404e6d7020c6a936e0171ca.tar.gz
gentoo-2-efba9da0e2a2c32f5404e6d7020c6a936e0171ca.tar.bz2
gentoo-2-efba9da0e2a2c32f5404e6d7020c6a936e0171ca.zip
Restore 0.20.10; it was still the latest stable on all arches besides amd64/hppa/x86.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gnome-doc-utils/ChangeLog6
-rw-r--r--app-text/gnome-doc-utils/gnome-doc-utils-0.20.10.ebuild82
2 files changed, 87 insertions, 1 deletions
diff --git a/app-text/gnome-doc-utils/ChangeLog b/app-text/gnome-doc-utils/ChangeLog
index 4831946cd19f..6feb31a0a2db 100644
--- a/app-text/gnome-doc-utils/ChangeLog
+++ b/app-text/gnome-doc-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/gnome-doc-utils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-doc-utils/ChangeLog,v 1.218 2014/04/23 20:55:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-doc-utils/ChangeLog,v 1.219 2014/04/24 01:23:57 leio Exp $
+
+ 24 Apr 2014; Mart Raudsepp <leio@gentoo.org> +gnome-doc-utils-0.20.10.ebuild:
+ Restore 0.20.10; it was still the latest stable on all arches besides
+ amd64/hppa/x86.
23 Apr 2014; Pacho Ramos <pacho@gentoo.org> -gnome-doc-utils-0.20.10.ebuild:
Drop old
diff --git a/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10.ebuild b/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10.ebuild
new file mode 100644
index 000000000000..b8909aec14d2
--- /dev/null
+++ b/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-doc-utils/gnome-doc-utils-0.20.10.ebuild,v 1.13 2014/04/24 01:23:57 leio Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+
+inherit gnome2 python
+
+DESCRIPTION="A collection of documentation utilities for the Gnome project"
+HOMEPAGE="http://live.gnome.org/GnomeDocUtils"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.6.12[python]
+ >=dev-libs/libxslt-1.1.8
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ app-text/docbook-xml-dtd:4.4
+ app-text/scrollkeeper-dtd
+ sys-devel/gettext
+ virtual/awk
+ virtual/pkgconfig"
+# dev-libs/glib needed for eautofoo, bug #255114.
+
+# If there is a need to reintroduce eautomake or eautoreconf, make sure
+# to AT_M4DIR="tools m4", bug #224609 (m4 removes glib build time dep)
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="${G2CONF} --disable-scrollkeeper"
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ python_clean_py-compile_files
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_test() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ installation() {
+ gnome2_src_install
+ python_convert_shebangs $(python_get_version) "${ED}"usr/bin/xml2po
+ mv "${ED}"usr/bin/xml2po "${ED}"usr/bin/xml2po-$(python_get_version)
+ }
+ python_execute_function -s installation
+ python_clean_installation_image
+
+ python_generate_wrapper_scripts -E -f "${ED}"usr/bin/xml2po
+}
+
+pkg_postinst() {
+ python_mod_optimize xml2po
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup xml2po
+ gnome2_pkg_postrm
+}