summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-27 05:26:25 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-27 05:26:25 +0000
commitf93a9b4701938a860bca75c910e0bb6e29c2822c (patch)
treecb9bbd99ff3fe94368ac3d093f2608c359971bbc /app-text
parentInitial import. (diff)
downloadgentoo-2-f93a9b4701938a860bca75c910e0bb6e29c2822c.tar.gz
gentoo-2-f93a9b4701938a860bca75c910e0bb6e29c2822c.tar.bz2
gentoo-2-f93a9b4701938a860bca75c910e0bb6e29c2822c.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/restview/ChangeLog7
-rw-r--r--app-text/restview/restview-2.3.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/app-text/restview/ChangeLog b/app-text/restview/ChangeLog
index 9d335893b6d4..bb70a0134161 100644
--- a/app-text/restview/ChangeLog
+++ b/app-text/restview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/restview
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/restview/ChangeLog,v 1.3 2015/01/06 20:00:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/restview/ChangeLog,v 1.4 2015/01/27 05:26:25 radhermit Exp $
+
+*restview-2.3.0 (27 Jan 2015)
+
+ 27 Jan 2015; Tim Harder <radhermit@gentoo.org> +restview-2.3.0.ebuild:
+ Version bump.
*restview-2.2.1 (06 Jan 2015)
diff --git a/app-text/restview/restview-2.3.0.ebuild b/app-text/restview/restview-2.3.0.ebuild
new file mode 100644
index 000000000000..0e6b7462ff5c
--- /dev/null
+++ b/app-text/restview/restview-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/restview/restview-2.3.0.ebuild,v 1.1 2015/01/27 05:26:25 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="reStructuredText viewer"
+HOMEPAGE="https://mg.pov.lt/restview/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/readme[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+DOCS=( README.rst CHANGES.rst )
+
+python_test() {
+ esetup.py test
+}