summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-20 12:19:38 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-20 12:19:38 +0000
commit77a021de93feea1457be83e230de2af8cfb6cb5b (patch)
tree0eada06c949f0ecb26d8cb1a6bb6784d40a8c13c /app-vim/breakpts/breakpts-4.0.ebuild
parentamd64 stable (diff)
downloadgentoo-2-77a021de93feea1457be83e230de2af8cfb6cb5b.tar.gz
gentoo-2-77a021de93feea1457be83e230de2af8cfb6cb5b.tar.bz2
gentoo-2-77a021de93feea1457be83e230de2af8cfb6cb5b.zip
Version bump.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-vim/breakpts/breakpts-4.0.ebuild')
-rw-r--r--app-vim/breakpts/breakpts-4.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/breakpts/breakpts-4.0.ebuild b/app-vim/breakpts/breakpts-4.0.ebuild
new file mode 100644
index 000000000000..c8a07fd12c67
--- /dev/null
+++ b/app-vim/breakpts/breakpts-4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/breakpts/breakpts-4.0.ebuild,v 1.1 2008/09/20 12:19:38 hawking Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: sets vim breakpoints visually"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=618"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ || ( >=app-editors/vim-7.0 >=app-editors/gvim-7.0 )
+ >=app-vim/multvals-3.6.1
+ >=app-vim/genutils-1.13
+ >=app-vim/foldutil-1.6"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin allows breakpoints to be set and cleared visually. To start,
+use :BreakPts, move to the required function and press <CR>. Breakpoints
+can then be added using :BPToggle or <F9>."