summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-08-05 16:34:27 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-08-05 16:34:27 +0000
commitd2f9a35eda1ba1c4c602adebcaae69003b74f0c9 (patch)
tree1fab0f767af1df89b651456713f0b113073e63bf /app-vim/doxygen-syntax/doxygen-syntax-1.12.ebuild
parent. (diff)
downloadgentoo-2-d2f9a35eda1ba1c4c602adebcaae69003b74f0c9.tar.gz
gentoo-2-d2f9a35eda1ba1c4c602adebcaae69003b74f0c9.tar.bz2
gentoo-2-d2f9a35eda1ba1c4c602adebcaae69003b74f0c9.zip
Version bump, bug #101454
(Portage version: 2.0.51.22-r2 flaming goat edition)
Diffstat (limited to 'app-vim/doxygen-syntax/doxygen-syntax-1.12.ebuild')
-rw-r--r--app-vim/doxygen-syntax/doxygen-syntax-1.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/doxygen-syntax/doxygen-syntax-1.12.ebuild b/app-vim/doxygen-syntax/doxygen-syntax-1.12.ebuild
new file mode 100644
index 000000000000..ac7fc3ad5ed3
--- /dev/null
+++ b/app-vim/doxygen-syntax/doxygen-syntax-1.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/doxygen-syntax/doxygen-syntax-1.12.ebuild,v 1.1 2005/08/05 16:34:27 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax higlighting for doxygen"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=5"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="doxygen.vim"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # make this work with the screwy vim7-supplied synload.vim, and fix the
+ # bug which causes it to try to use b:current_syntax when it's unset.
+ sed -e "/^let s:cpo_save/iif ! exists('b:current_syntax') | \
+let b:current_syntax='' | endif" \
+ -e "s/^if !exists('b:current_syntax')$/& || b:current_syntax == ''/" \
+ -e '1iau! Syntax cpp,c,idl' \
+ -e '1iau! Syntax *doxygen' \
+ -i syntax/doxygen.vim || \
+ die "sed failed"
+}
+