summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-08-08 22:10:50 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-08-08 22:10:50 +0000
commitf934e8134d951796d9f35f3502ea858e1aea0624 (patch)
tree577937e69677faea684edb7635a20f1bc8dd4a61 /app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild
parent~alpha keyword. (diff)
downloadgentoo-2-f934e8134d951796d9f35f3502ea858e1aea0624.tar.gz
gentoo-2-f934e8134d951796d9f35f3502ea858e1aea0624.tar.bz2
gentoo-2-f934e8134d951796d9f35f3502ea858e1aea0624.zip
Use hi def link rather than hi link. Bug #101797, bug #101804.
(Portage version: 2.0.51.22-r2 flaming goat edition)
Diffstat (limited to 'app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild')
-rw-r--r--app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild b/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild
new file mode 100644
index 000000000000..ec4662df0bc6
--- /dev/null
+++ b/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/help-extra-syntax/help-extra-syntax-20050106-r1.ebuild,v 1.1 2005/08/08 22:10:50 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: extra syntax highlighting for help files"
+HOMEPAGE="http://mysite.verizon.net/astronaut/vim/"
+LICENSE="as-is"
+KEYWORDS="alpha ~amd64 arm hppa ia64 mips ~ppc ppc64 sparc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides additional syntax highlighting for help files."
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # use hi def link, bug #101797 / bug #101804
+ sed -i -e 's,^hi link,hi def link,' \
+ "after/syntax/help.vim.d/extra-help-syntax.vim" || die "sed failed"
+}
+