summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-11-28 13:17:08 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-11-28 13:17:08 +0000
commite76993477cf0e2e8299b0d2607ea2e455349356e (patch)
tree0064929447163c2ea9dedfdcae9884cf53d4e164 /app-vim/vimoutliner/vimoutliner-0.3.3.ebuild
parentAdd a missing RDEPEND. Closes #72653. (Manifest recommit) (diff)
downloadgentoo-2-e76993477cf0e2e8299b0d2607ea2e455349356e.tar.gz
gentoo-2-e76993477cf0e2e8299b0d2607ea2e455349356e.tar.bz2
gentoo-2-e76993477cf0e2e8299b0d2607ea2e455349356e.zip
New package, as requested in bug #67261
Diffstat (limited to 'app-vim/vimoutliner/vimoutliner-0.3.3.ebuild')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild
new file mode 100644
index 000000000000..457c01d1a408
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimoutliner/vimoutliner-0.3.3.ebuild,v 1.1 2004/11/28 13:17:08 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easy and fast outlining"
+HOMEPAGE="http://www.vimoutliner.org"
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~mips ~amd64"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim
+ sed -i -e '/ru .vimoutlinerrc/aru vimoutlinerrc' ftplugin/vo_base.vim
+ sed -i -e '/hi spellErr,SpellErrors,BadWord/d' syntax/vo_base.vim
+}
+
+src_install() {
+ cd ${S}
+ p=/usr/share/vim/vimfiles
+ for d in doc ftdetect ftplugin syntax ; do
+ dodir ${p}/${d}
+ cp -R ${d} ${D}/${p}/
+ done
+
+ dodir ${p}/vimoutliner/plugins
+ cp -R add-ons/plugins ${D}/${p}/vimoutliner/
+
+ for d in scripts/* add-ons/scripts/* ; do
+ dobin ${d}
+ done
+
+ dodoc vimoutlinerrc
+}
+