summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-09-06 22:20:13 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-09-06 22:20:13 +0000
commit32dc4fa1502115db6ac45e8c7dbaa8eba64ae33a (patch)
tree14f54e39d1c1a4e90689dd95b0b991351884c113 /app-vim
parentnew ebuild (diff)
downloadgentoo-2-32dc4fa1502115db6ac45e8c7dbaa8eba64ae33a.tar.gz
gentoo-2-32dc4fa1502115db6ac45e8c7dbaa8eba64ae33a.tar.bz2
gentoo-2-32dc4fa1502115db6ac45e8c7dbaa8eba64ae33a.zip
Automatically generate help text from the vim file. Display plugin help text, bug #62559
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimirc/ChangeLog8
-rw-r--r--app-vim/vimirc/Manifest8
-rw-r--r--app-vim/vimirc/files/digest-vimirc-0.8.5-r11
-rw-r--r--app-vim/vimirc/vimirc-0.8.5-r1.ebuild34
4 files changed, 47 insertions, 4 deletions
diff --git a/app-vim/vimirc/ChangeLog b/app-vim/vimirc/ChangeLog
index 998bb60434b6..0ae07c5b4b7c 100644
--- a/app-vim/vimirc/ChangeLog
+++ b/app-vim/vimirc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/vimirc
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimirc/ChangeLog,v 1.13 2004/06/24 23:04:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimirc/ChangeLog,v 1.14 2004/09/06 22:20:13 ciaranm Exp $
+
+*vimirc-0.8.5-r1 (06 Sep 2004)
+
+ 06 Sep 2004; Ciaran McCreesh <ciaranm@gentoo.org> +vimirc-0.8.5-r1.ebuild:
+ Automatically generate help text from the vim file. Display plugin help text,
+ bug #62559
20 Jun 2004; Ciaran McCreesh <ciaranm@gentoo.org> -vimirc-0.6.3.ebuild,
-vimirc-0.7.2.ebuild, -vimirc-0.8.0.ebuild:
diff --git a/app-vim/vimirc/Manifest b/app-vim/vimirc/Manifest
index 1e3eb094c267..8a81ead65184 100644
--- a/app-vim/vimirc/Manifest
+++ b/app-vim/vimirc/Manifest
@@ -1,6 +1,8 @@
-MD5 edd88fcdd4eb1cad773891751326d613 vimirc-0.8.5.ebuild 684
-MD5 290b8ffa1dc7ea37c7b11e39e4de8181 vimirc-0.8.3.ebuild 686
MD5 8c5c04959321fee545138e231a0d26e2 ChangeLog 1464
+MD5 290b8ffa1dc7ea37c7b11e39e4de8181 vimirc-0.8.3.ebuild 686
+MD5 edd88fcdd4eb1cad773891751326d613 vimirc-0.8.5.ebuild 684
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
-MD5 606da086cc2b2e7a1f8e490b271f0e3a files/digest-vimirc-0.8.3 64
+MD5 5e8ad5ae1a1a2f6da989ceb4da3f0616 vimirc-0.8.5-r1.ebuild 947
MD5 0951d2c4f839b3d9dd1554bbb9bd6028 files/digest-vimirc-0.8.5 64
+MD5 606da086cc2b2e7a1f8e490b271f0e3a files/digest-vimirc-0.8.3 64
+MD5 0951d2c4f839b3d9dd1554bbb9bd6028 files/digest-vimirc-0.8.5-r1 64
diff --git a/app-vim/vimirc/files/digest-vimirc-0.8.5-r1 b/app-vim/vimirc/files/digest-vimirc-0.8.5-r1
new file mode 100644
index 000000000000..1a38437dfd44
--- /dev/null
+++ b/app-vim/vimirc/files/digest-vimirc-0.8.5-r1
@@ -0,0 +1 @@
+MD5 0126b122a98bb04cfa2a69775f0f12a4 vimirc-0.8.5.tar.bz2 30570
diff --git a/app-vim/vimirc/vimirc-0.8.5-r1.ebuild b/app-vim/vimirc/vimirc-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..23f06b22ca72
--- /dev/null
+++ b/app-vim/vimirc/vimirc-0.8.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimirc/vimirc-0.8.5-r1.ebuild,v 1.1 2004/09/06 22:20:13 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: IRC Client"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=931"
+LICENSE="vim"
+KEYWORDS="~x86 sparc mips ~ppc"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimirc.txt"
+
+# requires 6.2.412 at runtime. it's not too keen upon console vim, so we'll
+# just ask for gvim.
+RDEPEND=">=app-editors/gvim-6.2-r8"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Documentation is supplied in the source file.
+ mkdir doc
+ sed -e '/^[^"]/,9999d' -e 's~^" \?~~' -e '1s/$/ *vimirc.txt*/' \
+ plugin/vimirc.vim > doc/vimirc.txt
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ einfo " "
+ einfo "This plugin requires a Vim with perl support enabled. This is"
+ einfo "controlled by the 'perl' USE flag."
+ einfo " "
+}