summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-06 11:46:00 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-06 11:46:00 +0000
commit3ad606fc726e63437d285628f27aeb3f3a373bf6 (patch)
tree815aaa6d513c143725c2cb2054fad9b337d6d313 /app-vim
parentclean old impl (diff)
downloadgentoo-2-3ad606fc726e63437d285628f27aeb3f3a373bf6.tar.gz
gentoo-2-3ad606fc726e63437d285628f27aeb3f3a373bf6.tar.bz2
gentoo-2-3ad606fc726e63437d285628f27aeb3f3a373bf6.zip
Convert to python-single-r1, enforce a match on Python version used by vim.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/automatictexplugin/ChangeLog10
-rw-r--r--app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/app-vim/automatictexplugin/ChangeLog b/app-vim/automatictexplugin/ChangeLog
index af19f6decb84..60460d076ea1 100644
--- a/app-vim/automatictexplugin/ChangeLog
+++ b/app-vim/automatictexplugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/automatictexplugin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.48 2014/04/12 21:56:28 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/ChangeLog,v 1.49 2015/01/06 11:46:00 mgorny Exp $
+
+*automatictexplugin-12.5-r1 (06 Jan 2015)
+
+ 06 Jan 2015; Michał Górny <mgorny@gentoo.org>
+ +automatictexplugin-12.5-r1.ebuild:
+ Convert to python-single-r1, enforce a match on Python version used by vim.
*automatictexplugin-12.5 (12 Apr 2014)
diff --git a/app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild b/app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild
new file mode 100644
index 000000000000..db6d06a5ba71
--- /dev/null
+++ b/app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/automatictexplugin/automatictexplugin-12.5-r1.ebuild,v 1.1 2015/01/06 11:46:00 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 vim-plugin
+
+MY_P="AutomaticTexPlugin_${PV}"
+DESCRIPTION="vim plugin: a comprehensive plugin for editing LaTeX files"
+HOMEPAGE="http://atp-vim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atp-vim/releases/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}
+
+VIM_PLUGIN_HELPFILES="automatic-tex-plugin.txt"
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ !app-vim/vim-latex
+ app-vim/align
+ app-text/wdiff
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-tex/detex
+ virtual/tex-base
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ python_fix_shebang .
+}