summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-11-13 19:10:10 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-11-13 19:10:10 +0000
commit681be5489d72628c905455d470496ae2572ba05d (patch)
tree0f2d57cee1bdd0a4e19c71209e289be8de6e2050 /app-vim
parentdigest fixed (Manifest recommit) (diff)
downloadgentoo-2-681be5489d72628c905455d470496ae2572ba05d.tar.gz
gentoo-2-681be5489d72628c905455d470496ae2572ba05d.tar.bz2
gentoo-2-681be5489d72628c905455d470496ae2572ba05d.zip
New release. Changes include GLEP 31 (UTF-8) support (unless USE="ignore-glep31"), error highlighting for bad function syntax, more keywords (bug #71065) and pkg_config recognition (bug #67807)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/ChangeLog7
-rw-r--r--app-vim/gentoo-syntax/Manifest4
-rw-r--r--app-vim/gentoo-syntax/files/digest-gentoo-syntax-200411131
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20041113.ebuild52
4 files changed, 62 insertions, 2 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index d8df5ae53d0b..29d2b9b82032 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.14 2004/11/09 01:28:39 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.15 2004/11/13 19:10:10 ciaranm Exp $
+
+ 13 Nov 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
+ New release. Changes include GLEP 31 (UTF-8) support (unless
+ USE="ignore-glep31"), error highlighting for bad function syntax, more
+ keywords (bug #71065) and pkg_config recognition (bug #67807)
08 Nov 2004; Daniel Ostrow <dostrow@gentoo.org>
gentoo-syntax-20041009.ebuild:
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 9ba18872c143..5629a72741ef 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
MD5 396dae18cbf39a4eda441ef48cf40ec9 ChangeLog 2423
-MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 9ee2dc64110f6d40290cd51c9a540655 gentoo-syntax-20041113.ebuild 1840
MD5 15e22abf8413e78892c1a1c8e5569b78 gentoo-syntax-20041009.ebuild 651
+MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 8ae17c577573d3654205f007a4ecb6ce files/digest-gentoo-syntax-20041113 73
MD5 af854ba426622a145f3f786c605ff98c files/digest-gentoo-syntax-20041009 73
diff --git a/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041113 b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041113
new file mode 100644
index 000000000000..36875194a747
--- /dev/null
+++ b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041113
@@ -0,0 +1 @@
+MD5 93abe21730b65393c2f2eef5f03f12d1 gentoo-syntax-20041113.tar.bz2 7120
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20041113.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20041113.ebuild
new file mode 100644
index 000000000000..a8a1b035eabc
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20041113.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20041113.ebuild,v 1.1 2004/11/13 19:10:10 ciaranm Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage
+Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://developer.berlios.de/projects/gentoo-syntax"
+LICENSE="vim"
+KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc ~ppc64 ~alpha ~ia64"
+SRC_URI="http://download.berlios.de/gentoo-syntax/${P}.tar.bz2"
+
+# For gathering stats. Evil, I know, but I need to know whether I can
+# reasonably add this package in as a PDEPEND of vim-core. -- ciaranm
+RESTRICT="nomirror"
+
+IUSE="ignore-glep31"
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ einfo "Note for developers and anyone else who edits ebuilds:"
+ einfo " This release of gentoo-syntax now contains filetype rules to set"
+ einfo " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ einfo " If you find this feature breaks things, please submit a bug and"
+ einfo " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ einfo " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}
+