summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-20 13:59:45 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-20 13:59:45 +0000
commit8d189c322ce4aaba574ea9698e3a0b3cc722e40f (patch)
tree6a4cdeb7f584f26799413acf19f2c9954bc3c12f /app-vim
parentVersion bump. (diff)
downloadgentoo-2-8d189c322ce4aaba574ea9698e3a0b3cc722e40f.tar.gz
gentoo-2-8d189c322ce4aaba574ea9698e3a0b3cc722e40f.tar.bz2
gentoo-2-8d189c322ce4aaba574ea9698e3a0b3cc722e40f.zip
Version bump. Quoting.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/colorsel/ChangeLog8
-rw-r--r--app-vim/colorsel/colorsel-20040416.ebuild4
-rw-r--r--app-vim/colorsel/colorsel-20051121.ebuild29
3 files changed, 38 insertions, 3 deletions
diff --git a/app-vim/colorsel/ChangeLog b/app-vim/colorsel/ChangeLog
index 4529c6df2f70..9ea0e3c2c1dd 100644
--- a/app-vim/colorsel/ChangeLog
+++ b/app-vim/colorsel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/colorsel
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/colorsel/ChangeLog,v 1.13 2008/04/26 21:18:00 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/colorsel/ChangeLog,v 1.14 2008/09/20 13:59:45 hawking Exp $
+
+*colorsel-20051121 (20 Sep 2008)
+
+ 20 Sep 2008; Ali Polatel <hawking@gentoo.org> colorsel-20040416.ebuild,
+ +colorsel-20051121.ebuild:
+ Version bump. Quoting.
26 Apr 2008; <ricmm@gentoo.org> colorsel-20040416.ebuild:
Drop to ~mips due to unstable deps
diff --git a/app-vim/colorsel/colorsel-20040416.ebuild b/app-vim/colorsel/colorsel-20040416.ebuild
index 96fe9cfb01a7..7a1d6869cf9d 100644
--- a/app-vim/colorsel/colorsel-20040416.ebuild
+++ b/app-vim/colorsel/colorsel-20040416.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/colorsel/colorsel-20040416.ebuild,v 1.13 2008/04/26 21:18:00 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/colorsel/colorsel-20040416.ebuild,v 1.14 2008/09/20 13:59:45 hawking Exp $
inherit vim-plugin
@@ -20,7 +20,7 @@ function src_unpack() {
# nothing in non-GUI mode.
sed -i \
-e "s:echoerr 'Color selector needs GUI':\" mmm, cookies':" \
- ${S}/plugin/${PN}.vim \
+ "${S}"/plugin/${PN}.vim \
|| die "d'oh! sed magic didn't work, call an ambulance"
}
diff --git a/app-vim/colorsel/colorsel-20051121.ebuild b/app-vim/colorsel/colorsel-20051121.ebuild
new file mode 100644
index 000000000000..a9d62ddecbc7
--- /dev/null
+++ b/app-vim/colorsel/colorsel-20051121.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/colorsel/colorsel-20051121.ebuild,v 1.1 2008/09/20 13:59:45 hawking Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: RGB / HSV color selector"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=927"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+RDEPEND=">=app-editors/gvim-6.2"
+
+function src_unpack() {
+ unpack ${A}
+
+ # This plugin tests whether the GUI is present and barfs if not. We
+ # don't want this, since we don't have a gvim-specific plugins
+ # directory. Instead, we'll do a bit of sed-fu to make it just do
+ # nothing in non-GUI mode.
+ sed -i \
+ -e "s:echoerr 'Color selector needs GUI':\" mmm, cookies':" \
+ "${S}"/plugin/${PN}.vim \
+ || die "d'oh! sed magic didn't work, call an ambulance"
+}
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a color selector for vim. Use :ColorSel to start
+the selector. This command is only available when vim is run in GUI mode."