summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-11-14 16:46:03 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-11-14 16:46:03 +0000
commitd960779ad627e0f068dc8ec1e739b480b9380e49 (patch)
tree09fec4a90d0b42469659d957aee2f90528161142 /dev-ada/cbind/cbind-6.0.ebuild
parentStable on sparc wrt #147570 (diff)
downloadgentoo-2-d960779ad627e0f068dc8ec1e739b480b9380e49.tar.gz
gentoo-2-d960779ad627e0f068dc8ec1e739b480b9380e49.tar.bz2
gentoo-2-d960779ad627e0f068dc8ec1e739b480b9380e49.zip
a significant cleanup, repackaged the sources
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'dev-ada/cbind/cbind-6.0.ebuild')
-rw-r--r--dev-ada/cbind/cbind-6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ada/cbind/cbind-6.0.ebuild b/dev-ada/cbind/cbind-6.0.ebuild
new file mode 100644
index 000000000000..bdd3a8799f2a
--- /dev/null
+++ b/dev-ada/cbind/cbind-6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/cbind-6.0.ebuild,v 1.1 2006/11/14 16:46:03 george Exp $
+
+# !NOTE!
+# this is a utility, no libs generated, no reason to do the gnat.eclass dance
+# so, "inherit gnat" should not appear here!
+
+DESCRIPTION="This tool is designed to aid in the creation of Ada bindings to C."
+SRC_URI="http://dev.gentoo.org/~george/src/${P}.tar.bz2"
+HOMEPAGE="http://www.rational.com/"
+LICENSE="GMGPL"
+
+RDEPEND="virtual/gnat"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_compile() {
+ einfo "in dir: $(pwd)"
+ make || die
+}
+
+src_install () {
+ make PREFIX=${D}/usr/ install || die
+ dodoc README DOCS
+}