summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-08-15 11:51:48 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-08-15 11:51:48 +0000
commita5c0c6ea03bee95a76e93b15a45559cedfb79bf4 (patch)
tree3eb2f7ef06eda32a6a4cc38bd9b468c5161742d1 /dev-cpp/Ice
parentstable x86, bug 187681 (diff)
downloadgentoo-2-a5c0c6ea03bee95a76e93b15a45559cedfb79bf4.tar.gz
gentoo-2-a5c0c6ea03bee95a76e93b15a45559cedfb79bf4.tar.bz2
gentoo-2-a5c0c6ea03bee95a76e93b15a45559cedfb79bf4.zip
version bump
(Portage version: 2.1.3.5)
Diffstat (limited to 'dev-cpp/Ice')
-rw-r--r--dev-cpp/Ice/ChangeLog8
-rw-r--r--dev-cpp/Ice/Ice-3.2.1.ebuild65
-rw-r--r--dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch113
-rw-r--r--dev-cpp/Ice/files/digest-Ice-3.2.13
4 files changed, 188 insertions, 1 deletions
diff --git a/dev-cpp/Ice/ChangeLog b/dev-cpp/Ice/ChangeLog
index 4f26dc3fa0ab..477352f994b6 100644
--- a/dev-cpp/Ice/ChangeLog
+++ b/dev-cpp/Ice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/Ice
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.9 2007/08/13 09:03:55 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.10 2007/08/15 11:51:48 caleb Exp $
+
+*Ice-3.2.1 (15 Aug 2007)
+
+ 15 Aug 2007; Caleb Tennis <caleb@gentoo.org>
+ +files/Ice-3.2.1-Makefile.patch, +Ice-3.2.1.ebuild:
+ version bump
12 Aug 2007; Caleb Tennis <caleb@gentoo.org> Ice-3.2.0.ebuild:
Fix ncurses support from bug #175404
diff --git a/dev-cpp/Ice/Ice-3.2.1.ebuild b/dev-cpp/Ice/Ice-3.2.1.ebuild
new file mode 100644
index 000000000000..7483f9b99085
--- /dev/null
+++ b/dev-cpp/Ice/Ice-3.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.2.1.ebuild,v 1.1 2007/08/15 11:51:48 caleb Exp $
+
+inherit eutils
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses test debug"
+
+RDEPEND=">=dev-libs/expat-2.0
+ >=app-arch/bzip2-1.0.3
+ >=dev-libs/openssl-0.9.8
+ =sys-libs/db-4.5.20*"
+
+DEPEND="${RDEPEND}
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ test? ( >=dev-lang/python-2.4 )"
+
+pkg_setup() {
+ if built_with_use sys-libs/db nocxx; then
+ eerror "sys-libs/db must be compiled with C++ support!"
+ eerror "Remove the 'nocxx' use flag and try again."
+ die "Fix use flags and re-emerge"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use ncurses; then
+ sed -i -e "s#^USE_READLINE.*#USE_READLINE ?= yes#g" \
+ ${S}/config/Make.rules || die "Failed to set no readline"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+ make test || die "Test failed"
+}
diff --git a/dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch b/dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch
new file mode 100644
index 000000000000..d7df955c196c
--- /dev/null
+++ b/dev-cpp/Ice/files/Ice-3.2.1-Makefile.patch
@@ -0,0 +1,113 @@
+--- config/Make.rules.orig 2007-03-13 09:07:05.000000000 -0400
++++ config/Make.rules 2007-03-13 09:07:13.000000000 -0400
+@@ -11,13 +11,13 @@
+ # Select an installation base directory. The directory will be created
+ # if it does not exist.
+ #
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= /$(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
+@@ -125,9 +125,10 @@
+ install_bindir = $(prefix)/bin
+
+ install_includedir = $(prefix)/include
+-install_slicedir = $(prefix)/slice
+-install_schemadir = $(prefix)/schema
+-install_docdir = $(prefix)/doc
++install_slicedir = $(prefix)/share/Ice/slice
++install_schemadir = $(prefix)/share/Ice/schema
++install_configdir = $(prefix)/share/Ice/config
++install_docdir = $(prefix)/share/doc/Ice-$(VERSION)
+
+ INSTALL = cp -fp
+ INSTALL_PROGRAM = ${INSTALL}
+@@ -179,18 +180,8 @@
+ BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
+ BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
+
+-ifneq ($(DB_HOME),)
+- DB_FLAGS = -I$(DB_HOME)/include
+- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
+- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
+-else
+- ifeq ($(shell if [ -d /usr/include/db45 -a -d /usr/$(libsubdir)/db45 ] ; then echo yes; fi), yes)
+- DB_FLAGS = -I/usr/include/db45
+- DB_LIBS = -L/usr/$(libsubdir)/db45 -ldb_cxx
+- else
+- DB_LIBS = -ldb_cxx
+- endif
+-endif
++DB_FLAGS = -I/usr/include/db4.5
++DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.5
+
+ EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
+ EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
+--- Makefile.orig 2007-03-13 09:07:20.000000000 -0400
++++ Makefile 2007-03-13 09:08:44.000000000 -0400
+@@ -11,15 +11,15 @@
+
+ include $(top_srcdir)/config/Make.rules
+
+-SUBDIRS = config src include test demo slice doc
++SUBDIRS = config src include slice doc
+
+-INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
++INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir) $(install_configdir)
+
+ install::
+ @if test ! -d $(prefix) ; \
+ then \
+ echo "Creating $(prefix)..." ; \
+- $(call mkdir,$(prefix)) ; \
++ mkdir -p $(prefix) ; \
+ fi
+ ifneq ($(embedded_runpath_prefix),)
+ @if test -h $(embedded_runpath_prefix) ; \
+@@ -55,8 +55,8 @@
+ then \
+ ( cd doc && $(MAKE) install ) || exit 1 ; \
+ fi
+- $(call installdata,ICE_LICENSE,$(prefix))
+- $(call installdata,LICENSE,$(prefix))
++ $(call installdata,ICE_LICENSE,$(install_docdir))
++ $(call installdata,LICENSE,$(install_docdir))
+
+ clean::
+ @if test -d doc ; \
+@@ -65,4 +65,5 @@
+ fi
+
+ test::
++ @( cd test && $(MAKE) ) || exit 1
+ @python $(top_srcdir)/allTests.py
+--- config/Makefile.orig 2007-03-13 10:05:05.000000000 -0400
++++ config/Makefile 2007-03-13 10:05:43.000000000 -0400
+@@ -15,14 +15,9 @@
+ echo ""
+
+ install::
+- @if test ! -d $(prefix)/config ; \
+- then \
+- echo "Creating $(prefix)/config..." ; \
+- $(call mkdir,$(prefix)/config) ; \
+- fi
+- $(call installdata,templates.xml,$(prefix)/config)
+- $(call installdata,convertssl.py,$(prefix)/config)
+- $(call installdata,upgradeicegrid.py,$(prefix)/config)
+- $(call installdata,upgradeicestorm.py,$(prefix)/config)
+- $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/config)
++ $(call installdata,templates.xml,$(install_configdir))
++ $(call installdata,convertssl.py,$(install_configdir))
++ $(call installdata,upgradeicegrid.py,$(install_configdir))
++ $(call installdata,upgradeicestorm.py,$(install_configdir))
++ $(call installdata,icegrid-slice.3.1.ice.gz,$(install_configdir))
+
diff --git a/dev-cpp/Ice/files/digest-Ice-3.2.1 b/dev-cpp/Ice/files/digest-Ice-3.2.1
new file mode 100644
index 000000000000..ec335a19819b
--- /dev/null
+++ b/dev-cpp/Ice/files/digest-Ice-3.2.1
@@ -0,0 +1,3 @@
+MD5 77bb04788747d0f4f7ef35f7a4c2800f Ice-3.2.1.tar.gz 2090576
+RMD160 c3394486ba13e94c2491b0dc48dc19c3e7565ecd Ice-3.2.1.tar.gz 2090576
+SHA256 bd24cfe0296d81e2b04ea8d97b32a4f13fdd949d0f038f4c7e0922b395075149 Ice-3.2.1.tar.gz 2090576