summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-09-02 17:14:03 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-09-02 17:14:03 +0000
commit2c30462b641633623671ac9eb592fd2665265c34 (patch)
tree01997f4ab850cf8923280c82a38efcf4ae84bb69 /dev-cpp/bakery/bakery-2.3.15.ebuild
parentCleanup of eautoreconf call to use the new style AT_M4DIR variable. Use at le... (diff)
downloadgentoo-2-2c30462b641633623671ac9eb592fd2665265c34.tar.gz
gentoo-2-2c30462b641633623671ac9eb592fd2665265c34.tar.bz2
gentoo-2-2c30462b641633623671ac9eb592fd2665265c34.zip
New Package. Bakery is a C++ Framework for creating GNOME applications using gtkmm
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-cpp/bakery/bakery-2.3.15.ebuild')
-rw-r--r--dev-cpp/bakery/bakery-2.3.15.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/bakery/bakery-2.3.15.ebuild b/dev-cpp/bakery/bakery-2.3.15.ebuild
new file mode 100644
index 000000000000..c928ae1467fe
--- /dev/null
+++ b/dev-cpp/bakery/bakery-2.3.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/bakery/bakery-2.3.15.ebuild,v 1.1 2005/09/02 17:14:03 metalgod Exp $
+
+inherit gnome2
+
+DESCRIPTION="Bakery is a C++ Framework for creating GNOME applications using
+gtkmm."
+HOMEPAGE="http://bakery.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/gtkmm-2.2
+ >=dev-cpp/libxmlpp-1.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+ use doc && dohtml docs/*.html docs/reference/*.html
+}