summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-06-10 14:40:41 +0000
committerRémi Cardona <remi@gentoo.org>2008-06-10 14:40:41 +0000
commit7b16ac2272215da58fac15e32b7142a988701f2f (patch)
tree924845c95ba6c3daa556f15d01a0e5f5ad843438 /dev-cpp/cairomm/cairomm-1.6.0.ebuild
parentupdate to newer trunk revision. sync ebuild features to 0.21 (diff)
downloadgentoo-2-7b16ac2272215da58fac15e32b7142a988701f2f.tar.gz
gentoo-2-7b16ac2272215da58fac15e32b7142a988701f2f.tar.bz2
gentoo-2-7b16ac2272215da58fac15e32b7142a988701f2f.zip
dev-cpp/cairomm: bump to 1.6.0
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-cpp/cairomm/cairomm-1.6.0.ebuild')
-rw-r--r--dev-cpp/cairomm/cairomm-1.6.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-cpp/cairomm/cairomm-1.6.0.ebuild b/dev-cpp/cairomm/cairomm-1.6.0.ebuild
new file mode 100644
index 000000000000..7d6dd4e5691d
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.6.0.ebuild,v 1.1 2008/06/10 14:40:41 remi Exp $
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=x11-libs/cairo-1.5.14"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable doc docs) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use examples; then
+ dodoc examples
+ fi
+}