summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-05-26 10:04:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-05-26 10:04:49 +0000
commitb3e0ca16e76f2f368f9e63ccad3fe8f57dc774da (patch)
tree69fe837ccc743670727f89ee9b9f36c25bedd0e0 /dev-cpp/clucene/clucene-9999.ebuild
parentversion bump (#313557) (diff)
downloadgentoo-2-b3e0ca16e76f2f368f9e63ccad3fe8f57dc774da.tar.gz
gentoo-2-b3e0ca16e76f2f368f9e63ccad3fe8f57dc774da.tar.bz2
gentoo-2-b3e0ca16e76f2f368f9e63ccad3fe8f57dc774da.zip
Update clucene-0.9.21b-r1 to be eapi3 and use base eclass. Add live ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/clucene/clucene-9999.ebuild')
-rw-r--r--dev-cpp/clucene/clucene-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-cpp/clucene/clucene-9999.ebuild b/dev-cpp/clucene/clucene-9999.ebuild
new file mode 100644
index 000000000000..e0fdd2a123b7
--- /dev/null
+++ b/dev-cpp/clucene/clucene-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/clucene-9999.ebuild,v 1.1 2010/05/26 10:04:49 scarabeus Exp $
+
+EAPI="3"
+
+MY_P=${PN}-core-${PV}
+inherit git base cmake-utils
+
+DESCRIPTION="High-performance, full-featured text search engine based off of lucene in C++"
+HOMEPAGE="http://clucene.sourceforge.net/"
+EGIT_REPO_URI="git://${PN}.git.sourceforge.net/gitroot/${PN}/${PN}"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="1"
+KEYWORDS=""
+IUSE="debug doc static-libs threads"
+
+RDEPEND=""
+DEPEND="${DEPEND}
+ doc? ( >=app-doc/doxygen-1.4.2 )
+"
+
+src_unpack() {
+ git_src_unpack
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DENABLE_ASCII_MODE=OFF"
+ "-DENABLE_PACKAGING=OFF"
+ $(cmake-utils_use_enable debug)
+ $(cmake-utils_use_enable doc CLDOCS)
+ $(cmake-utils_use_build static-libs STATIC_LIBRARIES)
+ $(cmake-utils_use_disable threads MULTITHREADING)
+ )
+
+ cmake-utils_src_configure
+}