summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-03-07 15:13:55 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-03-07 15:13:55 +0000
commit361e0c40c34f2c07cb182e20eaa0654d7308fb41 (patch)
tree268cd0eed887a285575a4cc46f719242778b1401 /dev-cpp/commoncpp2
parentRemove built_with_use calls on boost by depending on new enough versions that... (diff)
downloadgentoo-2-361e0c40c34f2c07cb182e20eaa0654d7308fb41.tar.gz
gentoo-2-361e0c40c34f2c07cb182e20eaa0654d7308fb41.tar.bz2
gentoo-2-361e0c40c34f2c07cb182e20eaa0654d7308fb41.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'dev-cpp/commoncpp2')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog8
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild74
-rw-r--r--dev-cpp/commoncpp2/files/1.6.3-autoconf.patch12
3 files changed, 93 insertions, 1 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 053d0bf4d329..a78ad916331a 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.43 2009/03/07 14:57:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.44 2009/03/07 15:13:55 armin76 Exp $
+
+*commoncpp2-1.6.3 (07 Mar 2009)
+
+ 07 Mar 2009; Raúl Porcel <armin76@gentoo.org>
+ +files/1.6.3-autoconf.patch, +commoncpp2-1.6.3.ebuild:
+ Version bump
07 Mar 2009; Raúl Porcel <armin76@gentoo.org>
+files/1.6.2-configure_detect_netfilter.patch, commoncpp2-1.6.1.ebuild,
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
new file mode 100644
index 000000000000..03a86e581f8b
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild,v 1.1 2009/03/07 15:13:55 armin76 Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commoncpp/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc examples ipv6 gnutls"
+
+RDEPEND="gnutls? ( dev-libs/libgcrypt
+ net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ sys-libs/zlib"
+DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/1.6.1-gcc42_atomicity.patch"
+ epatch "${FILESDIR}/${PV}-autoconf.patch"
+ epatch "${FILESDIR}/1.6.2-configure_detect_netfilter.patch" # bug 236177
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ use doc || \
+ sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
+
+ local myconf
+ use gnutls || myconf="--with-openssl"
+
+ econf \
+ $(use_enable debug) \
+ $(use_with ipv6 ) \
+ ${myconf} || die "econf failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ cd demo
+ doins *.cpp *.h *.xml README
+ fi
+}
+
+pkg_postinst() {
+ ewarn "There's a change in the ABI between version 1.5.x and 1.6.x, please"
+ ewarn "run the following command to find broken packages and rebuild them:"
+ ewarn " revdep-rebuild --library=libccext2-1.5.so"
+}
+
+# Some of the tests hang forever
+#src_test() {
+# cd "${S}/tests"
+# emake || die "emake tests failed"
+# ./test.sh || die "tests failed"
+#}
diff --git a/dev-cpp/commoncpp2/files/1.6.3-autoconf.patch b/dev-cpp/commoncpp2/files/1.6.3-autoconf.patch
new file mode 100644
index 000000000000..a94ac91d8b03
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.6.3-autoconf.patch
@@ -0,0 +1,12 @@
+diff -ur commoncpp2-1.6.3.orig/configure.ac commoncpp2-1.6.3/configure.ac
+--- commoncpp2-1.6.3.orig/configure.ac 2009-03-07 16:03:44.000000000 +0100
++++ commoncpp2-1.6.3/configure.ac 2009-03-07 16:04:25.000000000 +0100
+@@ -10,6 +10,8 @@
+
+ AC_INIT(src/thread.cpp)
+
++m4_pattern_allow([^LT_VERSION$])
++
+ VERSION="1.6.3"
+ LT_RELEASE="1.6"
+ LT_VERSION="0:2"