summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-09-19 12:04:33 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-09-19 12:04:33 +0000
commit58339eb7c69eb481c2309ec4ac8b745ad8635f1e (patch)
treeeda9d75ee96c44d5e8d4f96c5efd76e129261c17 /dev-cpp/gconfmm/gconfmm-2.12.0.ebuild
parentNew USE flag selinux now depends on the selinux-ftpd policy, wrt #106355. (diff)
downloadgentoo-2-58339eb7c69eb481c2309ec4ac8b745ad8635f1e.tar.gz
gentoo-2-58339eb7c69eb481c2309ec4ac8b745ad8635f1e.tar.bz2
gentoo-2-58339eb7c69eb481c2309ec4ac8b745ad8635f1e.zip
Version bump.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-cpp/gconfmm/gconfmm-2.12.0.ebuild')
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.12.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-cpp/gconfmm/gconfmm-2.12.0.ebuild b/dev-cpp/gconfmm/gconfmm-2.12.0.ebuild
new file mode 100644
index 000000000000..5d650d2214bd
--- /dev/null
+++ b/dev-cpp/gconfmm/gconfmm-2.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/gconfmm-2.12.0.ebuild,v 1.1 2005/09/19 12:04:33 ka0ttic Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="C++ bindings for GConf"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~hppa"
+IUSE=""
+
+RDEPEND=">=gnome-base/gconf-2.4
+ >=dev-cpp/glibmm-2.4
+ >=dev-cpp/gtkmm-2.4"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
+
+src_compile() {
+ if useq amd64 || useq ppc64; then
+ aclocal -I scripts
+ libtoolize --force --copy
+ automake -c -f
+ autoconf
+ fi
+
+ gnome2_src_compile
+}