summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-11 20:35:50 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-11 20:35:50 +0000
commit0bab8022daf90e47af12a27815a2e813f5ac2564 (patch)
treebabedaedce75d0f1b4f6f436c4fbcc9324cdfbd9 /dev-cpp/gmock
parentRemove old ebuild (diff)
downloadgentoo-2-0bab8022daf90e47af12a27815a2e813f5ac2564.tar.gz
gentoo-2-0bab8022daf90e47af12a27815a2e813f5ac2564.tar.bz2
gentoo-2-0bab8022daf90e47af12a27815a2e813f5ac2564.zip
Call elibtoolize to fix cross-compiling relink issues.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gmock')
-rw-r--r--dev-cpp/gmock/ChangeLog6
-rw-r--r--dev-cpp/gmock/gmock-1.4.0.ebuild8
-rw-r--r--dev-cpp/gmock/gmock-1.5.0.ebuild8
3 files changed, 19 insertions, 3 deletions
diff --git a/dev-cpp/gmock/ChangeLog b/dev-cpp/gmock/ChangeLog
index 787f241eac7d..f8f7c7fdffe9 100644
--- a/dev-cpp/gmock/ChangeLog
+++ b/dev-cpp/gmock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/gmock
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/ChangeLog,v 1.3 2011/11/11 20:21:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/ChangeLog,v 1.4 2011/11/11 20:35:50 vapier Exp $
+
+ 11 Nov 2011; Mike Frysinger <vapier@gentoo.org> gmock-1.4.0.ebuild,
+ gmock-1.5.0.ebuild:
+ Call elibtoolize to fix cross-compiling relink issues.
*gmock-1.4.0 (11 Nov 2011)
diff --git a/dev-cpp/gmock/gmock-1.4.0.ebuild b/dev-cpp/gmock/gmock-1.4.0.ebuild
index fb7017a9388d..3fe4fa8d3801 100644
--- a/dev-cpp/gmock/gmock-1.4.0.ebuild
+++ b/dev-cpp/gmock/gmock-1.4.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.4.0.ebuild,v 1.1 2011/11/11 20:21:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.4.0.ebuild,v 1.2 2011/11/11 20:35:50 vapier Exp $
EAPI="4"
+inherit libtool
+
DESCRIPTION="Google's C++ mocking framework"
HOMEPAGE="http://code.google.com/p/googlemock/"
SRC_URI="http://googlemock.googlecode.com/files/${P}.tar.bz2"
@@ -22,6 +24,10 @@ src_unpack() {
rm -r "${S}"/gtest/Makefile* || die
}
+src_prepare() {
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}
diff --git a/dev-cpp/gmock/gmock-1.5.0.ebuild b/dev-cpp/gmock/gmock-1.5.0.ebuild
index 350b594c7ac6..d02b8873aed4 100644
--- a/dev-cpp/gmock/gmock-1.5.0.ebuild
+++ b/dev-cpp/gmock/gmock-1.5.0.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.5.0.ebuild,v 1.2 2011/11/11 20:12:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.5.0.ebuild,v 1.3 2011/11/11 20:35:50 vapier Exp $
EAPI="4"
+inherit libtool
+
DESCRIPTION="Google's C++ mocking framework"
HOMEPAGE="http://code.google.com/p/googlemock/"
SRC_URI="http://googlemock.googlecode.com/files/${P}.tar.bz2"
@@ -22,6 +24,10 @@ src_unpack() {
rm -r "${S}"/gtest/Makefile* || die
}
+src_prepare() {
+ elibtoolize
+}
+
src_configure() {
econf $(use_enable static-libs static)
}