summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-10-20 05:55:48 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-10-20 05:55:48 +0000
commitabc408690465cb7c3afebcc7ea6beb1e2e8ddf41 (patch)
treedaf8b4fc82f155105877ceafdbe2522865db0905 /dev-cpp/libcult/libcult-1.4.6.ebuild
parentInitial commit (ebuild written by me), needed for xsd and the required librar... (diff)
downloadgentoo-2-abc408690465cb7c3afebcc7ea6beb1e2e8ddf41.tar.gz
gentoo-2-abc408690465cb7c3afebcc7ea6beb1e2e8ddf41.tar.bz2
gentoo-2-abc408690465cb7c3afebcc7ea6beb1e2e8ddf41.zip
Initial commit (ebuild written by me), needed for xsd and the required libraries.
(Portage version: 2.2_rc94/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/libcult/libcult-1.4.6.ebuild')
-rw-r--r--dev-cpp/libcult/libcult-1.4.6.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-cpp/libcult/libcult-1.4.6.ebuild b/dev-cpp/libcult/libcult-1.4.6.ebuild
new file mode 100644
index 000000000000..e0ef1f1b9734
--- /dev/null
+++ b/dev-cpp/libcult/libcult-1.4.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcult/libcult-1.4.6.ebuild,v 1.1 2010/10/20 05:55:48 dev-zero Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs versionator
+
+DESCRIPTION="A collection of C++ libraries"
+HOMEPAGE="http://kolpackov.net/projects/libcult/"
+SRC_URI="ftp://kolpackov.net/pub/projects/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-util/build:0.3"
+RDEPEND=""
+
+src_prepare() {
+ # never build the examples
+ sed -i \
+ -e 's| $(out_base)/examples/[[:alnum:]\.]*||' \
+ -e '/examples\/makefile/d' \
+ makefile || die "sed failed"
+}
+
+src_configure() {
+ mkdir -p build/{cxx/gnu,ld}
+
+ cat >> build/configuration-dynamic.make <<- EOF
+cult_dr := y
+cult_threads := y
+cult_network := y
+ EOF
+
+ cat >> build/cxx/configuration-dynamic.make <<- EOF
+cxx_id := gnu
+cxx_optimize := n
+cxx_debug := n
+cxx_rpath := n
+cxx_pp_extra_options :=
+cxx_extra_options := ${CXXFLAGS}
+cxx_ld_extra_options := ${LDFLAGS}
+cxx_extra_libs :=
+cxx_extra_lib_paths :=
+ EOF
+
+ cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF
+cxx_gnu := $(tc-getCXX)
+cxx_gnu_libraries :=
+cxx_gnu_optimization_options :=
+ EOF
+
+ cat >> build/ld/configuration-lib-dynamic.make <<- EOF
+ld_lib_type := shared
+ EOF
+}
+
+src_install() {
+ dolib.so cult/libcult.so
+
+ find cult -iname "*.cxx" \
+ -o -iname "makefile" \
+ -o -iname "*.o" -o -iname "*.d" \
+ -o -iname "*.m4" -o -iname "*.l" \
+ -o -iname "*.cpp-options" -o -iname "*.so" | xargs rm -f
+ rm -rf cult/arch
+
+ insinto /usr/include
+ doins -r cult
+
+ dodoc NEWS README documentation/[[:upper:]]*
+ dohtml -A xhtml -r documentation/*
+
+ if use examples ; then
+ find examples -name makefile -delete
+ # preserving symlinks in the examples
+ cp -dpR examples "${D}/usr/share/doc/${PF}"
+ fi
+}