summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-04-21 21:04:35 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-04-21 21:04:35 +0000
commitd9a74cfefa3fbf31c9712a8374da3d22d9692ac8 (patch)
tree29adb0c2ffa7aaaa9407515f3e9312e5bca52b3d /dev-cpp/tbb
parentFix SCROLLKEEPER_UPDATE variable documentation. (diff)
downloadgentoo-2-d9a74cfefa3fbf31c9712a8374da3d22d9692ac8.tar.gz
gentoo-2-d9a74cfefa3fbf31c9712a8374da3d22d9692ac8.tar.bz2
gentoo-2-d9a74cfefa3fbf31c9712a8374da3d22d9692ac8.zip
Version bump + gcc 4.6 patch for tests
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/ChangeLog11
-rw-r--r--dev-cpp/tbb/files/tbb-3.0.056-tests.patch15
-rw-r--r--dev-cpp/tbb/files/tbb-3.0.174-gcc46.patch33
-rw-r--r--dev-cpp/tbb/tbb-3.0.104.ebuild94
-rw-r--r--dev-cpp/tbb/tbb-3.0.174.ebuild (renamed from dev-cpp/tbb/tbb-3.0.131.ebuild)9
5 files changed, 47 insertions, 115 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index e0bdefc6d4df..9e0ad02c2d9c 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/tbb
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.10 2010/12/25 18:44:49 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.11 2011/04/21 21:04:35 bicatali Exp $
+
+*tbb-3.0.174 (21 Apr 2011)
+
+ 21 Apr 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ -files/tbb-3.0.056-tests.patch, -tbb-3.0.104.ebuild, -tbb-3.0.131.ebuild,
+ +tbb-3.0.174.ebuild, +files/tbb-3.0.174-gcc46.patch:
+ Version bump + gcc 4.6 patch for tests
*tbb-3.0.131 (25 Dec 2010)
diff --git a/dev-cpp/tbb/files/tbb-3.0.056-tests.patch b/dev-cpp/tbb/files/tbb-3.0.056-tests.patch
deleted file mode 100644
index 183f8c83e440..000000000000
--- a/dev-cpp/tbb/files/tbb-3.0.056-tests.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- build/Makefile.test.orig 2010-08-04 23:37:11.000000000 +0100
-+++ build/Makefile.test 2010-08-04 23:38:11.000000000 +0100
-@@ -191,10 +191,10 @@
- # If a component Y uses component X, then tests for Y should come after tests for X.
- # Note that usually run_cmd is empty, and tests run directly
- test_tbb_plain: $(TEST_PREREQUISITE) $(TASK_CPP_DIRECTLY_INCLUDED) $(TEST_TBB_PLAIN.EXE)
-- $(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
-+ #$(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
- # Checking TBB version first to make sure the following testing has anything in it
- $(run_cmd) ./test_assembly.$(TEST_EXT) $(args)
-- $(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
-+ #$(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
- # Yes, 4:8 is intended on the next line.
- $(run_cmd) ./test_yield.$(TEST_EXT) $(args) 4:8
- $(run_cmd) ./test_handle_perror.$(TEST_EXT) $(args)
diff --git a/dev-cpp/tbb/files/tbb-3.0.174-gcc46.patch b/dev-cpp/tbb/files/tbb-3.0.174-gcc46.patch
new file mode 100644
index 000000000000..a2b0ac54c512
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-3.0.174-gcc46.patch
@@ -0,0 +1,33 @@
+diff -Nur tbb30_174oss.orig/src/test/test_condition_variable.h tbb30_174oss/src/test/test_condition_variable.h
+--- tbb30_174oss.orig/src/test/test_condition_variable.h 2011-04-21 21:57:36.000000000 +0100
++++ tbb30_174oss/src/test/test_condition_variable.h 2011-04-21 21:58:57.000000000 +0100
+@@ -189,7 +189,7 @@
+ Counter<M> counter;
+ counter.value = 0;
+ Order = 0;
+- const long test_size = 100000;
++ const size_t test_size = 100000;
+ NativeParallelFor( nthread, WorkForLocks<Counter<M>, test_size>(counter) );
+
+ if( counter.value!=2*test_size )
+diff -Nur tbb30_174oss.orig/src/test/test_mutex_native_threads.cpp tbb30_174oss/src/test/test_mutex_native_threads.cpp
+--- tbb30_174oss.orig/src/test/test_mutex_native_threads.cpp 2011-04-21 21:57:36.000000000 +0100
++++ tbb30_174oss/src/test/test_mutex_native_threads.cpp 2011-04-21 21:58:57.000000000 +0100
+@@ -182,7 +182,7 @@
+ Counter<M> counter;
+ counter.value = 0;
+ Order = 0;
+- const long test_size = 100000;
++ const size_t test_size = 100000;
+ tbb::tick_count t0 = tbb::tick_count::now();
+ NativeParallelFor( nthread, Work<Counter<M>, test_size>(counter) );
+ tbb::tick_count t1 = tbb::tick_count::now();
+@@ -199,7 +199,7 @@
+ REMARK("testing %s\n",mutex_name);
+ Invariant<M,8> invariant(mutex_name);
+ Order = 0;
+- static const long test_size = 1000000;
++ static const size_t test_size = 1000000;
+ tbb::tick_count t0 = tbb::tick_count::now();
+ NativeParallelFor( nthread, Work<Invariant<M,8>, test_size>(invariant) );
+ tbb::tick_count t1 = tbb::tick_count::now();
diff --git a/dev-cpp/tbb/tbb-3.0.104.ebuild b/dev-cpp/tbb/tbb-3.0.104.ebuild
deleted file mode 100644
index 1344084be835..000000000000
--- a/dev-cpp/tbb/tbb-3.0.104.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.104.ebuild,v 1.2 2010/11/19 06:11:07 bicatali Exp $
-
-EAPI=3
-inherit eutils versionator toolchain-funcs
-# url number
-MYU="78/160"
-# release update
-MYR="%20update%20"3
-
-PV1="$(get_version_component_range 1)"
-PV2="$(get_version_component_range 2)"
-PV3="$(get_version_component_range 3)"
-MYP="${PN}${PV1}${PV2}_${PV3}oss"
-
-DESCRIPTION="High level abstract threading library"
-HOMEPAGE="http://www.threadingbuildingblocks.org/"
-SRC_URI="http://www.threadingbuildingblocks.org/uploads/${MYU}/${PV1}.${PV2}${MYR}/${MYP}_src.tgz"
-LICENSE="GPL-2-with-exceptions"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc examples"
-
-DEPEND="!<=dev-cpp/tbb-2.1.016"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MYP}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-tests.patch
- # use fully qualified compilers. do not force pentium4 for x86 users
- local CC="$(tc-getCC)"
- sed -i \
- -e "s/-O2/${CXXFLAGS}/g" \
- -e 's/^\(CPLUS = \)g++ $/\1'"$(tc-getCXX)/" \
- -e 's/^\(CONLY = \)gcc$/\1'"${CC}/" \
- -e 's/\(shell \)gcc\( --version\)/\1'"${CC}"'\2/' \
- -e '/CPLUS_FLAGS +=/s/-march=pentium4//' \
- build/*.inc || die
- # - Strip the $(shell ... >$(NUL) 2>$(NUL)) wrapping, leaving just the
- # actual command.
- # - Force generation of version_string.tmp immediately after the directory
- # is created. This avoids a race when the user builds tbb and tbbmalloc
- # concurrently. The choice of Makefile.tbb (instead of
- # Makefile.tbbmalloc) is arbitrary.
- sed -i \
- -e 's/^\t\$(shell \(.*\) >\$(NUL) 2>\$(NUL))\s*/\t\1/' \
- -e 's!^\t@echo Created \$(work_dir)_\(debug\|release\).*$!&\n\t$(MAKE) -C "$(work_dir)_\1" -r -f $(tbb_root)/build/Makefile.tbb cfg=\1 tbb_root=$(tbb_root) version_string.tmp!' \
- src/Makefile || die
-}
-
-src_compile() {
- if [[ $(tc-getCXX) == *g++ ]]; then
- myconf="compiler=gcc"
- elif [[ $(tc-getCXX) == *ic*c ]]; then
- myconf="compiler=icc"
- fi
- local ccconf="${myconf}"
- if use debug || use examples; then
- ccconf="${ccconf} tbb_debug tbbmalloc_debug"
- fi
- emake -C src ${ccconf} tbb_release tbbmalloc_release || die "emake failed"
-}
-
-src_test() {
- local ccconf="${myconf}"
- if use debug || use examples; then
- ${ccconf}="${myconf} test_debug tbbmalloc_test_debug"
- fi
- emake -C src ${ccconf} test_release || die "emake test failed"
-}
-
-src_install(){
- for l in $(find build -name lib\*.so.\*); do
- dolib.so ${l} || die
- local bl=$(basename ${l})
- dosym ${bl} /usr/$(get_libdir)/${bl%.*}
- done
- insinto /usr
- doins -r include || die
-
- dodoc README CHANGES doc/Release_Notes.txt
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins -r doc/html || die
- fi
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples/build
- doins build/*.inc || die
- insinto /usr/share/doc/${PF}/examples
- doins -r examples || die
- fi
-}
diff --git a/dev-cpp/tbb/tbb-3.0.131.ebuild b/dev-cpp/tbb/tbb-3.0.174.ebuild
index 539aeb244b4b..ed0c806dc01c 100644
--- a/dev-cpp/tbb/tbb-3.0.131.ebuild
+++ b/dev-cpp/tbb/tbb-3.0.174.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.131.ebuild,v 1.1 2010/12/25 18:44:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.174.ebuild,v 1.1 2011/04/21 21:04:35 bicatali Exp $
EAPI=3
inherit eutils versionator toolchain-funcs
# those 2 below change pretty much every release
# url number
-MYU="78/165"
+MYU="78/166"
# release update
-MYR="%20Update%20"5
+MYR="%20update%20"6
PV1="$(get_version_component_range 1)"
PV2="$(get_version_component_range 2)"
@@ -31,6 +31,7 @@ S="${WORKDIR}/${MYP}"
src_prepare() {
epatch "${FILESDIR}"/${PN}-3.0.104-tests.patch
+ epatch "${FILESDIR}"/${PN}-3.0.174-gcc46.patch
# use fully qualified compilers. do not force pentium4 for x86 users
local CC="$(tc-getCC)"
sed -i \