summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2004-08-16 02:02:40 +0000
committerIlya Volynets <iluxa@gentoo.org>2004-08-16 02:02:40 +0000
commitcf261a341a1a25a9695f409279fb2d8861369601 (patch)
treee194419c15c2d785271e147ad3c3f7c366565f9e /dev-cpp
parentVersion bump. No gtk or qt support at the moment, neither work (Manifest reco... (diff)
downloadgentoo-2-cf261a341a1a25a9695f409279fb2d8861369601.tar.gz
gentoo-2-cf261a341a1a25a9695f409279fb2d8861369601.tar.bz2
gentoo-2-cf261a341a1a25a9695f409279fb2d8861369601.zip
Added SPTK ebuild contibuted by Alexey Parshin
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog14
-rw-r--r--dev-cpp/sptk/Manifest2
-rw-r--r--dev-cpp/sptk/files/digest-sptk-2.21
-rw-r--r--dev-cpp/sptk/metadata.xml9
-rw-r--r--dev-cpp/sptk/sptk-2.2.ebuild44
5 files changed, 70 insertions, 0 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
new file mode 100644
index 000000000000..8d133243ca63
--- /dev/null
+++ b/dev-cpp/sptk/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-cpp/sptk
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.1 2004/08/16 02:02:40 iluxa Exp $
+
+*sptk-2.2 (15 Aug 2004)
+
+ 15 Aug 2004 Ilya A. Volynets-Evenbakh <iluxa@gentoo.org> ChangeLog :
+ Added sptk - ebuild contributed by Alexey Parshin <alexeyp@tts-sf.com>
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-cpp/sptk/Manifest b/dev-cpp/sptk/Manifest
new file mode 100644
index 000000000000..b022272773b8
--- /dev/null
+++ b/dev-cpp/sptk/Manifest
@@ -0,0 +1,2 @@
+MD5 fe4fb70b810d3a02d6e8c76a067d79b2 sptk-2.2.ebuild 1001
+MD5 5a9228da983dfa643e2f36da4772303c files/digest-sptk-2.2 58
diff --git a/dev-cpp/sptk/files/digest-sptk-2.2 b/dev-cpp/sptk/files/digest-sptk-2.2
new file mode 100644
index 000000000000..7273a7cc72fb
--- /dev/null
+++ b/dev-cpp/sptk/files/digest-sptk-2.2
@@ -0,0 +1 @@
+MD5 ea0d96457b32f9ffd751ea46d53db039 sptk-2.2.tgz 4730086
diff --git a/dev-cpp/sptk/metadata.xml b/dev-cpp/sptk/metadata.xml
new file mode 100644
index 000000000000..75e84e547665
--- /dev/null
+++ b/dev-cpp/sptk/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+<maintainer>
+ <email>desktop-misc@gentoo.org</email>
+</maintainer>
+<longdescription>C++ user interface toolkit for X with ODBC, IMAP, Excel support.</longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/sptk/sptk-2.2.ebuild b/dev-cpp/sptk/sptk-2.2.ebuild
new file mode 100644
index 000000000000..0e39790c24bd
--- /dev/null
+++ b/dev-cpp/sptk/sptk-2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-2.2.ebuild,v 1.1 2004/08/16 02:02:40 iluxa Exp $
+
+IUSE="fltk odbc"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://sptk.tts-sf.com/sptk-${PV}.tgz"
+HOMEPAGE="http://sptk.tts-sf.com"
+
+SLOT="2"
+LICENSE="FLTK | GPL-2"
+KEYWORDS="-* ~x86 ~sparc ~mips"
+
+DEPEND="fltk? ( x11-libs/fltk )
+ odbc? ( >=dev-db/unixODBC-2.2.8 )"
+
+src_compile() {
+
+ local myconf
+ myconf="--enable-shared"
+
+ use odbc || myconf="${myconf} --disable-odbc" #default enabled
+ use fltk || myconf="${myconf} --disable-fltk"
+
+ econf \
+ --prefix=/usr \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ einstall \
+ includedir=${D}/usr/include/sptk \
+ libdir=${D}/usr/lib || die "Installation Failed"
+
+ dodoc CHANGES COPYING README
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/sptk/* ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/share/doc/sptk
+}