summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-02-17 21:25:36 +0000
committerJohannes Huber <johu@gentoo.org>2015-02-17 21:25:36 +0000
commitf359bb23b986b89101da4c43bc2a838b873f567f (patch)
tree42d6194c778b1fb2dab99a3978ed2479bbc0e963 /dev-cpp
parentarm stable, bug #536790 (diff)
downloadgentoo-2-f359bb23b986b89101da4c43bc2a838b873f567f.tar.gz
gentoo-2-f359bb23b986b89101da4c43bc2a838b873f567f.tar.bz2
gentoo-2-f359bb23b986b89101da4c43bc2a838b873f567f.zip
Version bump.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/lucene++/ChangeLog8
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7.ebuild35
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-cpp/lucene++/ChangeLog b/dev-cpp/lucene++/ChangeLog
index e0bed147a89e..5a3e75a69944 100644
--- a/dev-cpp/lucene++/ChangeLog
+++ b/dev-cpp/lucene++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/lucene++
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/lucene++/ChangeLog,v 1.1 2015/01/10 13:37:49 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/lucene++/ChangeLog,v 1.2 2015/02/17 21:25:36 johu Exp $
+
+*lucene++-3.0.7 (17 Feb 2015)
+
+ 17 Feb 2015; Johannes Huber <johu@gentoo.org> +lucene++-3.0.7.ebuild:
+ Version bump.
*lucene++-3.0.6 (10 Jan 2015)
@@ -9,4 +14,3 @@
+files/lucene++-3.0.6-disable-tests.patch,
+files/lucene++-3.0.6-fix-installing-headers.patch, +metadata.xml:
New package. Ebuild by Nikoli <nikoli@gmx.us>. Bug #528550.
-
diff --git a/dev-cpp/lucene++/lucene++-3.0.7.ebuild b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
new file mode 100644
index 000000000000..c203cb392216
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/lucene++/lucene++-3.0.7.ebuild,v 1.1 2015/02/17 21:25:36 johu Exp $
+
+EAPI=5
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils multilib
+
+DESCRIPTION="C++ port of Java Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEMO=OFF
+ -DENABLE_TEST=OFF
+ )
+
+ cmake-utils_src_configure
+}