summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-03-22 21:27:44 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-03-22 21:27:44 +0000
commit9b38d5e12a57f3071d8e44560fba6623e710d499 (patch)
treed15c39f8ac860c69dc09ee4ce334e0b13c7d6715 /dev-db/couchdb
parentKeyworded on alpha, bug #263409 (diff)
downloadgentoo-2-9b38d5e12a57f3071d8e44560fba6623e710d499.tar.gz
gentoo-2-9b38d5e12a57f3071d8e44560fba6623e710d499.tar.bz2
gentoo-2-9b38d5e12a57f3071d8e44560fba6623e710d499.zip
Initial import of couchdb, from 197176
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'dev-db/couchdb')
-rw-r--r--dev-db/couchdb/ChangeLog10
-rw-r--r--dev-db/couchdb/couchdb-0.8.1.ebuild51
-rw-r--r--dev-db/couchdb/files/couchdb.conf-0.8.19
-rw-r--r--dev-db/couchdb/files/couchdb.init-0.8.147
-rw-r--r--dev-db/couchdb/metadata.xml9
5 files changed, 126 insertions, 0 deletions
diff --git a/dev-db/couchdb/ChangeLog b/dev-db/couchdb/ChangeLog
new file mode 100644
index 000000000000..f561c1800250
--- /dev/null
+++ b/dev-db/couchdb/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/couchdb
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/couchdb/ChangeLog,v 1.1 2009/03/22 21:27:43 caleb Exp $
+
+*couchdb-0.8.1 (22 Mar 2009)
+
+ 22 Mar 2009; Caleb Tennis <caleb@gentoo.org> +files/couchdb.conf-0.8.1,
+ +files/couchdb.init-0.8.1, +couchdb-0.8.1.ebuild:
+ Initial import, from bug 197176. Thanks to everyone there who submitted ebuilds and supplemental files.
+
diff --git a/dev-db/couchdb/couchdb-0.8.1.ebuild b/dev-db/couchdb/couchdb-0.8.1.ebuild
new file mode 100644
index 000000000000..327720a854c9
--- /dev/null
+++ b/dev-db/couchdb/couchdb-0.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/couchdb/couchdb-0.8.1.ebuild,v 1.1 2009/03/22 21:27:43 caleb Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Apache CouchDB is a distributed, fault-tolerant and schema-free document-oriented database."
+HOMEPAGE="http://couchdb.apache.org/"
+SRC_URI="mirror://apache/incubator/couchdb/${PV}-incubating/apache-${P}-incubating.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="test mirror" #72375
+
+RDEPEND="dev-libs/icu
+ dev-lang/erlang
+ >=dev-libs/openssl-0.9.8j
+ >=net-misc/curl-7.18.2
+ dev-lang/spidermonkey"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/apache-${P}-incubating"
+
+pkg_setup() {
+ enewgroup couchdb
+ enewuser couchdb -1 /bin/bash /var/lib/couchdb couchdb
+}
+
+src_compile() {
+ ./bootstrap
+ econf --with-erlang=/usr/lib/erlang/usr/include --prefix=/usr \
+ --localstatedir=/var || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ insinto /var/run/couchdb
+
+ fowners couchdb:couchdb \
+ /var/run/couchdb \
+ /var/lib/couchdb \
+ /var/log/couchdb
+
+ newinitd "${FILESDIR}/couchdb.init-0.8.1" couchdb || die
+ newconfd "${FILESDIR}/couchdb.conf-0.8.1" couchdb || die
+}
diff --git a/dev-db/couchdb/files/couchdb.conf-0.8.1 b/dev-db/couchdb/files/couchdb.conf-0.8.1
new file mode 100644
index 000000000000..a2258d356c5e
--- /dev/null
+++ b/dev-db/couchdb/files/couchdb.conf-0.8.1
@@ -0,0 +1,9 @@
+# Options for CouchDB
+
+EXEC="/usr/bin/couchdb"
+COUCHDB_USER="couchdb"
+COUCHDB_PID_FILE="/var/run/couchdb/couchdb.pid"
+COUCHDB_STDOUT_FILE="/dev/null"
+COUCHDB_STDERR_FILE="/dev/null"
+#COUCHDB_RESPAWN_TIMEOUT=
+#COUCHDB_OPTIONS=
diff --git a/dev-db/couchdb/files/couchdb.init-0.8.1 b/dev-db/couchdb/files/couchdb.init-0.8.1
new file mode 100644
index 000000000000..42b92917143b
--- /dev/null
+++ b/dev-db/couchdb/files/couchdb.init-0.8.1
@@ -0,0 +1,47 @@
+#!/sbin/runscript
+# Copyright 2008 Dirkjan Ochtman
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+
+ args="-b"
+ if test -n "$COUCHDB_STDOUT_FILE"; then
+ args="$args -o $COUCHDB_STDOUT_FILE"
+ fi
+ if test -n "$COUCHDB_STDERR_FILE"; then
+ args="$args -e $COUCHDB_STDERR_FILE"
+ fi
+ if test -n "$COUCHDB_RESPAWN_TIMEOUT"; then
+ args="$args -r $COUCHDB_RESPAWN_TIMEOUT"
+ fi
+ if test -n "$COUCHDB_OPTIONS"; then
+ args="$args $COUCHDB_OPTIONS"
+ fi
+ if test -n "$COUCHDB_PID_FILE"; then
+ args="$args -p $COUCHDB_PID_FILE"
+ else
+ echo "* ERROR: COUCHDB_PID_FILE must be set"
+ return -1
+ fi
+ if test -z "$COUCHDB_USER"; then
+ echo "* ERROR: COUCHDB_USER must be set"
+ return -1
+ fi
+
+ start-stop-daemon --start --exec ${EXEC} --name beam \
+ --user ${COUCHDB_USER} --chuid ${COUCHDB_USER} --pidfile ${COUCHDB_PID_FILE} -- $args
+
+ eend $? "Failed to start ${SVCNAME}"
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --exec ${EXEC} --name beam \
+ --pidfile ${COUCHDB_PID_FILE}
+ eend $? "Failed to stop ${SVCNAME}"
+}
diff --git a/dev-db/couchdb/metadata.xml b/dev-db/couchdb/metadata.xml
new file mode 100644
index 000000000000..995b6aade137
--- /dev/null
+++ b/dev-db/couchdb/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>caleb@gentoo.org</email>
+</maintainer>
+</pkgmetadata>