summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-07-13 12:37:06 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-07-13 12:37:06 +0000
commite95a7e6233a6c1c170ae720d390707c2e455ea5c (patch)
tree9e9df37b4c34a8b721feb97b4d40c14251191c8c /dev-db/hk_classes/hk_classes-0.7.ebuild
parentAdded a patch to the rc script to run sensors -s at start time. Closes bug #2... (diff)
downloadgentoo-2-e95a7e6233a6c1c170ae720d390707c2e455ea5c.tar.gz
gentoo-2-e95a7e6233a6c1c170ae720d390707c2e455ea5c.tar.bz2
gentoo-2-e95a7e6233a6c1c170ae720d390707c2e455ea5c.zip
ebuild clean up, fixed digest, version bump
Diffstat (limited to 'dev-db/hk_classes/hk_classes-0.7.ebuild')
-rw-r--r--dev-db/hk_classes/hk_classes-0.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-db/hk_classes/hk_classes-0.7.ebuild b/dev-db/hk_classes/hk_classes-0.7.ebuild
new file mode 100644
index 000000000000..cf8d02cad806
--- /dev/null
+++ b/dev-db/hk_classes/hk_classes-0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hk_classes/hk_classes-0.7.ebuild,v 1.1 2004/07/13 12:37:06 carlo Exp $
+
+MY_P=${P/_alpha/-test}
+S=${WORKDIR}/${MY_P}
+P_DOCS="hk_docs-0.7"
+
+DESCRIPTION="GUI-independent C++ libraries for database applications, including API documentation and tutorials."
+HOMEPAGE="http://hk-classes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hk-classes/${MY_P}.tar.bz2
+ mirror://sourceforge/knoda/knodapython.tar.bz2
+ mirror://sourceforge/knoda/${P_DOCS}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE="mysql postgres sqlite odbc doc"
+
+# At least one of the following is required
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-db/postgresql-7.3 )
+ sqlite? ( dev-db/sqlite )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )"
+
+src_compile() {
+ ./configure || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ use doc && dohtml -r ${WORKDIR}/${P_DOCS}/*
+ use doc && dohtml -r ${WORKDIR}/knodapythondoc
+ make DESTDIR=${D} install || die
+} \ No newline at end of file