summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:26:37 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:26:37 +0000
commit3542138bb08d34f0badce64af3f67387212a039e (patch)
tree3799bc5d4d054e8481940b18487d8151128346ea /dev-db/lib_mysqludf_str
parentinitial commit (diff)
downloadgentoo-2-3542138bb08d34f0badce64af3f67387212a039e.tar.gz
gentoo-2-3542138bb08d34f0badce64af3f67387212a039e.tar.bz2
gentoo-2-3542138bb08d34f0badce64af3f67387212a039e.zip
initial commit
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/lib_mysqludf_str')
-rw-r--r--dev-db/lib_mysqludf_str/ChangeLog10
-rw-r--r--dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild57
-rw-r--r--dev-db/lib_mysqludf_str/metadata.xml9
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_str/ChangeLog b/dev-db/lib_mysqludf_str/ChangeLog
new file mode 100644
index 000000000000..a3a7b17bed4c
--- /dev/null
+++ b/dev-db/lib_mysqludf_str/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/lib_mysqludf_str
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_str/ChangeLog,v 1.1 2011/10/19 12:26:37 sbriesen Exp $
+
+*lib_mysqludf_str-0.3 (19 Oct 2011)
+
+ 19 Oct 2011; Stefan Briesenick <sbriesen@gentoo.org>
+ +lib_mysqludf_str-0.3.ebuild, +metadata.xml:
+ initial commit
+
diff --git a/dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild b/dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild
new file mode 100644
index 000000000000..aabb905f71c8
--- /dev/null
+++ b/dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_str/lib_mysqludf_str-0.3.ebuild,v 1.1 2011/10/19 12:26:37 sbriesen Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="MySQL UDFs of string functions that complement the set of native ones"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_str/"
+SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ edos2unix README
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ [ -f ${PN}.html ] && dohtml ${PN}.html
+ [ -d doc/html ] && dohtml -r doc/html/.
+ for X in API AUTHORS ChangeLog NEWS README *installdb.sql; do
+ [ -s "${X}" ] && dodoc "${X}"
+ done
+
+ # remove obsolete *.la file
+ rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_str/metadata.xml b/dev-db/lib_mysqludf_str/metadata.xml
new file mode 100644
index 000000000000..abc550987baf
--- /dev/null
+++ b/dev-db/lib_mysqludf_str/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
+</pkgmetadata>