summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-02-22 11:46:57 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-02-22 11:46:57 +0000
commit5196e89ae0e735fbc1f98f7f30f9a649f0d0068e (patch)
treeab921e5d5367c60c26d4ce7516f06999e06ed14b /dev-db/metakit/metakit-2.4.9.7.ebuild
parentChanged RDEP to <=pymol-1.2.4 per 306239 (diff)
downloadgentoo-2-5196e89ae0e735fbc1f98f7f30f9a649f0d0068e.tar.gz
gentoo-2-5196e89ae0e735fbc1f98f7f30f9a649f0d0068e.tar.bz2
gentoo-2-5196e89ae0e735fbc1f98f7f30f9a649f0d0068e.zip
Fix the name of installed html doc file, to Metakit.html wrt bug #305551
by flameeyes. Also fix repoman warnings about unquoted variables. (Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'dev-db/metakit/metakit-2.4.9.7.ebuild')
-rw-r--r--dev-db/metakit/metakit-2.4.9.7.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-db/metakit/metakit-2.4.9.7.ebuild b/dev-db/metakit/metakit-2.4.9.7.ebuild
index 662eca7c97d5..f04f9eb4d758 100644
--- a/dev-db/metakit/metakit-2.4.9.7.ebuild
+++ b/dev-db/metakit/metakit-2.4.9.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.7.ebuild,v 1.2 2009/07/16 13:44:51 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.7.ebuild,v 1.3 2010/02/22 11:46:57 phajdan.jr Exp $
inherit python multilib eutils
@@ -22,7 +22,9 @@ RESTRICT="test"
src_unpack() {
python_version
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd "${S}"
+
# Fix all hardcoded python2.5 paths
for name in python/scxx/PWOBase.h python/PyHead.h python/PyStorage.cpp ; do
sed -i -e "s:Python.h:python${PYVER}/Python.h:" ${name}
@@ -54,9 +56,9 @@ src_install () {
python_version
use python && dodir /usr/$(get_libdir)/python${PYVER}/site-packages
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc CHANGES README
- dohtml MetaKit.html
+ dohtml Metakit.html
dohtml -a html,gif,png,jpg -r doc/*
}