summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-03-02 21:02:52 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-03-02 21:02:52 +0000
commitb8326613276dc1b65a5cd287b92ff86ef8d76e97 (patch)
tree90c9d6cd89d834eb56da6beaf832308c77ea5973 /dev-db/mysql++
parentStable on ppc wrt bug 166742 (diff)
downloadgentoo-2-b8326613276dc1b65a5cd287b92ff86ef8d76e97.tar.gz
gentoo-2-b8326613276dc1b65a5cd287b92ff86ef8d76e97.tar.bz2
gentoo-2-b8326613276dc1b65a5cd287b92ff86ef8d76e97.zip
Version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-db/mysql++')
-rw-r--r--dev-db/mysql++/ChangeLog9
-rw-r--r--dev-db/mysql++/files/digest-mysql++-2.2.13
-rw-r--r--dev-db/mysql++/mysql++-2.2.1.ebuild50
3 files changed, 60 insertions, 2 deletions
diff --git a/dev-db/mysql++/ChangeLog b/dev-db/mysql++/ChangeLog
index 7fadc444eda9..e94d2bbaeb1d 100644
--- a/dev-db/mysql++/ChangeLog
+++ b/dev-db/mysql++/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql++
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.39 2007/01/23 22:19:42 hansmi Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.40 2007/03/02 21:02:52 hansmi Exp $
+
+*mysql++-2.2.1 (02 Mar 2007)
+
+ 02 Mar 2007; Michael Hanselmann <hansmi@gentoo.org> +mysql++-2.2.1.ebuild:
+ Version bump.
*mysql++-2.1.1-r2 (28 Nov 2006)
diff --git a/dev-db/mysql++/files/digest-mysql++-2.2.1 b/dev-db/mysql++/files/digest-mysql++-2.2.1
new file mode 100644
index 000000000000..3dc7c48cc947
--- /dev/null
+++ b/dev-db/mysql++/files/digest-mysql++-2.2.1
@@ -0,0 +1,3 @@
+MD5 3325bad5713a819ebf6c2e2941c5975c mysql++-2.2.1.tar.gz 2689019
+RMD160 11db655d330358b31d2e8bfaf2f76ab36d358fe0 mysql++-2.2.1.tar.gz 2689019
+SHA256 1b7fe18ab1635ae833a8f6066197191df54ad58a69d3e0c84d02b8cf39b42777 mysql++-2.2.1.tar.gz 2689019
diff --git a/dev-db/mysql++/mysql++-2.2.1.ebuild b/dev-db/mysql++/mysql++-2.2.1.ebuild
new file mode 100644
index 000000000000..563198870639
--- /dev/null
+++ b/dev-db/mysql++/mysql++-2.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.2.1.ebuild,v 1.1 2007/03/02 21:02:52 hansmi Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="C++ API interface to the MySQL database"
+# This is the download page but includes links to other places
+HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
+SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~hppa ~mips ~sparc ~ppc ~amd64"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-3"
+RDEPEND="${DEPEND}
+ >=virtual/mysql-4.0"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+}
+
+src_compile() {
+ local myconf
+ # we want C++ exceptions turned on
+ myconf="--enable-exceptions"
+ # give threads a try
+ myconf="${myconf} --enable-thread-check"
+ # not including the directives to where MySQL is because it seems to
+ # find it just fine without
+
+ # force the cflags into place otherwise they get totally ignored by
+ # configure
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ econf ${myconf} || die "econf failed"
+
+ emake || die "unable to make"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ # install the docs and HTML pages
+ dodoc README LGPL
+ dodoc doc/*
+ dohtml doc/man-html/*
+ prepalldocs
+}