summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-15 00:32:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-15 00:32:00 +0000
commit1801c170fa41ea7fa848995ac10b7b81df6f4691 (patch)
treecefb7f82b08160cef7273105f01eaea0efdf7d2b /dev-db/mysql-community
parentCleanup of src_test code so that the enterprise and community ebuilds can be ... (diff)
downloadgentoo-2-1801c170fa41ea7fa848995ac10b7b81df6f4691.tar.gz
gentoo-2-1801c170fa41ea7fa848995ac10b7b81df6f4691.tar.bz2
gentoo-2-1801c170fa41ea7fa848995ac10b7b81df6f4691.zip
Version bump of mysql-community, per security bug #185333, bump request #178265. Also cleans up the src_test per bug #161885. If you want to use src_test now, you MUST have FEATURES=userpriv. See the main dev-db/mysql/ChangeLog for more details.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-db/mysql-community')
-rw-r--r--dev-db/mysql-community/ChangeLog11
-rw-r--r--dev-db/mysql-community/files/digest-mysql-community-5.0.456
-rw-r--r--dev-db/mysql-community/mysql-community-5.0.45.ebuild64
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-db/mysql-community/ChangeLog b/dev-db/mysql-community/ChangeLog
index 2aadd4c18d59..15453608f23b 100644
--- a/dev-db/mysql-community/ChangeLog
+++ b/dev-db/mysql-community/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/mysql-community
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/ChangeLog,v 1.14 2007/07/14 21:39:02 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/ChangeLog,v 1.15 2007/07/15 00:32:00 robbat2 Exp $
+
+*mysql-community-5.0.45 (15 Jul 2007)
+
+ 15 Jul 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +mysql-community-5.0.45.ebuild:
+ Version bump of mysql-community, per security bug #185333, bump request
+ #178265. Also cleans up the src_test per bug #161885. If you want to use
+ src_test now, you MUST have FEATURES=userpriv. See the main
+ dev-db/mysql/ChangeLog for more details.
14 Jul 2007; Robin H. Johnson <robbat2@gentoo.org>
mysql-community-5.0.27-r1.ebuild:
diff --git a/dev-db/mysql-community/files/digest-mysql-community-5.0.45 b/dev-db/mysql-community/files/digest-mysql-community-5.0.45
new file mode 100644
index 000000000000..05a1c88442f0
--- /dev/null
+++ b/dev-db/mysql-community/files/digest-mysql-community-5.0.45
@@ -0,0 +1,6 @@
+MD5 a2a1c5a82bb22b45ab76a8ecab94e10d mysql-5.0.45.tar.gz 24433261
+RMD160 ee6717c65dc7bb6b5b596b90ef6c47c7fdebf5fb mysql-5.0.45.tar.gz 24433261
+SHA256 e4443d8dc859ed53bd9f3bef143ce30c7f5dee66a02748e9a003136be25e0060 mysql-5.0.45.tar.gz 24433261
+MD5 6619312d9ec44aba9ffbef530fc03cdc mysql-extras-20070710.tar.bz2 52626
+RMD160 e0f39f1fd35012fb3e2a431379d7b15389e05187 mysql-extras-20070710.tar.bz2 52626
+SHA256 980a5fa500f4136e13bf434f167995248b9c8f96a2c42c96e4d7ad60246ad7fc mysql-extras-20070710.tar.bz2 52626
diff --git a/dev-db/mysql-community/mysql-community-5.0.45.ebuild b/dev-db/mysql-community/mysql-community-5.0.45.ebuild
new file mode 100644
index 000000000000..4227c8db93b1
--- /dev/null
+++ b/dev-db/mysql-community/mysql-community-5.0.45.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-community/mysql-community-5.0.45.ebuild,v 1.1 2007/07/15 00:32:00 robbat2 Exp $
+
+MY_EXTRAS_VER="20070710"
+
+inherit toolchain-funcs mysql
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+src_test() {
+ make check || die "make check failed"
+ if ! use "minimal" ; then
+ if ! hasq "userpriv" ${FEATURES} ; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream"
+ fi
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus1
+ local retstatus2
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # mysqladmin start before dir creation
+ mkdir -p "${S}"/mysql-test/var{,/log}
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Broken in 5.0.42" ;;
+
+ 5.0.44)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+
+ 5.0.45)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test "archive_gis" "Broken in 5.0.4[45] on big-endian boxes only" ;;
+ esac
+
+ # We run the test protocols seperately
+ make -j1 test-ns force=--force
+ retstatus1=$?
+ [[ $retstatus1 -eq 0 ]] || eerror "test-ns failed"
+
+ make -j1 test-ps force=--force
+ retstatus2=$?
+ [[ $retstatus2 -eq 0 ]] || eerror "test-ps failed"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus1 -eq 0 ]] || die "test-ns failed"
+ [[ $retstatus2 -eq 0 ]] || die "test-ps failed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}