summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2005-12-30 20:07:13 +0000
committerFrancesco Riosa <vivo@gentoo.org>2005-12-30 20:07:13 +0000
commit59acb16541fe5f3005d24960cba824913ebc93b1 (patch)
treee8da7351aa4009087882d8ac5fc91e9982b206fa /dev-db/mysql/mysql-5.0.17.ebuild
parentUpdate to latest release. (diff)
downloadgentoo-2-59acb16541fe5f3005d24960cba824913ebc93b1.tar.gz
gentoo-2-59acb16541fe5f3005d24960cba824913ebc93b1.tar.bz2
gentoo-2-59acb16541fe5f3005d24960cba824913ebc93b1.zip
Synced the code of the ebuilds, this should _NOT_ affect the emerge behaviour on these ones.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-db/mysql/mysql-5.0.17.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.0.17.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-db/mysql/mysql-5.0.17.ebuild b/dev-db/mysql/mysql-5.0.17.ebuild
index 4d692487cd26..69686f395359 100644
--- a/dev-db/mysql/mysql-5.0.17.ebuild
+++ b/dev-db/mysql/mysql-5.0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.17.ebuild,v 1.3 2005/12/28 21:54:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.17.ebuild,v 1.4 2005/12/30 20:07:13 vivo Exp $
# helper function, version (integer) may have section separated by dots
# for readbility
@@ -56,6 +56,9 @@ mysql_version_is_at_least() {
mysql_version_is_at_least "4.01.03.00" \
&& IUSE="${IUSE} cluster utf8 extraengine"
+mysql_version_is_at_least "5.00.18.00" \
+&& IUSE="${IUSE} max-idx-128"
+
mysql_version_is_at_least "5.01.00.00" \
&& IUSE="${IUSE} innodb"
@@ -440,6 +443,10 @@ src_compile() {
myconf="${myconf} --with-partition"
fi
fi
+
+ mysql_version_is_at_least "5.00.18.00" \
+ && useq "max-idx-128" \
+ && myconf="${myconf} --with-max-indexes=128"
fi
#Bug #114895,Bug #110149
@@ -548,7 +555,7 @@ src_install() {
done
# oops
- mysql_check_version_range "5.00.16.00 to 5.00.17.99" \
+ mysql_check_version_range "5.00.16.00 to 5.00.18.99" \
&& cp "${WORKDIR}/mysql-extras/fill_help_tables.sql-5.0.15" "${D}/usr/share/mysql/"
# TODO change at Makefile-am level