summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-05-05 19:51:40 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-05-05 19:51:40 +0000
commit906b65335258ec6d797361092569945616dd592f (patch)
treee8d816fe12c2f4b66b61daeeacaf2eb131a4acd3 /dev-db/mysql/mysql-5.0.19-r1.ebuild
parentSync with overlay. (diff)
downloadgentoo-2-906b65335258ec6d797361092569945616dd592f.tar.gz
gentoo-2-906b65335258ec6d797361092569945616dd592f.tar.bz2
gentoo-2-906b65335258ec6d797361092569945616dd592f.zip
Sync with overlay, fix security bugs.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'dev-db/mysql/mysql-5.0.19-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.0.19-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-db/mysql/mysql-5.0.19-r1.ebuild b/dev-db/mysql/mysql-5.0.19-r1.ebuild
index d5ec7c76ec2e..732086dd72f1 100644
--- a/dev-db/mysql/mysql-5.0.19-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.19-r1.ebuild
@@ -1,28 +1,31 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.19-r1.ebuild,v 1.4 2006/04/22 21:20:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.19-r1.ebuild,v 1.5 2006/05/05 19:51:39 chtekk Exp $
+# Leave this empty
MYSQL_VERSION_ID=""
-MY_EXTRAS_VER=""
+# Set the patchset revision to use, must be either empty or a decimal number
+MYSQL_PATCHSET_REV="2"
inherit mysql
+
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
src_test() {
- cd ${S}
+ cd "${S}"
einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
make check || die "make check failed"
- if ! useq minimal; then
+ if ! useq "minimal" ; then
einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
local retstatus
addpredict /this-dir-does-not-exist/t9.MYI
cd mysql-test
- sed -i -e "s|MYSQL_TCP_PORT=3306|MYSQL_TCP_PORT=3307|" mysql-test-run
+ sed -i -e "s|PORT=3306|PORT=3307|g" mysql-test-run
./mysql-test-run
retstatus=$?
- # to be sure ;)
+ # Just to be sure ;)
pkill -9 -f "${S}/ndb" 2>/dev/null
pkill -9 -f "${S}/sql" 2>/dev/null
[[ $retstatus -eq 0 ]] || die "make test failed"
@@ -30,4 +33,3 @@ src_test() {
einfo "Skipping server tests due to minimal build."
fi
}
-