summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-12-27 12:34:30 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-12-27 12:34:30 +0000
commit995ef51df15e20f6191502104a3d831254c81e69 (patch)
tree08e90c8da5eb5025ffc6a3c4a810d4294b25cc02 /dev-db/oracle-instantclient-jdbc
parentVersion bump, #228803 (diff)
downloadgentoo-2-995ef51df15e20f6191502104a3d831254c81e69.tar.gz
gentoo-2-995ef51df15e20f6191502104a3d831254c81e69.tar.bz2
gentoo-2-995ef51df15e20f6191502104a3d831254c81e69.zip
Version bump, #228803
(Portage version: 2.2_rc19/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'dev-db/oracle-instantclient-jdbc')
-rw-r--r--dev-db/oracle-instantclient-jdbc/ChangeLog8
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.1.0.7.0.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/ChangeLog b/dev-db/oracle-instantclient-jdbc/ChangeLog
index 305a698b1372..b81a235e38d4 100644
--- a/dev-db/oracle-instantclient-jdbc/ChangeLog
+++ b/dev-db/oracle-instantclient-jdbc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/oracle-instantclient-jdbc
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.23 2008/06/18 22:35:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.24 2008/12/27 12:34:30 dertobi123 Exp $
+
+*oracle-instantclient-jdbc-11.1.0.7.0 (27 Dec 2008)
+
+ 27 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +oracle-instantclient-jdbc-11.1.0.7.0.ebuild:
+ Version bump, #228803
18 Jun 2008; Chris Gianelloni <wolf31o2@gentoo.org>
oracle-instantclient-jdbc-10.2.0.3.ebuild:
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.1.0.7.0.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.1.0.7.0.ebuild
new file mode 100644
index 000000000000..94ae1f8f6cdd
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.1.0.7.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-11.1.0.7.0.ebuild,v 1.1 2008/12/27 12:34:30 dertobi123 Exp $
+
+inherit eutils
+
+MY_P_x86="${PN/oracle-/}-linux32-${PV/7.0/7}"
+MY_P_amd64="${PN/oracle-instantclient-/}-${PV}-linux-x86_64"
+
+S="${WORKDIR}"
+DESCRIPTION="Oracle 10g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://www.oracle.com/technology/tech/oci/instantclient/index.html"
+SRC_URI="amd64? ( ${MY_P_amd64}.zip )
+ x86? ( ${MY_P_x86}.zip )"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch"
+IUSE=""
+
+RDEPEND=">=dev-db/oracle-instantclient-basic-${PV}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ MY_P=MY_P_${ARCH}
+ export MY_P=${!MY_P}
+}
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ unzip "${DISTDIR}"/${MY_P}.zip
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/oracle/${PV}/client/lib
+ cd "${S}"/instantclient_11_1
+ insinto /usr/$(get_libdir)/oracle/${PV}/client/lib
+ doins libheteroxa11.so orai18n.jar
+}
+
+pkg_postinst() {
+ elog "The JDBC supplement package for Oracle 10g has been installed."
+ elog "You may wish to install the oracle-instantclient-sqlplus (for "
+ elog "running the SQL*Plus application) package as well."
+}