summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 16:30:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 16:30:29 +0000
commitb48cb3900ae5943aa848f6ca2bee4dd55bfbad40 (patch)
tree4b8f1accfac8706e8914e935e9898794d39aa126 /dev-db/pgasync
parentDelete older ebuild. (diff)
downloadgentoo-2-b48cb3900ae5943aa848f6ca2bee4dd55bfbad40.tar.gz
gentoo-2-b48cb3900ae5943aa848f6ca2bee4dd55bfbad40.tar.bz2
gentoo-2-b48cb3900ae5943aa848f6ca2bee4dd55bfbad40.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS (bug #312139).
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/pgasync')
-rw-r--r--dev-db/pgasync/ChangeLog6
-rw-r--r--dev-db/pgasync/pgasync-2.01.ebuild18
2 files changed, 17 insertions, 7 deletions
diff --git a/dev-db/pgasync/ChangeLog b/dev-db/pgasync/ChangeLog
index 88e91798a003..f4a28360d7b0 100644
--- a/dev-db/pgasync/ChangeLog
+++ b/dev-db/pgasync/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/pgasync
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgasync/ChangeLog,v 1.5 2011/01/08 16:24:13 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgasync/ChangeLog,v 1.6 2011/01/08 16:30:29 arfrever Exp $
+
+ 08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pgasync-2.01.ebuild:
+ Fix dependencies. Set SUPPORT_PYTHON_ABIS (bug #312139).
08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-pgasync-1.15b.ebuild:
diff --git a/dev-db/pgasync/pgasync-2.01.ebuild b/dev-db/pgasync/pgasync-2.01.ebuild
index 8de26ca1cb71..d6b322237be6 100644
--- a/dev-db/pgasync/pgasync-2.01.ebuild
+++ b/dev-db/pgasync/pgasync-2.01.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgasync/pgasync-2.01.ebuild,v 1.2 2010/02/06 10:40:34 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgasync/pgasync-2.01.ebuild,v 1.3 2011/01/08 16:30:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -13,15 +18,16 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="doc"
-DEPEND=">=dev-python/twisted-1.3
- >=dev-lang/python-2.3"
+DEPEND=">=dev-python/twisted-1.3"
+RDEPEND="${DEPEND}"
-DOCS="CHANGELOG LICENSE PKG-INFO README TODO"
+DOCS="CHANGELOG PKG-INFO README TODO"
src_install() {
distutils_src_install
+
if use doc; then
insinto /usr/share/doc/${PF}
- doins -r examples
+ doins -r examples || die "doins failed"
fi
}