summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2011-08-23 22:56:13 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2011-08-23 22:56:13 +0000
commit3807351502e55582726b506aadaf6045e04fcfda (patch)
tree610de3e7e6a95aabefe43c1ff1e593f26f787c8f /dev-db/postgis
parentFixed typo: ESPG -> EPSG (diff)
downloadgentoo-2-3807351502e55582726b506aadaf6045e04fcfda.tar.gz
gentoo-2-3807351502e55582726b506aadaf6045e04fcfda.tar.bz2
gentoo-2-3807351502e55582726b506aadaf6045e04fcfda.zip
Backpatched fixes from 1.5.3. Fixed typo.
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/ChangeLog8
-rw-r--r--dev-db/postgis/postgis-1.4.2-r1.ebuild (renamed from dev-db/postgis/postgis-1.4.2.ebuild)26
2 files changed, 21 insertions, 13 deletions
diff --git a/dev-db/postgis/ChangeLog b/dev-db/postgis/ChangeLog
index 83ea48208c7d..e143c142d885 100644
--- a/dev-db/postgis/ChangeLog
+++ b/dev-db/postgis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgis
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/ChangeLog,v 1.57 2011/08/23 22:46:51 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/ChangeLog,v 1.58 2011/08/23 22:56:13 titanofold Exp $
+
+*postgis-1.4.2-r1 (23 Aug 2011)
+
+ 23 Aug 2011; Aaron W. Swenson <titanofold@gentoo.org> -postgis-1.4.2.ebuild,
+ +postgis-1.4.2-r1.ebuild:
+ Backpatched fixes from 1.5.3. Fixed typo.
*postgis-1.5.3-r1 (23 Aug 2011)
diff --git a/dev-db/postgis/postgis-1.4.2.ebuild b/dev-db/postgis/postgis-1.4.2-r1.ebuild
index 6940592320e4..d3ef2ce455bc 100644
--- a/dev-db/postgis/postgis-1.4.2.ebuild
+++ b/dev-db/postgis/postgis-1.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-1.4.2.ebuild,v 1.1 2011/08/23 22:31:43 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgis/postgis-1.4.2-r1.ebuild,v 1.1 2011/08/23 22:56:13 titanofold Exp $
EAPI="4"
@@ -41,6 +41,9 @@ RESTRICT="test"
PGIS="$(get_version_component_range 1-2)"
+# not parallel safe
+MAKEOPTS+=" -j1"
+
pkg_setup() {
export PGSLOT="$(postgresql-config show)"
if [[ ${PGSLOT//.} < 82 || ${PGSLOT//.} > 84 ]] ; then
@@ -52,30 +55,29 @@ pkg_setup() {
src_configure() {
# Configure interprets --without-gui as being the same as --with-gui
- if use gtk ; then
- econf --with-gui
- else
- econf
- fi
+ local myargs=""
+ use gtk && myargs+=" --with-gui"
+ econf \
+ ${myargs}
}
src_compile() {
# Occasionally, builds fail because of out of order compilation.
# Otherwise, it'd be fine.
- emake -j1
+ emake
cd topology/
- emake -j1
+ emake
if use doc ; then
cd "${S}/doc/"
- emake -j1
+ emake
fi
}
src_install() {
- emake -j1 DESTDIR="${D}" install
+ emake DESTDIR="${D}" install
cd topology/
- emake -j1 DESTDIR="${D}" install
+ emake DESTDIR="${D}" install
cd "${S}"
dodoc CREDITS TODO loader/README.* doc/*txt
@@ -111,7 +113,7 @@ pkg_postinst() {
pkg_config(){
source "${EROOT%/}/etc/conf.d/postgresql-${PGSLOT}"
- source "${EROOT%/}/etc/postgis_dbs"
+ source "${EROOT%/}/etc/postgis_dbs-${PGIS}"
local postgis_path="${EROOT%/}/usr/share/postgresql-${PGSLOT}/contrib/postgis-${PGIS}"
if [[ -n ${configured} ]] ; then