summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-10-02 23:57:49 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-10-02 23:57:49 +0000
commit49819677ff58f10ea454aac0e5a57c8549aa18c3 (patch)
tree76800df88f9b1e5ccbbae95adb0b40d20713d777 /dev-db/postgresql/files
parentFixed typo. (diff)
downloadgentoo-2-49819677ff58f10ea454aac0e5a57c8549aa18c3.tar.gz
gentoo-2-49819677ff58f10ea454aac0e5a57c8549aa18c3.tar.bz2
gentoo-2-49819677ff58f10ea454aac0e5a57c8549aa18c3.zip
Fixed some bugs
Diffstat (limited to 'dev-db/postgresql/files')
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.3.7-r13
-rw-r--r--dev-db/postgresql/files/digest-postgresql-8.0.0_beta23
-rw-r--r--dev-db/postgresql/files/pg_autovacuum.init-7.4.522
-rw-r--r--dev-db/postgresql/files/postgresql-7.3.7-gentoo.patch12
-rw-r--r--dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch27
-rw-r--r--dev-db/postgresql/files/postgresql-8.0.0_beta2-gentoo.patch16
6 files changed, 35 insertions, 48 deletions
diff --git a/dev-db/postgresql/files/digest-postgresql-7.3.7-r1 b/dev-db/postgresql/files/digest-postgresql-7.3.7-r1
new file mode 100644
index 000000000000..f7f8f6801db1
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.3.7-r1
@@ -0,0 +1,3 @@
+MD5 d64e0eca8025caa2e35e5d8226a1afbf postgresql-base-7.3.7.tar.bz2 5651364
+MD5 d3a8a078e786abc5b6c52fac2663a125 postgresql-opt-7.3.7.tar.bz2 340879
+MD5 53bb62e0d7a302b0e626436001f9b242 postgresql-docs-7.3.7.tar.bz2 2340178
diff --git a/dev-db/postgresql/files/digest-postgresql-8.0.0_beta2 b/dev-db/postgresql/files/digest-postgresql-8.0.0_beta2
deleted file mode 100644
index fcc96780886a..000000000000
--- a/dev-db/postgresql/files/digest-postgresql-8.0.0_beta2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 a0235a0119377ad58990b4398c1fcb42 postgresql-base-8.0.0beta2.tar.bz2 7326585
-MD5 f2a5a72d0519c6d47558ad45e8f97574 postgresql-opt-8.0.0beta2.tar.bz2 130765
-MD5 c5f237ef2f5b3acf82e7a55b1b46798c postgresql-docs-8.0.0beta2.tar.bz2 2248195
diff --git a/dev-db/postgresql/files/pg_autovacuum.init-7.4.5 b/dev-db/postgresql/files/pg_autovacuum.init-7.4.5
index 11c88d3eaba2..74c38c832cb0 100644
--- a/dev-db/postgresql/files/pg_autovacuum.init-7.4.5
+++ b/dev-db/postgresql/files/pg_autovacuum.init-7.4.5
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/files/pg_autovacuum.init-7.4.5,v 1.1 2004/08/21 16:12:27 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/files/pg_autovacuum.init-7.4.5,v 1.2 2004/10/02 23:57:49 nakano Exp $
depend() {
need postgresql logger
@@ -9,12 +9,30 @@ depend() {
start() {
ebegin "Starting pg_autovacuum"
- start-stop-daemon --chuid $PGUSER --start --quiet --exec /usr/bin/pg_autovacuum -- -D -v $VACUUM_BASE -V $VACUUM_SCALE -s $SLEEP_BASE -S $SLEEP_SCALE -L $PG_AUTOVACUUM_LOG
+ echo ""
+ echo -n "Waiting max. 10 sec. for postgresql to start "
+ CONTINUE=0
+ TOO_LONG=0
+ while [ "$CONTINUE" -eq 0 ] && [ $TOO_LONG -lt 10 ]
+ do
+ psql -U $PGUSER -d template1 -c "SELECT 1" 1> /dev/null 2> /dev/null
+ if [ "$?" -eq 0 ]
+ then
+ CONTINUE=1
+ else
+ echo -n "."
+ TOO_LONG=`expr $TOO_LONG + 1`
+ sleep 1
+ fi
+ done
+ start-stop-daemon -o --chuid $PGUSER --start --quiet --exec /usr/bin/pg_autovacuum -- -D -v $VACUUM_BASE -V $VACUUM_SCALE -s $SLEEP_BASE -S $SLEEP_SCALE -L $PG_AUTOVACUUM_LOG
+
sleep 1
pidof /usr/bin/pg_autovacuum > /dev/null
if [ $? -eq 0 ]; then
eend 0
else
+ eerror ""
eerror "Please see log file: $PG_AUTOVACUUM_LOG"
eerror "You may need to add following lines in /var/lib/postgresql/data/postgresql.conf and restart PostgreSQL."
eerror " stats_start_collector = true"
diff --git a/dev-db/postgresql/files/postgresql-7.3.7-gentoo.patch b/dev-db/postgresql/files/postgresql-7.3.7-gentoo.patch
new file mode 100644
index 000000000000..0b54f6d33b41
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-7.3.7-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naru postgresql-7.3.7.org/configure postgresql-7.3.7/configure
+--- postgresql-7.3.7.org/configure 2004-08-15 01:51:58.000000000 +0100
++++ postgresql-7.3.7/configure 2004-10-03 00:24:38.477010826 +0100
+@@ -5871,7 +5871,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ pgac_cv_check_readline=no
+-for pgac_lib in "" " -ltermcap" " -lncurses" " -lcurses" ; do
++for pgac_lib in "" " -lncurses" " -lcurses" ; do
+ for pgac_rllib in -lreadline -ledit ; do
+ pgac_save_LIBS=$LIBS
+ LIBS="${pgac_rllib}${pgac_lib} $LIBS"
diff --git a/dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch b/dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch
deleted file mode 100644
index b88ccbf570a8..000000000000
--- a/dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -Naru postgresql-8.0.0beta1.org/contrib/Makefile postgresql-8.0.0beta1/contrib/Makefile
---- postgresql-8.0.0beta1.org/contrib/Makefile 2004-06-01 06:15:47.000000000 +0100
-+++ postgresql-8.0.0beta1/contrib/Makefile 2004-08-10 15:42:47.197198133 +0100
-@@ -11,7 +11,6 @@
- dbase \
- dblink \
- dbmirror \
-- dbsize \
- earthdistance \
- findoidjoins \
- fulltextindex \
-diff -Naru postgresql-8.0.0beta1.org/src/bin/initdb/initdb.c postgresql-8.0.0beta1/src/bin/initdb/initdb.c
---- postgresql-8.0.0beta1.org/src/bin/initdb/initdb.c 2004-08-01 07:19:23.000000000 +0100
-+++ postgresql-8.0.0beta1/src/bin/initdb/initdb.c 2004-08-10 15:45:05.678447838 +0100
-@@ -2490,11 +2490,7 @@
- fprintf(stderr, authwarning);
-
- printf(_("\nSuccess. You can now start the database server using:\n\n"
-- " %s%s%s/postmaster -D %s%s%s\n"
-- "or\n"
-- " %s%s%s/pg_ctl -D %s%s%s -l logfile start\n\n"),
-- QUOTE_PATH, bin_path, QUOTE_PATH, QUOTE_PATH, pg_data, QUOTE_PATH,
-- QUOTE_PATH, bin_path, QUOTE_PATH, QUOTE_PATH, pg_data, QUOTE_PATH);
-+ "/etc/init.d/postgresql start\n\n"));
-
- return 0;
- }
diff --git a/dev-db/postgresql/files/postgresql-8.0.0_beta2-gentoo.patch b/dev-db/postgresql/files/postgresql-8.0.0_beta2-gentoo.patch
deleted file mode 100644
index fafe3f9ab57a..000000000000
--- a/dev-db/postgresql/files/postgresql-8.0.0_beta2-gentoo.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -Naru postgresql-8.0.0beta2.org/src/bin/initdb/initdb.c postgresql-8.0.0beta2/src/bin/initdb/initdb.c
---- postgresql-8.0.0beta2.org/src/bin/initdb/initdb.c 2004-08-29 06:06:52.000000000 +0100
-+++ postgresql-8.0.0beta2/src/bin/initdb/initdb.c 2004-09-02 09:18:00.634625577 +0100
-@@ -2499,11 +2499,7 @@
- fprintf(stderr, authwarning);
-
- printf(_("\nSuccess. You can now start the database server using:\n\n"
-- " %s%s%s/postmaster -D %s%s%s\n"
-- "or\n"
-- " %s%s%s/pg_ctl -D %s%s%s -l logfile start\n\n"),
-- QUOTE_PATH, bin_path, QUOTE_PATH, QUOTE_PATH, pg_data, QUOTE_PATH,
-- QUOTE_PATH, bin_path, QUOTE_PATH, QUOTE_PATH, pg_data, QUOTE_PATH);
-+ "/etc/init.d/postgresql start\n\n"));
-
- return 0;
- }