summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-08-10 16:01:30 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-08-10 16:01:30 +0000
commitd108522c1f2905da69d76de6a5537a95baf221bf (patch)
treec4174bf013cf87100a45dfc5b78e49babab08e68 /dev-db/postgresql/files
parentadded mask for postgresql-8.0.0 (diff)
downloadgentoo-2-d108522c1f2905da69d76de6a5537a95baf221bf.tar.gz
gentoo-2-d108522c1f2905da69d76de6a5537a95baf221bf.tar.bz2
gentoo-2-d108522c1f2905da69d76de6a5537a95baf221bf.zip
Version bump. But this is hard masked because of beta version.
Diffstat (limited to 'dev-db/postgresql/files')
-rw-r--r--dev-db/postgresql/files/digest-postgresql-8.0.0_beta13
-rw-r--r--dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch27
-rw-r--r--dev-db/postgresql/files/postgresql.conf-8.0.014
-rw-r--r--dev-db/postgresql/files/postgresql.init-8.0.063
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-db/postgresql/files/digest-postgresql-8.0.0_beta1 b/dev-db/postgresql/files/digest-postgresql-8.0.0_beta1
new file mode 100644
index 000000000000..15b38bc03fd5
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-8.0.0_beta1
@@ -0,0 +1,3 @@
+MD5 e8fe985e6333b45dbb328cab815796f4 postgresql-base-8.0.0beta1.tar.bz2 7205993
+MD5 20b45631a3bd9567b166632f0a65e7ca postgresql-opt-8.0.0beta1.tar.bz2 131046
+MD5 21303676d964c72e868d01c49d1e04fe postgresql-docs-8.0.0beta1.tar.bz2 2249514
diff --git a/dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch b/dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch
new file mode 100644
index 000000000000..b88ccbf570a8
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql-8.0.0_beta1-gentoo.patch
@@ -0,0 +1,27 @@
+diff -Naru postgresql-8.0.0beta1.org/contrib/Makefile postgresql-8.0.0beta1/contrib/Makefile
+--- postgresql-8.0.0beta1.org/contrib/Makefile 2004-06-01 06:15:47.000000000 +0100
++++ postgresql-8.0.0beta1/contrib/Makefile 2004-08-10 15:42:47.197198133 +0100
+@@ -11,7 +11,6 @@
+ dbase \
+ dblink \
+ dbmirror \
+- dbsize \
+ earthdistance \
+ findoidjoins \
+ fulltextindex \
+diff -Naru postgresql-8.0.0beta1.org/src/bin/initdb/initdb.c postgresql-8.0.0beta1/src/bin/initdb/initdb.c
+--- postgresql-8.0.0beta1.org/src/bin/initdb/initdb.c 2004-08-01 07:19:23.000000000 +0100
++++ postgresql-8.0.0beta1/src/bin/initdb/initdb.c 2004-08-10 15:45:05.678447838 +0100
+@@ -2490,11 +2490,7 @@
+ fprintf(stderr, authwarning);
+
+ printf(_("\nSuccess. You can now start the database server using:\n\n"
+- " %s%s%s/postmaster -D %s%s%s\n"
+- "or\n"
+- " %s%s%s/pg_ctl -D %s%s%s -l logfile start\n\n"),
+- QUOTE_PATH, bin_path, QUOTE_PATH, QUOTE_PATH, pg_data, QUOTE_PATH,
+- QUOTE_PATH, bin_path, QUOTE_PATH, QUOTE_PATH, pg_data, QUOTE_PATH);
++ "/etc/init.d/postgresql start\n\n"));
+
+ return 0;
+ }
diff --git a/dev-db/postgresql/files/postgresql.conf-8.0.0 b/dev-db/postgresql/files/postgresql.conf-8.0.0
new file mode 100644
index 000000000000..e8dab3e4c827
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql.conf-8.0.0
@@ -0,0 +1,14 @@
+# PostgreSQL's Database Directory
+PGDATA=/var/lib/postgresql/data
+
+# Logfile path: (NOTE: This must be uid/gid owned by the value of $PGUSER!)
+PGLOG=/var/lib/postgresql/data/postgresql.log
+
+# Run the PostgreSQL user as:
+PGUSER=postgres
+
+# Extra options to run postmaster with.
+# If you want to enable TCP/IP for PostgreSQL, add -i to the following:
+# PGOPTS="-N 1024 -B 2048 -i"
+PGOPTS=""
+
diff --git a/dev-db/postgresql/files/postgresql.init-8.0.0 b/dev-db/postgresql/files/postgresql.init-8.0.0
new file mode 100644
index 000000000000..fb1f14117ac6
--- /dev/null
+++ b/dev-db/postgresql/files/postgresql.init-8.0.0
@@ -0,0 +1,63 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/files/postgresql.init-8.0.0,v 1.1 2004/08/10 16:01:30 nakano Exp $
+
+opts="${opts} reload"
+
+depend() {
+ use net
+}
+
+checkconfig() {
+ if [ ! -d $PGDATA ]; then
+ eerror "directory not found: $PGDATA"
+ eerror "You should create PGDATA directory first."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting PostgreSQL"
+ if [ -f $PGDATA/postmaster.pid ]; then
+ rm $PGDATA/postmaster.pid
+ fi
+ su - $PGUSER -c "/usr/bin/pg_ctl start -D '$PGDATA' -s -l '$PGLOG' -o '$PGOPTS'"
+
+ while :
+ do
+ cnt=$(($cnt + 1))
+ if [ -f "$PGDATA/postmaster.pid" ]; then
+ ret=0
+ break
+ fi
+
+ if [ $cnt -eq 30 ]; then
+ eerror "Please see log file: $PGLOG"
+ ret=1
+ break
+ fi
+ sleep 1
+ done
+ eend $ret
+}
+
+stop() {
+ ebegin "Stopping PostgreSQL"
+ su - $PGUSER -c "/usr/bin/pg_ctl stop -D '$PGDATA' -s -m fast"
+ eend $?
+}
+
+svc_restart() {
+ ebegin "Restarting PostgreSQL"
+ su - $PGUSER -c "/usr/bin/pg_ctl restart -D '$PGDATA' -s -m fast -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading PostgreSQL configuration"
+ su - $PGUSER -c "/usr/bin/pg_ctl reload -D '$PGDATA' -s"
+ eend $?
+}