summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-31 01:40:49 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-31 01:40:49 +0000
commit55c61d95f38037ca1d3e238ade534089f8e700c0 (patch)
treec9e13ad4385db47498f3f7e4892940a32db2c794 /dev-db/recutils
parentMake sure BUILD_DIR exists before pushd'ing into it. (diff)
downloadgentoo-2-55c61d95f38037ca1d3e238ade534089f8e700c0.tar.gz
gentoo-2-55c61d95f38037ca1d3e238ade534089f8e700c0.tar.bz2
gentoo-2-55c61d95f38037ca1d3e238ade534089f8e700c0.zip
Version bump, add uuid use flag.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-db/recutils')
-rw-r--r--dev-db/recutils/ChangeLog8
-rw-r--r--dev-db/recutils/files/recutils-1.7-automagic.patch130
-rw-r--r--dev-db/recutils/metadata.xml3
-rw-r--r--dev-db/recutils/recutils-1.7.ebuild88
4 files changed, 227 insertions, 2 deletions
diff --git a/dev-db/recutils/ChangeLog b/dev-db/recutils/ChangeLog
index 7bea4d03c9f5..33c14d902ff1 100644
--- a/dev-db/recutils/ChangeLog
+++ b/dev-db/recutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/recutils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/recutils/ChangeLog,v 1.4 2014/03/01 22:27:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/recutils/ChangeLog,v 1.5 2014/10/31 01:40:49 radhermit Exp $
+
+*recutils-1.7 (31 Oct 2014)
+
+ 31 Oct 2014; Tim Harder <radhermit@gentoo.org> +recutils-1.7.ebuild,
+ +files/recutils-1.7-automagic.patch, metadata.xml:
+ Version bump, add uuid use flag.
01 Mar 2014; Michał Górny <mgorny@gentoo.org> recutils-1.5.ebuild:
Update libgcrypt dep to use slot :0.
diff --git a/dev-db/recutils/files/recutils-1.7-automagic.patch b/dev-db/recutils/files/recutils-1.7-automagic.patch
new file mode 100644
index 000000000000..e5d33bf87492
--- /dev/null
+++ b/dev-db/recutils/files/recutils-1.7-automagic.patch
@@ -0,0 +1,130 @@
+--- recutils-1.7/configure.ac
++++ recutils-1.7/configure.ac
+@@ -85,17 +85,32 @@
+ fi
+ AC_SUBST([CHECKLIBS])
+
++AC_ARG_ENABLE([curl],
++ AS_HELP_STRING([--enable-curl],
++ [Enable support for remote descriptors using libcurl (default is YES)]),
++ [curl_enabled=$enableval], [curl_enabled=yes])
+ have_curl=no
+-AC_CHECK_LIB([curl],[curl_global_init],[have_curl=yes],)
+-if test "x$have_curl" = "xyes"; then
+- CURLLIBS=-lcurl
++if test "x$curl_enabled" = "xyes"; then
++ AC_CHECK_LIB([curl],[curl_global_init],[have_curl=yes],)
++ if test "x$have_curl" = "xyes"; then
++ CURLLIBS=-lcurl
++ else
++ AC_MSG_ERROR([curl support enabled but libcurl not found])
++ fi
+ fi
+ AC_SUBST([CURLLIBS])
+
++AC_ARG_ENABLE([uuid],
++ AS_HELP_STRING([--enable-uuid],
++ [Compile recutils with support for uuid types (default is YES)]),
++ [uuid_enabled=$enableval], [uuid_enabled=yes])
++
+ have_uuid=no
+-AC_CHECK_LIB([uuid],[uuid_generate],[have_uuid=yes],)
+-if test "x$have_uuid" = "xyes"; then
+- UUIDLIBS=-luuid
++if test "x$uuid_enabled" = "xyes"; then
++ AC_CHECK_LIB([uuid],[uuid_generate],[have_uuid=yes],)
++ if test "x$have_uuid" = "xyes"; then
++ UUIDLIBS=-luuid
++ fi
+ fi
+ AC_SUBST([UUIDLIBS])
+ AC_SUBST([have_uuid])
+@@ -119,32 +134,42 @@
+ AM_CONDITIONAL([CRYPT], [test "x$crypt_support" = "xyes"])
+ AC_SUBST([crypt_support])
+
+-have_glib=no
+-PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.0.0],
+- [have_glib=yes], [have_glib=no])
+-
++AC_ARG_ENABLE([mdb],
++ AS_HELP_STRING([--enable-mdb],
++ [Build the mdb2rec utility (default is YES)]),
++ [mdb_enabled=$enableval], [mdb_enabled=yes])
+ have_mdb=no
+-AC_CHECK_LIB([mdb],[mdb_init],[have_mdb=yes],)
+-if test "x$have_mdb" = "xyes"; then
+- MDBLIBS=-lmdb
+-
+- OLD_CFLAGS=$CFLAGS
+- CFLAGS="$CFLAGS $pkg_cv_GLIB_CFLAGS"
+- mdb_uses_sdatetime=no
+- AC_CHECK_DECL([MDB_SDATETIME],[mdb_uses_sdatetime=yes],,[#include <glib.h>
++if test "x$mdb_enabled" = "xyes"; then
++ AC_CHECK_LIB([mdb],[mdb_init],[have_mdb=yes],)
++ if test "x$have_mdb" = "xyes"; then
++ MDBLIBS=-lmdb
++
++ OLD_CFLAGS=$CFLAGS
++ CFLAGS="$CFLAGS $pkg_cv_GLIB_CFLAGS"
++ mdb_uses_sdatetime=no
++ AC_CHECK_DECL([MDB_SDATETIME],[mdb_uses_sdatetime=yes],,[#include <glib.h>
+ #include <mdbtools.h>])
+- CFLAGS=$OLD_CFLAGS
++ CFLAGS=$OLD_CFLAGS
+
+- if test "x$mdb_uses_sdatetime" = "xyes"; then
+- MDB_DATETIME="MDB_SDATETIME"
++ if test "x$mdb_uses_sdatetime" = "xyes"; then
++ MDB_DATETIME="MDB_SDATETIME"
++ else
++ MDB_DATETIME="MDB_DATETIME"
++ fi
+ else
+- MDB_DATETIME="MDB_DATETIME"
++ AC_MSG_ERROR([mdb support enabled but libmdb not found])
+ fi
+
+ AC_SUBST([MDB_DATETIME])
+ fi
+ AC_SUBST([MDBLIBS])
+
++have_glib=no
++if test "x$mdb_enabled" = "xyes"; then
++ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.0.0],
++ [have_glib=yes], [have_glib=no])
++fi
++
+ AM_CONDITIONAL([COMPILE_MDB2REC],
+ [test "x$have_glib" = "xyes" && test "x$have_mdb" = "xyes"])
+ AM_CONDITIONAL([REMOTE_DESCRIPTORS], [test "x$have_curl" = "xyes"])
+@@ -233,29 +258,6 @@
+
+ dnl Report warnings
+
+-if test "x$have_check" = "xno"; then
+- echo "warning: libcheck was not found in the system."
+- echo "warning: unit tests wont be compiled and executed upon make check."
+-fi
+-
+-if test "x$have_mdb" = "xno"; then
+- echo "warning: libmdb was not found in the system."
+- echo "warning: the mdb2rec utility won't get built."
+-fi
+-
+-if test "x$have_glib" = "xno"; then
+- echo "warning: glib was not found in the system."
+- echo "warning: the mdb2rec utility won't get built."
+-fi
+-
+-if test "x$crypt_support" = "xno"; then
+- echo "warning: building recutils without encryption support."
+-fi
+-
+-if test "x$have_uuid" = "xno"; then
+- echo "warning: building recutils without support for uuid types."
+-fi
+-
+ if test "x$bash_headers_available" = "xno" || test "x$bash_builtins_enabled" = "xno"; then
+ echo "warning: not building the recutils bash builtins."
+ fi
diff --git a/dev-db/recutils/metadata.xml b/dev-db/recutils/metadata.xml
index 44cb46c7e324..8012f655304e 100644
--- a/dev-db/recutils/metadata.xml
+++ b/dev-db/recutils/metadata.xml
@@ -6,7 +6,8 @@
<name>Tim Harder</name>
</maintainer>
<use>
- <flag name="mdb">Build the mdb2rec utility</flag>
<flag name="curl">Enable support for remote descriptors using libcurl</flag>
+ <flag name="mdb">Build the mdb2rec utility</flag>
+ <flag name="uuid">Enable support for uuid types</flag>
</use>
</pkgmetadata>
diff --git a/dev-db/recutils/recutils-1.7.ebuild b/dev-db/recutils/recutils-1.7.ebuild
new file mode 100644
index 000000000000..0c7865cea1cc
--- /dev/null
+++ b/dev-db/recutils/recutils-1.7.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/recutils/recutils-1.7.ebuild,v 1.1 2014/10/31 01:40:49 radhermit Exp $
+
+EAPI=5
+
+inherit autotools eutils elisp-common
+
+DESCRIPTION="Tools and libraries to access human-editable, plain text databases"
+HOMEPAGE="http://www.gnu.org/software/recutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt curl emacs mdb nls static-libs +uuid"
+
+RDEPEND="sys-libs/readline
+ crypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ curl? ( net-misc/curl )
+ emacs? (
+ app-emacs/org-mode
+ virtual/emacs
+ )
+ mdb? (
+ app-office/mdbtools
+ dev-libs/glib:2
+ )
+ nls? ( virtual/libintl )
+ uuid? ( sys-apps/util-linux )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-automagic.patch
+
+ # don't unconditionally install emacs files
+ sed -i "/^dist_lisp_DATA/d" etc/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable crypt encryption) \
+ $(use_enable curl) \
+ $(use_enable mdb) \
+ $(use_enable nls) \
+ $(use_enable uuid) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile etc/*.el || die
+ fi
+}
+
+src_test() {
+ # tests have parallel issues
+ emake -j1 check
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if use emacs ; then
+ elisp-install ${PN} etc/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}