summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-10 13:59:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-10 13:59:52 +0000
commited44672f2fc6b60e99ba4edc225e4348eae98a1b (patch)
treee97e5719c34e9107e02a4a39f80f906ef4dfe3b6 /dev-db/tokyocabinet
parentFix cname issue ( bug #292545 ). EAPI2fy it (diff)
downloadgentoo-2-ed44672f2fc6b60e99ba4edc225e4348eae98a1b.tar.gz
gentoo-2-ed44672f2fc6b60e99ba4edc225e4348eae98a1b.tar.bz2
gentoo-2-ed44672f2fc6b60e99ba4edc225e4348eae98a1b.zip
Buuuump.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/tokyocabinet')
-rw-r--r--dev-db/tokyocabinet/ChangeLog8
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.38.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index 803564819445..d8e8a76a80c8 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.11 2009/11/07 18:49:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.12 2009/11/10 13:59:52 patrick Exp $
+
+*tokyocabinet-1.4.38 (10 Nov 2009)
+
+ 10 Nov 2009; Patrick Lauer <patrick@gentoo.org>
+ +tokyocabinet-1.4.38.ebuild:
+ Buuuump.
*tokyocabinet-1.4.37 (07 Nov 2009)
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.38.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.38.ebuild
new file mode 100644
index 000000000000..052f7250fc60
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.38.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.38.ebuild,v 1.1 2009/11/10 13:59:52 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://1978th.net/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86 ~x86-fbsd ~ppc-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ dodoc example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ dodoc doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}