summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-12-15 22:15:11 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-12-15 22:15:11 +0000
commite8f88338f38757fe35b6933c3e7bb2093d5119a2 (patch)
tree92b8eecf0437ad62549ebb1bd5c263947f35ebde /dev-db/unixODBC
parentautoconf-2.5 is required for hardened (diff)
downloadgentoo-2-e8f88338f38757fe35b6933c3e7bb2093d5119a2.tar.gz
gentoo-2-e8f88338f38757fe35b6933c3e7bb2093d5119a2.tar.bz2
gentoo-2-e8f88338f38757fe35b6933c3e7bb2093d5119a2.zip
fixed dependency problem via bug #35889
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/ChangeLog6
-rw-r--r--dev-db/unixODBC/Manifest10
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.6.ebuild13
3 files changed, 17 insertions, 12 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index 69e763e7cf03..5b52e12c3532 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/unixODBC
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.15 2003/12/04 20:21:35 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.16 2003/12/15 22:15:04 rphillips Exp $
+
+ 15 Dec 2003; <rphillips@gentoo.org> unixODBC-2.2.6.ebuild:
+ added Cory Visi's modified ebuild to correct the dependecy problems with
+ gODBCconfig. #35889
04 Dec 2003; Jason Wever <weeve@gentoo.org> unixODBC-2.2.6.ebuild:
Marked stable to fix dependency borkage.
diff --git a/dev-db/unixODBC/Manifest b/dev-db/unixODBC/Manifest
index 43211bda54a7..5b8e3ed89e01 100644
--- a/dev-db/unixODBC/Manifest
+++ b/dev-db/unixODBC/Manifest
@@ -1,9 +1,9 @@
-MD5 fa1fef29b02c17d406e5db8125ee0e13 ChangeLog 2073
-MD5 0bd88c25618464c75595f9e0e39195ff unixODBC-2.0.8.ebuild 1108
MD5 2352820d0c329b031a28ed77cd6be6d3 unixODBC-2.2.2.ebuild 1297
+MD5 0bd88c25618464c75595f9e0e39195ff unixODBC-2.0.8.ebuild 1108
+MD5 1594a72d3c0e7eefc68442be02cadc8c unixODBC-2.2.6.ebuild 1375
+MD5 86d045c0f47c5dd018143ee0578842fc ChangeLog 2236
MD5 059733ad92a101895ce18a1120b6eb55 metadata.xml 225
-MD5 d6ccf11bd2ea8ff46980aeb57b9f7172 unixODBC-2.2.6.ebuild 1341
-MD5 4eaaa819fc28ee784da166d14e9f7fad files/digest-unixODBC-2.2.6 67
+MD5 ffd3cee4e2a1f6dffc130557ccda934b files/gentoo-yac.diff 316
MD5 f383c7806ba5f687ba55d5f1bc6a36aa files/digest-unixODBC-2.0.8 67
MD5 0f7614b93d6ede252ed2f7d7ff1aac90 files/digest-unixODBC-2.2.2 67
-MD5 ffd3cee4e2a1f6dffc130557ccda934b files/gentoo-yac.diff 316
+MD5 4eaaa819fc28ee784da166d14e9f7fad files/digest-unixODBC-2.2.6 67
diff --git a/dev-db/unixODBC/unixODBC-2.2.6.ebuild b/dev-db/unixODBC/unixODBC-2.2.6.ebuild
index 6f156caf139d..1c07918b69f2 100644
--- a/dev-db/unixODBC/unixODBC-2.2.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6.ebuild,v 1.3 2003/12/04 20:21:35 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6.ebuild,v 1.4 2003/12/15 22:15:04 rphillips Exp $
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.unixodbc.org/"
@@ -9,12 +9,13 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~hppa ~alpha amd64 sparc"
-IUSE="qt gtk"
+IUSE="qt gnome"
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
- qt? ( >=x11-libs/qt-3.0* )"
+ qt? ( >=x11-libs/qt-3.0* )
+ gnome? ( gnome-base/gnome-libs )"
src_compile() {
local myconf
@@ -33,13 +34,13 @@ src_compile() {
make || die
- if [ "`use gtk`" ]
+ if [ "`use gnome`" ]
then
cd gODBCConfig
./configure --host=${CHOST} \
--prefix=/usr \
--sysconfdir=/etc/unixODBC \
- ${myconf} || die
+ || die
# not sure why these symlinks are needed. busted configure, i guess...
ln -s ../depcomp .
@@ -52,7 +53,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- if [ "`use gtk`" ]
+ if [ "`use gnome`" ]
then
cd gODBCConfig
make DESTDIR=${D} install || die