summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2013-05-11 15:01:26 +0000
committerChristian Ruppert <idl0r@gentoo.org>2013-05-11 15:01:26 +0000
commit4103ace8b0328f220afe301b58e74103462746e9 (patch)
tree1dcf72b0d4744af0e8f9ee07f0523051c6d34407 /dev-db/xtrabackup-bin/xtrabackup-bin-2.0.7.ebuild
parentstable amd64 arm ppc ppc64 x86, similar to rdepen sys-kernel/linux-headers-3.7 (diff)
downloadgentoo-2-4103ace8b0328f220afe301b58e74103462746e9.tar.gz
gentoo-2-4103ace8b0328f220afe301b58e74103462746e9.tar.bz2
gentoo-2-4103ace8b0328f220afe301b58e74103462746e9.zip
Version bump. Remove old version.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'dev-db/xtrabackup-bin/xtrabackup-bin-2.0.7.ebuild')
-rw-r--r--dev-db/xtrabackup-bin/xtrabackup-bin-2.0.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/xtrabackup-bin/xtrabackup-bin-2.0.7.ebuild b/dev-db/xtrabackup-bin/xtrabackup-bin-2.0.7.ebuild
new file mode 100644
index 000000000000..99fcf83ad6b7
--- /dev/null
+++ b/dev-db/xtrabackup-bin/xtrabackup-bin-2.0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xtrabackup-bin/xtrabackup-bin-2.0.7.ebuild,v 1.1 2013/05/11 15:01:26 idl0r Exp $
+
+EAPI=5
+
+MY_PN="percona-${PN/-bin}"
+MY_PVR="${PV}-552"
+MY_P="${MY_PN}-${PV}"
+MY_PF="${MY_PN}-${MY_PVR}"
+
+DESCRIPTION="MySQL hot backup software that performs non-blocking backups for
+InnoDB and XtraDB databases"
+HOMEPAGE="http://www.percona.com/software/percona-xtrabackup"
+SRC_URI="
+ amd64? (
+ http://www.percona.com/redir/downloads/XtraBackup/XtraBackup-${PV}/binary/Linux/x86_64/${MY_PF}.tar.gz -> ${MY_P}-x86_64.tar.gz
+ )
+ x86? (
+ http://www.percona.com/redir/downloads/XtraBackup/XtraBackup-${PV}/binary/Linux/i686/${MY_PF}.tar.gz -> ${MY_P}-x86_32.tar.gz
+ )
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-libs/libaio"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ for bin in xtrabackup xtrabackup_55 xbstream xtrabackup_51 innobackupex; do
+ dobin bin/${bin}
+ done
+ dosym /usr/bin/innobackupex /usr/bin/innobackupex-1.5.1
+}