summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-23 20:31:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-23 20:31:29 +0000
commit2d0d064b5835000a562eedc974814b25e0808790 (patch)
treea3b472b82f39d84ba3a6d657ca5de3fca508d3bb /dev-db
parentRemove older ebuilds in x11-plugins/wmifs... (Manifest recommit) (diff)
downloadgentoo-2-2d0d064b5835000a562eedc974814b25e0808790.tar.gz
gentoo-2-2d0d064b5835000a562eedc974814b25e0808790.tar.bz2
gentoo-2-2d0d064b5835000a562eedc974814b25e0808790.zip
Bug #60744, security.
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog10
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.58-r11
-rw-r--r--dev-db/mysql/files/digest-mysql-4.0.20-r11
-rw-r--r--dev-db/mysql/files/mysql-4.0-mysqlhotcopy-security.patch48
-rw-r--r--dev-db/mysql/mysql-3.23.58-r1.ebuild194
-rw-r--r--dev-db/mysql/mysql-4.0.20-r1.ebuild257
6 files changed, 510 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 801ae9b9c0e5..80baa657eb55 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.117 2004/08/22 08:46:26 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.118 2004/08/23 20:31:28 robbat2 Exp $
+
+*mysql-4.0.20-r1 (23 Aug 2004)
+*mysql-3.23.58-r1 (23 Aug 2004)
+
+ 23 Aug 2004; Robin H. Johnson <robbat2@gentoo.org>
+ +files/mysql-4.0-mysqlhotcopy-security.patch, +mysql-3.23.58-r1.ebuild,
+ +mysql-4.0.20-r1.ebuild:
+ Bug #60744, security.
22 Aug 2004; Joshua Kinard <kumba@gentoo.org> mysql-4.0.20.ebuild:
Marked stable on mips.
diff --git a/dev-db/mysql/files/digest-mysql-3.23.58-r1 b/dev-db/mysql/files/digest-mysql-3.23.58-r1
new file mode 100644
index 000000000000..36384becd475
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-3.23.58-r1
@@ -0,0 +1 @@
+MD5 835a96c86132fbde0db36db60c5b34cd mysql-3.23.58.tar.gz 12039843
diff --git a/dev-db/mysql/files/digest-mysql-4.0.20-r1 b/dev-db/mysql/files/digest-mysql-4.0.20-r1
new file mode 100644
index 000000000000..72e609213891
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-4.0.20-r1
@@ -0,0 +1 @@
+MD5 7c75ac74e23396bd228dbc2c2d1131df mysql-4.0.20.tar.gz 13807983
diff --git a/dev-db/mysql/files/mysql-4.0-mysqlhotcopy-security.patch b/dev-db/mysql/files/mysql-4.0-mysqlhotcopy-security.patch
new file mode 100644
index 000000000000..f2f2e74e52e6
--- /dev/null
+++ b/dev-db/mysql/files/mysql-4.0-mysqlhotcopy-security.patch
@@ -0,0 +1,48 @@
+--- 1.42/scripts/mysqlhotcopy.sh Tue May 25 21:00:12 2004
++++ 1.43/scripts/mysqlhotcopy.sh Fri Jul 9 14:30:48 2004
+@@ -8,5 +8,7 @@
+ use DBI;
+ use Sys::Hostname;
++use File::Copy;
++use File::Temp;
+
+ =head1 NAME
+
+@@ -626,7 +628,6 @@
+ sub copy_index
+ {
+ my ($method, $files, $source, $target) = @_;
+- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
+
+ print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
+ foreach my $file (@$files)
+@@ -652,21 +653,21 @@
+ }
+ close OUTPUT || die "Error on close of $to: $!\n";
+ }
+- elsif ($opt{method} eq 'scp')
++ elsif ($opt{method} =~ /^scp\b/)
+ {
+- my $tmp=$tmpfile;
+- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
+- if (syswrite(OUTPUT,$buff) != length($buff))
++ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
++ die "Can\'t create/open file in $opt_tmpdir\n";
++ if (syswrite($fh,$buff) != length($buff))
+ {
+ die "Error when writing data to $tmp: $!\n";
+ }
+- close OUTPUT || die "Error on close of $tmp: $!\n";
+- safe_system("scp $tmp $to");
++ close $fh || die "Error on close of $tmp: $!\n";
++ safe_system("$opt{method} $tmp $to");
++ unlink $tmp;
+ }
+ else
+ {
+ die "Can't use unsupported method '$opt{method}'\n";
+ }
+ }
+- unlink "$tmpfile" if ($opt{method} eq 'scp');
+ }
+
diff --git a/dev-db/mysql/mysql-3.23.58-r1.ebuild b/dev-db/mysql/mysql-3.23.58-r1.ebuild
new file mode 100644
index 000000000000..87b081a0fe4d
--- /dev/null
+++ b/dev-db/mysql/mysql-3.23.58-r1.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.58-r1.ebuild,v 1.1 2004/08/23 20:31:29 robbat2 Exp $
+
+inherit flag-o-matic eutils
+
+SVER=${PV%.*}
+#normal releases:
+SDIR=MySQL-${SVER}
+#for a pre-release:
+#SDIR=MySQL-${SVER}-Pre
+
+DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
+HOMEPAGE="http://www.mysql.com/"
+SRC_URI="ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/${SDIR}/${P}.tar.gz
+ ftp://mysql.valueclick.com/pub/mysql/Downloads/${SDIR}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~hppa ~ppc"
+IUSE="berkdb debug innodb perl readline ssl static tcpd"
+
+DEPEND="readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ >=sys-libs/zlib-1.1.3
+ dev-lang/perl
+ sys-apps/procps"
+PDEPEND="perl? ( dev-perl/DBI dev-perl/DBD-mysql )"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ # required for qmail-mysql
+ epatch ${FILESDIR}/mysql-3.23-nisam.h.diff
+ # zap startup script messages
+ epatch ${FILESDIR}/mysql-3.23.52-install-db-sh.diff
+ # zap binary distribution stuff
+ epatch ${FILESDIR}/mysql-3.23-safe-mysqld-sh.diff
+ # for correct hardcoded sysconf directory
+ epatch ${FILESDIR}/mysql-3.23-my-print-defaults.diff
+ #patch -p1 < ${FILESDIR}/mysql-3.23.51-tcpd.patch || die
+ #epatch ${FILESDIR}/mysql-4.0.14-security-28394.patch
+
+ # security fix from http://lists.mysql.com/internals/15185
+ # gentoo bug #60744
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-4.0-mysqlhotcopy-security.patch
+
+}
+
+src_compile() {
+ # bug #11681; get b0rked code when using -march=k6 with this package.
+ replace-cpu-flags i586 k6 k6-2 k6-3
+
+ local myconf
+ # The following fix is due to a bug with bdb on sparc's. See:
+ # http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
+ # same for alpha (see http://www.mysql.com/doc/en/BDB_portability.html)
+ # thanks to peter@icebear.net for noticing this.
+ if use sparc || use alpha || use hppa
+ then
+ myconf="${myconf} --without-berkeley-db"
+ else
+ use berkdb && myconf="${myconf} --with-berkeley-db=./bdb" \
+ || myconf="${myconf} --without-berkeley-db"
+ fi
+ #readline pair reads backwards on purpose, DONT change it around, Ok?
+ use readline && myconf="${myconf} --without-readline"
+ use readline || myconf="${myconf} --with-readline"
+ use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
+ use static || myconf="${myconf} --enable-shared --enable-static"
+ use tcpd && myconf="${myconf} --with-libwrap"
+ use tcpd || myconf="${myconf} --without-libwrap"
+ use innodb && myconf="${myconf} --with-innodb"
+ use innodb || myconf="${myconf} --without-innodb"
+ use ssl && myconf="${myconf} --with-vio --with-openssl"
+ use ssl || myconf="${myconf} --without-openssl"
+ myconf="${myconf} `use_with debug`"
+
+ #glibc-2.3.2_pre fix; bug #16496
+ export CFLAGS="${CFLAGS} -DHAVE_ERRNO_AS_DEFINE=1"
+ export CXXFLAGS="${CXXFLAGS} -DHAVE_ERRNO_AS_DEFINE=1"
+
+ # the compiler flags are as per their "official" spec ;-)
+ einfo "\$myconf is $myconf"
+ CFLAGS="${CFLAGS/-O?/} -O3" \
+ CXXFLAGS="${CXXFLAGS/-O?/} -O3 -felide-constructors -fno-exceptions -fno-rtti" \
+ econf \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/lib/mysql \
+ --with-raid \
+ --with-low-memory \
+ --enable-assembler \
+ --with-charset=latin1 \
+ --enable-local-infile \
+ --with-mysqld-user=mysql \
+ --with-extra-charsets=all \
+ --enable-thread-safe-client \
+ --with-client-ldflags=-lstdc++ \
+ --with-comment="Gentoo Linux ${PF}" \
+ --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
+ ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
+
+ # eeek, not sure whats going on here.. are these needed by anything?
+ #use innodb && insinto /usr/lib/mysql && doins ${WORKDIR}/../libs/*
+
+ # move client libs, install a couple of missing headers
+ mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
+ dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
+ dosym ../libmysqlclient_r.so /usr/lib/mysql/libmysqlclient_r.so
+ insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
+
+ # convenience links
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
+
+ # various junk
+ rm -f ${D}/usr/share/mysql/binary-configure
+ rm -f ${D}/usr/share/mysql/mysql.server
+ rm -f ${D}/usr/share/mysql/make_binary_distribution
+ rm -f ${D}/usr/share/mysql/mi_test_all*
+ rm -f ${D}/usr/share/mysql/mysql-log-rotate
+ rm -f ${D}/usr/share/mysql/mysql*.spec
+ rm -f ${D}/usr/share/mysql/my-*.cnf
+
+ #hmm what about all the very nice benchmark/test scripts
+ #in /usr/share/mysql/sql-bench
+ if ! use perl; then
+ rm -f ${D}/usr/bin/mysql_setpermission
+ fi
+
+ dodoc README MIRRORS Docs/{manual.ps,manual.txt}
+ dohtml -r Docs/*
+ docinto conf-samples
+ dodoc support-files/my-*.cnf
+
+ insinto /etc/mysql
+ doins ${FILESDIR}/my.cnf scripts/mysqlaccess.conf
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mysql.init mysql
+}
+
+pkg_config() {
+ if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
+ einfo "Press ENTER to create the mysql database and set proper"
+ einfo "permissions on it, or Control-C to abort now..."
+ read
+ ${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
+ else
+ einfo "Hmm, it appears as though you already have the mysql"
+ einfo "database in place. If you are having problems trying"
+ einfo "to start mysqld, perhaps you need to manually run"
+ einfo "/usr/bin/mysql_install_db and/or check your config"
+ einfo "file(s) and/or database(s) and/or logfile(s)."
+ fi
+}
+
+pkg_preinst() {
+ if ! groupmod mysql; then
+ groupadd -g 60 mysql || die "problem adding group mysql"
+ fi
+
+ if ! id mysql; then
+ useradd -g mysql -s /dev/null -d /var/lib/mysql -c "mysql" mysql
+ assert "problem adding user mysql"
+ fi
+}
+
+pkg_postinst() {
+ # empty dirs...
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/lib/mysql
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+ # secure the logfiles... does this bother anybody?
+ touch ${ROOT}/var/log/mysql/mysql.{log,err}
+ chown mysql:mysql ${ROOT}/var/log/mysql/mysql.{log,err}
+ chmod 0660 ${ROOT}/var/log/mysql/mysql.{log,err}
+
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
+ einfo "if this is a new install."
+ einfo
+}
diff --git a/dev-db/mysql/mysql-4.0.20-r1.ebuild b/dev-db/mysql/mysql-4.0.20-r1.ebuild
new file mode 100644
index 000000000000..c709ce24b126
--- /dev/null
+++ b/dev-db/mysql/mysql-4.0.20-r1.ebuild
@@ -0,0 +1,257 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.20-r1.ebuild,v 1.1 2004/08/23 20:31:29 robbat2 Exp $
+
+inherit eutils gnuconfig
+#to accomodate -laadeedah releases
+NEWP=${P}
+
+SVER=${PV%.*}
+#normal releases:
+SDIR=MySQL-${SVER}
+#for a pre-release:
+#SDIR=MySQL-${SVER}-Pre
+
+S=${WORKDIR}/${NEWP}
+
+DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
+HOMEPAGE="http://www.mysql.com/"
+SRC_URI="mirror://mysql/Downloads/${SDIR}/${NEWP}.tar.gz"
+RESTRICT="nomirror"
+
+KEYWORDS="~ia64 ~x86 ~sparc ~ppc ~amd64 ~hppa ~alpha ~mips ~s390 ~arm ~ppc64"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="static readline innodb berkdb tcpd ssl perl debug"
+
+DEPEND="readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( dev-lang/perl )
+ >=sys-libs/zlib-1.1.3
+ sys-apps/procps
+ >=sys-apps/sed-4"
+PDEPEND="perl? ( dev-perl/DBI dev-perl/DBD-mysql )"
+
+warning() {
+ ewarn
+ ewarn "If you're upgrading from MySQL-3.x, you must recompile the other"
+ ewarn "packages on your system that link with libmysqlclient after the"
+ ewarn "upgrade completes. To obtain such a list of packages for your"
+ ewarn "system, you may use 'revdep-rebuild' from app-portage/gentoolkit."
+ ewarn
+ sleep 5
+}
+
+pkg_setup() {
+ warning
+}
+
+src_unpack() {
+ if use static && use ssl; then
+ local msg="MySQL does not support building statically with SSL support"
+ eerror "${msg}"
+ die "${msg}"
+ fi
+ unpack ${A} || die
+
+ #zap startup script messages
+ EPATCH_OPTS="-p1 -d ${S}" \
+ epatch ${FILESDIR}/${PN}-4.0.18-install-db-sh.diff
+ #zap binary distribution stuff
+ EPATCH_OPTS="-p1 -d ${S}" \
+ epatch ${FILESDIR}/${PN}-4.0.18-mysqld-safe-sh.diff
+ #required for qmail-mysql
+ EPATCH_OPTS="-p0 -d ${S}" \
+ epatch ${FILESDIR}/${PN}-4.0-nisam.h.diff
+ #for correct hardcoded sysconf directory
+ EPATCH_OPTS="-p1 -d ${S}" \
+ epatch ${FILESDIR}/${PN}-4.0-my-print-defaults.diff
+ #
+ EPATCH_OPTS="-p1 -d ${S}" \
+ epatch ${FILESDIR}/${PN}-4.0.18-gentoo-nptl.diff
+
+ # attempt to get libmysqlclient_r linked against ssl if USE="ssl" enabled
+ # i would really prefer to fix this at the Makefile.am level, but can't
+ # get the software to autoreconf as distributed - too many missing files
+ EPATCH_OPTS="-p1 -d ${S}" \
+ epatch ${FILESDIR}/${PN}-4.0.18-thrssl.patch
+
+ # Security fix for bug #46242, upstream fix pending for 4.0.19
+ #EPATCH_OPTS="-p1 -d ${S}" \
+ #epatch ${FILESDIR}/${PN}-4.0.18-mysqlbugsecurity.diff
+ #EPATCH_OPTS="-p1 -d ${S}" \
+ #epatch ${FILESDIR}/${PN}-4.0.18-mysqldmultisecurity.diff
+
+ if use tcpd; then
+ EPATCH_OPTS="-p1 -d ${S}" \
+ epatch ${FILESDIR}/${PN}-4.0.14-r1-tcpd-vars-fix.diff
+ fi
+
+ # security fix from http://lists.mysql.com/internals/15185
+ # gentoo bug #60744
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-4.0-mysqlhotcopy-security.patch
+
+ cd ${S}
+ autoconf
+ #WANT_AUTOMAKE=1.7 automake
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf
+
+ #The following fix is due to a bug with bdb on sparc's. See:
+ #http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
+ if use sparc || use alpha || use hppa || use mips
+ then
+ myconf="${myconf} --without-berkeley-db"
+ else
+ use berkdb \
+ && myconf="${myconf} --with-berkeley-db=./bdb" \
+ || myconf="${myconf} --without-berkeley-db"
+ fi
+
+ #readline pair reads backwards on purpose, DONT change it around, Ok?
+ # this is because it refers to the building of a bundled readline
+ # versus the system copy
+ use readline && myconf="${myconf} --without-readline"
+ use readline || myconf="${myconf} --with-readline"
+
+ use static \
+ && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared" \
+ || myconf="${myconf} --enable-shared --enable-static"
+
+ myconf="${myconf} `use_with tcpd libwrap`"
+ myconf="${myconf} `use_with innodb`"
+
+ use ssl \
+ && myconf="${myconf} --with-vio --with-openssl" \
+ || myconf="${myconf} --without-openssl"
+
+ myconf="${myconf} `use_with debug`"
+
+ #glibc-2.3.2_pre fix; bug #16496
+ export CFLAGS="${CFLAGS} -DHAVE_ERRNO_AS_DEFINE=1"
+
+ #bug fix for #15099, should make this api backward compatible
+ export CFLAGS="${CFLAGS} -DUSE_OLD_FUNCTIONS"
+
+ #the compiler flags are as per their "official" spec ;)
+ #CFLAGS="${CFLAGS/-O?/} -O3" \
+ CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-exceptions -fno-rtti" \
+ econf \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/lib/mysql \
+ --with-raid \
+ --with-low-memory \
+ --enable-assembler \
+ --with-charset=latin1 \
+ --enable-local-infile \
+ --with-mysqld-user=mysql \
+ --with-extra-charsets=all \
+ --enable-thread-safe-client \
+ --with-client-ldflags=-lstdc++ \
+ --with-comment="Gentoo Linux ${PF}" \
+ --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
+ --with-embedded-server \
+ ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
+
+ #move client libs, install a couple of missing headers
+ mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
+ dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
+ dosym ../libmysqlclient_r.so /usr/lib/mysql/libmysqlclient_r.so
+ insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
+
+ #convenience links
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
+ dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
+
+ #various junk
+ rm -f ${D}/usr/share/mysql/mysql.server
+ rm -f ${D}/usr/share/mysql/binary-configure
+ rm -f ${D}/usr/share/mysql/make_binary_distribution
+ rm -f ${D}/usr/share/mysql/mysql-log-rotate
+ rm -f ${D}/usr/share/mysql/{post,pre}install
+ rm -f ${D}/usr/share/mysql/mi_test*
+ rm -f ${D}/usr/share/mysql/*.spec # Redhat gunk
+ rm -f ${D}/usr/share/mysql/*.plist # Apple gunk
+ rm -f ${D}/usr/share/mysql/my-*.cnf # Put them elsewhere
+
+ # All of these (ab)use Perl.
+ if ! use perl; then
+ rm -f ${D}/usr/bin/mysql_setpermission
+ rm -rf ${D}/usr/share/mysql/sql-bench
+ fi
+
+ dohtml Docs/*.html
+ rm -f Docs/*.html
+ dodoc README COPYING COPYING.LIB Docs/manual.*
+ docinto conf-samples
+ dodoc support-files/my-*.cnf
+
+ insinto /etc/mysql
+ newins ${FILESDIR}/my.cnf-4.0.14-r1 my.cnf
+ doins scripts/mysqlaccess.conf
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mysql-4.0.15.rc6 mysql
+}
+
+pkg_config() {
+ if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
+ einfo "Press ENTER to create the mysql database and set proper"
+ einfo "permissions on it, or Control-C to abort now..."
+ read
+ ${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
+ # changing ownership of newly created databases to mysql.mysql
+ local DATADIR=""
+ if [ -f '/etc/mysql/my.cnf' ] ; then
+ #DATADIR=`grep ^datadir /etc/mysql/my.cnf | sed -e 's/.*= //'`
+ DATADIR=`/usr/sbin/mysqld --help |grep '^datadir' | awk '{print $2}'`
+ fi
+ if [ -z "${DATADIR}" ]; then
+ DATADIR="/var/lib/mysql/"
+ fi
+ chown -R mysql:mysql ${DATADIR}
+ else
+ einfo "Hmm, it appears as though you already have the mysql"
+ einfo "database in place. If you are having problems trying"
+ einfo "to start mysqld, perhaps you need to manually run"
+ einfo "/usr/bin/mysql_install_db and/or check your config"
+ einfo "file(s) and/or database(s) and/or logfile(s)."
+ fi
+}
+
+pkg_preinst() {
+ enewgroup mysql 60 || die "problem adding group mysql"
+ enewuser mysql 60 /dev/null /var/lib/mysql mysql || die "problem adding user mysql"
+}
+
+pkg_postinst() {
+ #empty dirs...
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/lib/mysql
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
+ install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+ #secure the logfiles... does this bother anybody?
+ touch ${ROOT}/var/log/mysql/mysql.{log,err}
+ chown mysql:mysql ${ROOT}/var/log/mysql/mysql.{log,err}
+ chmod 0660 ${ROOT}/var/log/mysql/mysql.{log,err}
+
+ #your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
+ einfo "if this is a new install."
+ einfo
+
+ warning
+}