summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2009-06-11 08:43:32 +0000
committerAlistair Bush <ali_bush@gentoo.org>2009-06-11 08:43:32 +0000
commit2ef31906b00ad2ec74b1460e3bedfb81a6b2cdb8 (patch)
treeaab21bcaf60d78f5feaa99c1b7585232cce19849 /dev-db
parentFix Manifest (#273670) (diff)
downloadgentoo-2-2ef31906b00ad2ec74b1460e3bedfb81a6b2cdb8.tar.gz
gentoo-2-2ef31906b00ad2ec74b1460e3bedfb81a6b2cdb8.tar.bz2
gentoo-2-2ef31906b00ad2ec74b1460e3bedfb81a6b2cdb8.zip
Version bump on behalf of wtljr.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/flamerobin/ChangeLog7
-rw-r--r--dev-db/flamerobin/flamerobin-0.9.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-db/flamerobin/ChangeLog b/dev-db/flamerobin/ChangeLog
index 1e406648900e..330a31871307 100644
--- a/dev-db/flamerobin/ChangeLog
+++ b/dev-db/flamerobin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/flamerobin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/ChangeLog,v 1.15 2009/04/08 22:37:46 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/ChangeLog,v 1.16 2009/06/11 08:43:32 ali_bush Exp $
+
+*flamerobin-0.9.2 (11 Jun 2009)
+
+ 11 Jun 2009; Alistair Bush <ali_bush@gentoo.org> +flamerobin-0.9.2.ebuild:
+ Version bump on behalf of wtljr.
08 Apr 2009; Christian Faulhammer <fauli@gentoo.org>
flamerobin-0.8.3.ebuild, flamerobin-0.8.6.ebuild:
diff --git a/dev-db/flamerobin/flamerobin-0.9.2.ebuild b/dev-db/flamerobin/flamerobin-0.9.2.ebuild
new file mode 100644
index 000000000000..5b8deab6ba08
--- /dev/null
+++ b/dev-db/flamerobin/flamerobin-0.9.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/flamerobin/flamerobin-0.9.2.ebuild,v 1.1 2009/06/11 08:43:32 ali_bush Exp $
+
+EAPI=1
+
+inherit eutils wxwidgets
+
+DESCRIPTION="A database administration tool for Firebird DBMS"
+HOMEPAGE="http://www.flamerobin.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="x11-libs/wxGTK:2.8
+ dev-db/firebird"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+pkg_setup() {
+ export WX_GTK_VER="2.8"
+ need-wxwidgets gtk2
+}
+src_compile() {
+ # temp hack since configure is not executable
+ chmod +x configure
+
+ local myconf
+ myconf="${myconf} \
+ --disable-shared \
+ --disable-debug \
+ --with-wx=yes \
+ --with-wx-config=${WX_CONFIG}"
+ econf ${myconf} || die "Could not configure FlameRobin"
+ emake || die "error during make"
+}
+src_install() {
+ make DESTDIR="${D}" install || die "Could not install FlameRobin"
+
+ doicon "${S}"/res/fricon.xpm
+ domenu "${FILESDIR}"/FlameRobin.desktop
+
+ dodoc devdocs/* docs/* docs-src/*
+}