summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-02-26 11:07:13 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-02-26 11:07:13 +0000
commit47b377e1961ad4d1de649ede40050cc374cc2326 (patch)
tree16d9339951d5c25eca29cc1c316750dfe566a544 /dev-db
parentFix build failure with mozjs17, bug #499980. (diff)
downloadgentoo-2-47b377e1961ad4d1de649ede40050cc374cc2326.tar.gz
gentoo-2-47b377e1961ad4d1de649ede40050cc374cc2326.tar.bz2
gentoo-2-47b377e1961ad4d1de649ede40050cc374cc2326.zip
version bump fix #502486, drop old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/redis/ChangeLog8
-rw-r--r--dev-db/redis/redis-2.6.15.ebuild106
-rw-r--r--dev-db/redis/redis-2.8.6.ebuild (renamed from dev-db/redis/redis-2.8.3.ebuild)6
3 files changed, 10 insertions, 110 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index 44cb4c860a22..93e7a7fab58f 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/redis
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.74 2014/02/07 19:44:23 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.75 2014/02/26 11:07:13 ultrabug Exp $
+
+*redis-2.8.6 (26 Feb 2014)
+
+ 26 Feb 2014; Ultrabug <ultrabug@gentoo.org> -redis-2.6.15.ebuild,
+ -redis-2.8.3.ebuild, +redis-2.8.6.ebuild:
+ version bump fix #502486, drop old
*redis-2.8.5 (07 Feb 2014)
diff --git a/dev-db/redis/redis-2.6.15.ebuild b/dev-db/redis/redis-2.6.15.ebuild
deleted file mode 100644
index 5c537d01cc99..000000000000
--- a/dev-db/redis/redis-2.6.15.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.6.15.ebuild,v 1.1 2013/08/26 11:47:13 djc Exp $
-
-EAPI=5
-
-inherit autotools eutils flag-o-matic toolchain-funcs user
-
-DESCRIPTION="A persistent caching system, key-value and data structures database."
-HOMEPAGE="http://redis.io/"
-SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
-IUSE="+jemalloc tcmalloc test"
-SLOT="0"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- jemalloc? ( >=dev-libs/jemalloc-3.2 )"
-DEPEND=">=sys-devel/autoconf-2.63
- test? ( dev-lang/tcl )
- ${RDEPEND}"
-REQUIRED_USE="tcmalloc? ( !jemalloc )
- jemalloc? ( !tcmalloc )"
-
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-pkg_setup() {
- enewgroup redis 75
- enewuser redis 75 -1 /var/lib/redis redis
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.6.7"-{shared,config}.patch
-
- # bug 467172, 467174
- sed -i -e 's:AR=:AR?=:g' -e 's:RANLIB=:RANLIB?=:g' "${S}/deps/lua/src/Makefile" || die
-
- # now we will rewrite present Makefiles
- local makefiles=""
- for MKF in $(find -name 'Makefile' | cut -b 3-); do
- mv "${MKF}" "${MKF}.in"
- sed -i -e 's:$(CC):@CC@:g' \
- -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
- -e 's: $(DEBUG)::g' \
- -e 's:$(OBJARCH)::g' \
- -e 's:ARCH:TARCH:g' \
- -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
- "${MKF}.in" \
- || die "Sed failed for ${MKF}"
- makefiles+=" ${MKF}"
- done
- # autodetection of compiler and settings; generates the modified Makefiles
- cp "${FILESDIR}"/configure.ac-2.2 configure.ac
- sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
- configure.ac || die "Sed failed for configure.ac"
- eautoconf
-}
-
-src_configure() {
- econf
-
- # Linenoise can't be built with -std=c99, see https://bugs.gentoo.org/451164
- # also, don't define ANSI/c99 for lua twice
- sed -i -e "s:-std=c99::g" deps/linenoise/Makefile deps/Makefile || die
-}
-
-src_compile() {
- tc-export CC AR RANLIB
-
- local myconf=""
-
- if use tcmalloc ; then
- myconf="${myconf} USE_TCMALLOC=yes"
- elif use jemalloc ; then
- myconf="${myconf} JEMALLOC_SHARED=yes"
- else
- myconf="${myconf} MALLOC=yes"
- fi
-
- emake ${myconf} V=1 CC="${CC}" AR="${AR} rcu" RANLIB="${RANLIB}"
-}
-
-src_install() {
- insinto /etc/
- doins redis.conf sentinel.conf
- use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
- fperms 0644 /etc/{redis,sentinel}.conf
-
- newconfd "${FILESDIR}/redis.confd" redis
- newinitd "${FILESDIR}/redis.initd-3" redis
-
- nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
-
- dobin src/redis-cli
- dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
- fperms 0750 /usr/sbin/redis-benchmark
- dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
-
- if use prefix; then
- diropts -m0750
- else
- diropts -m0750 -o redis -g redis
- fi
- keepdir /var/{log,lib}/redis
-}
diff --git a/dev-db/redis/redis-2.8.3.ebuild b/dev-db/redis/redis-2.8.6.ebuild
index 429d59e1c97c..afe138c8b1c3 100644
--- a/dev-db/redis/redis-2.8.3.ebuild
+++ b/dev-db/redis/redis-2.8.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.3.ebuild,v 1.1 2013/12/17 21:47:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.8.6.ebuild,v 1.1 2014/02/26 11:07:13 ultrabug Exp $
EAPI=5
@@ -31,7 +31,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${P}"-{shared,config}.patch
+ epatch "${FILESDIR}"/${PN}-2.8.3-{shared,config}.patch
# bug 467172, 467174
sed -i -e 's:AR=:AR?=:g' -e 's:RANLIB=:RANLIB?=:g' "${S}/deps/lua/src/Makefile" || die