summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-03 16:27:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-03 16:27:59 +0000
commit5c91a007a74bdb30d10f1a90a8b9bbb798884ceb (patch)
treefdd576007202e6530cb163720c8332b000995008 /dev-db
parentStable for HPPA (bug #287292). (diff)
downloadgentoo-2-5c91a007a74bdb30d10f1a90a8b9bbb798884ceb.tar.gz
gentoo-2-5c91a007a74bdb30d10f1a90a8b9bbb798884ceb.tar.bz2
gentoo-2-5c91a007a74bdb30d10f1a90a8b9bbb798884ceb.zip
Bump to 7.4.26
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql-base/ChangeLog9
-rw-r--r--dev-db/postgresql-base/files/postgresql-7.4.26-autoconf.patch48
-rw-r--r--dev-db/postgresql-base/postgresql-base-7.4.26.ebuild148
3 files changed, 204 insertions, 1 deletions
diff --git a/dev-db/postgresql-base/ChangeLog b/dev-db/postgresql-base/ChangeLog
index 7401b4ba61a3..fc4f5726147c 100644
--- a/dev-db/postgresql-base/ChangeLog
+++ b/dev-db/postgresql-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/postgresql-base
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.25 2009/10/01 20:48:40 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/ChangeLog,v 1.26 2009/10/03 16:27:59 patrick Exp $
+
+*postgresql-base-7.4.26 (03 Oct 2009)
+
+ 03 Oct 2009; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-base-7.4.26.ebuild, +files/postgresql-7.4.26-autoconf.patch:
+ Bump to 7.4.26, fixes half of #286700. Thanks to Aaron W. Swenson for
+ testing and patching.
01 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
postgresql-base-8.4.1.ebuild:
diff --git a/dev-db/postgresql-base/files/postgresql-7.4.26-autoconf.patch b/dev-db/postgresql-base/files/postgresql-7.4.26-autoconf.patch
new file mode 100644
index 000000000000..808370cbc4f0
--- /dev/null
+++ b/dev-db/postgresql-base/files/postgresql-7.4.26-autoconf.patch
@@ -0,0 +1,48 @@
+diff --git a/config/programs.m4 b/config/programs.m4
+index ae3b91a..6af24d2 100644
+--- a/config/programs.m4
++++ b/config/programs.m4
+@@ -153,13 +153,13 @@ AC_DEFUN([PGAC_CHECK_GETTEXT],
+ dnl FIXME: We should probably check for version >=0.10.36.
+ AC_CHECK_PROGS(XGETTEXT, xgettext)
+
+- # Note: share/locale is always the default, independent of $datadir
+- localedir='${prefix}/share/locale'
+- if test x"$prefix" = x"NONE"; then
+- exp_localedir="$ac_default_prefix/share/locale"
+- else
+- exp_localedir="$prefix/share/locale"
+- fi
++ # Note: share/locale *WAS* always the default, independent of $datadir
++ AC_ARG_WITH([locale-dir],
++ AC_HELP_STRING([--with-locale-dir],[Set path to locale files]),
++ [ localedir="${withval}" ],
++ [ localedir='${prefix}/share/locale' ]
++ )
++ exp_localedir="${localedir}"
+
+ AC_SUBST(localedir)
+ AC_DEFINE_UNQUOTED(LOCALEDIR, ["$exp_localedir"],
+diff --git a/configure.in b/configure.in
+index f7bdec3..c8b5b7e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -19,17 +19,8 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros
+ dnl
+ dnl The GNU folks apparently haven't heard that some people don't use
+ dnl Texinfo. Use this sorcery to use "docdir" instead of "infodir".
+-m4_define([info], [doc])
+-m4_define([infodir], [docdir])
+ AC_INIT([PostgreSQL], [7.4.26], [pgsql-bugs@postgresql.org])
+-m4_undefine([infodir])
+-m4_undefine([info])
+-AC_SUBST(docdir)
+-
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.53], [], [m4_fatal([Autoconf version 2.53 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
++
+ AC_COPYRIGHT([Copyright 2004 PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
diff --git a/dev-db/postgresql-base/postgresql-base-7.4.26.ebuild b/dev-db/postgresql-base/postgresql-base-7.4.26.ebuild
new file mode 100644
index 000000000000..f9858b455d09
--- /dev/null
+++ b/dev-db/postgresql-base/postgresql-base-7.4.26.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-7.4.26.ebuild,v 1.1 2009/10/03 16:27:59 patrick Exp $
+
+EAPI="1"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="none"
+
+inherit eutils multilib toolchain-funcs versionator autotools
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PostgreSQL libraries and clients"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE_LINGUAS="
+ linguas_cs linguas_de linguas_es linguas_fr linguas_hr linguas_hu
+ linguas_it linguas_nb linguas_pt_BR linguas_ru linguas_sl linguas_sv
+ linguas_tr linguas_zh_CN linguas_zh_TW"
+IUSE="doc kerberos nls pam pg-intdatetime readline ssl threads zlib ${IUSE_LINGUAS}"
+RESTRICT="test"
+
+wanted_languages() {
+ for u in ${IUSE_LINGUAS} ; do
+ use $u && echo -n "${u#linguas_} "
+ done
+}
+
+RDEPEND="kerberos? ( virtual/krb5 )
+ pam? ( virtual/pam )
+ readline? ( >=sys-libs/readline-4.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ >=app-admin/eselect-postgresql-0.3
+ !dev-db/postgresql-libs
+ !dev-db/postgresql-client
+ !dev-db/libpq
+ !dev-db/postgresql"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-devel/bison-1.875
+ nls? ( sys-devel/gettext )"
+PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
+
+S="${WORKDIR}/postgresql-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/postgresql-${PV}-autoconf.patch" \
+ "${FILESDIR}/postgresql-${SLOT}-hppa.patch" \
+ "${FILESDIR}/postgresql-${SLOT}-base.patch"
+
+ # to avoid collision - it only should be installed by server
+ rm "${S}/src/backend/nls.mk"
+
+ # because psql/help.c includes the file
+ ln -s "${S}/src/include/libpq/pqsignal.h" "${S}/src/bin/psql/"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \
+ --datadir=/usr/share/postgresql-${SLOT} \
+ --sysconfdir=/etc/postgresql-${SLOT} \
+ --includedir=/usr/include/postgresql-${SLOT} \
+ --with-locale-dir=/usr/share/postgresql-${SLOT}/locale \
+ --mandir=/usr/share/postgresql-${SLOT}/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${PF} \
+ --without-tcl \
+ --without-perl \
+ --without-python \
+ $(use_with kerberos krb5) \
+ "$(use_enable nls nls "$(wanted_languages)")" \
+ $(use_with pam) \
+ $(use_enable pg-intdatetime integer-datetimes ) \
+ $(use_with readline) \
+ $(use_with ssl openssl) \
+ $(use_enable threads thread-safety ) \
+ $(use_with zlib) \
+ || die "configure failed"
+
+ emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
+
+ cd "${S}/contrib"
+ emake LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto /usr/include/postgresql-${SLOT}/postmaster
+ doins "${S}"/src/include/postmaster/*.h
+
+ # Install missing libpgport.a
+ insinto /usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)
+ doins "${S}/src/port/libpgport.a"
+
+ dodir /usr/share/postgresql-${SLOT}/man/man1
+ tar -zxf "${S}/doc/man.tar.gz" -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1
+
+ rm -rf "${D}/usr/share/doc/${PF}/html"
+ rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,initlocation,ipcclean,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster}.1
+ dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+ cd "${S}/contrib"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ cd "${S}"
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+
+ IDIR="/usr/include/postgresql-${SLOT}"
+ cat > "${D}/etc/eselect/postgresql/slots/${SLOT}/base" <<-__EOF__
+postgres_ebuilds="\${postgres_ebuilds} ${PF}"
+postgres_prefix=/usr/$(get_libdir)/postgresql-${SLOT}
+postgres_datadir=/usr/share/postgresql-${SLOT}
+postgres_bindir=/usr/$(get_libdir)/postgresql-${SLOT}/bin
+postgres_symlinks=(
+ ${IDIR} /usr/include/postgresql
+ ${IDIR}/libpq-fe.h /usr/include/libpq-fe.h
+ ${IDIR}/libpq /usr/include/libpq
+ ${IDIR}/postgres_ext.h /usr/include/postgres_ext.h
+)
+__EOF__
+
+ cat >"${T}/50postgresql-98-${SLOT}" <<-__EOF__
+ LDPATH=/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)
+ MANPATH=/usr/share/postgresql-${SLOT}/man
+ __EOF__
+ doenvd "${T}/50postgresql-98-${SLOT}"
+
+ keepdir /etc/postgresql-${SLOT}
+}
+
+pkg_postinst() {
+ eselect postgresql update
+ [[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+ elog "If you need a global psqlrc-file, you can place it in '${ROOT}/etc/postgresql-${SLOT}/'."
+}
+
+pkg_postrm() {
+ eselect postgresql update
+}