summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-02-24 23:37:52 +0000
committerZac Medico <zmedico@gentoo.org>2015-02-24 23:37:52 +0000
commit65035a3af4c066bdfa01f293b6b504a6420e4830 (patch)
treebff8557b19d8f31684c22dedb9d4582b91179286 /dev-db
parentFix #541092 thanks to felix.janda@posteo.de and remove old versions (diff)
downloadgentoo-2-65035a3af4c066bdfa01f293b6b504a6420e4830.tar.gz
gentoo-2-65035a3af4c066bdfa01f293b6b504a6420e4830.tar.bz2
gentoo-2-65035a3af4c066bdfa01f293b6b504a6420e4830.zip
Install in src instead of src/pkg for go-1.4. Thanks to William Hubbs <williamh@gentoo.org> for the fix (bug 541284).
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xAE5719A3)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/go-etcd/ChangeLog8
-rw-r--r--dev-db/go-etcd/go-etcd-0_p20141013.ebuild12
2 files changed, 12 insertions, 8 deletions
diff --git a/dev-db/go-etcd/ChangeLog b/dev-db/go-etcd/ChangeLog
index 166d55412133..ebf625838422 100644
--- a/dev-db/go-etcd/ChangeLog
+++ b/dev-db/go-etcd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/go-etcd
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/go-etcd/ChangeLog,v 1.1 2014/10/16 00:13:51 zmedico Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/go-etcd/ChangeLog,v 1.2 2015/02/24 23:37:52 zmedico Exp $
+
+ 24 Feb 2015; Zac Medico <zmedico@gentoo.org> go-etcd-0_p20141013.ebuild:
+ Install in src instead of src/pkg for go-1.4. Thanks to William Hubbs
+ <williamh@gentoo.org> for the fix (bug 541284).
*go-etcd-0_p20141013 (16 Oct 2014)
diff --git a/dev-db/go-etcd/go-etcd-0_p20141013.ebuild b/dev-db/go-etcd/go-etcd-0_p20141013.ebuild
index 2dc3178e9075..78361195a1db 100644
--- a/dev-db/go-etcd/go-etcd-0_p20141013.ebuild
+++ b/dev-db/go-etcd/go-etcd-0_p20141013.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/go-etcd/go-etcd-0_p20141013.ebuild,v 1.1 2014/10/16 00:13:51 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/go-etcd/go-etcd-0_p20141013.ebuild,v 1.2 2015/02/24 23:37:52 zmedico Exp $
EAPI=5
@@ -9,11 +9,11 @@ DESCRIPTION="Go client library for etcd"
GO_PN=github.com/coreos/${PN}
HOMEPAGE="https://${GO_PN}"
EGIT_COMMIT="25e2c63be8e8ab405014a78879e0992ae5ff55e8"
-SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.zip -> ${P}.zip"
+SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
-DEPEND=">=dev-lang/go-1.3"
+DEPEND=">=dev-lang/go-1.4"
RDEPEND=""
S=${WORKDIR}
@@ -27,7 +27,7 @@ src_compile() {
# Create a filtered GOROOT tree out of symlinks,
# excluding go-etcd, for bug #503324.
cp -sR /usr/lib/go goroot || die
- rm -rf goroot/src/pkg/${GO_PN} || die
+ rm -rf goroot/src/${GO_PN} || die
rm -rf goroot/pkg/linux_${ARCH}/${GO_PN} || die
GOROOT=${WORKDIR}/goroot GOPATH=${WORKDIR} \
go install -x ${GO_PN}/etcd || die
@@ -36,7 +36,7 @@ src_compile() {
src_install() {
insinto /usr/lib/go
doins -r pkg
- insinto /usr/lib/go/src/pkg
+ insinto /usr/lib/go/src
find src/${GO_PN} -name .gitignore -delete
doins -r src/*
}