summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-02 16:11:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-02 16:11:45 +0000
commit6dd1861d26c964f0e472affa2e2b8bb4dbe7ef71 (patch)
tree493ea934e2a30f9279e19864cc71e8272225e255 /dev-db
parentFix compilation with Qt 5.5 (diff)
downloadgentoo-2-6dd1861d26c964f0e472affa2e2b8bb4dbe7ef71.tar.gz
gentoo-2-6dd1861d26c964f0e472affa2e2b8bb4dbe7ef71.tar.bz2
gentoo-2-6dd1861d26c964f0e472affa2e2b8bb4dbe7ef71.zip
Initial commit, based on ebuild from https://github.com/uu/ubuilds/blob/master/dev-db/repmgr/repmgr-9999.ebuild.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/repmgr/ChangeLog10
-rw-r--r--dev-db/repmgr/metadata.xml12
-rw-r--r--dev-db/repmgr/repmgr-3.0.1.ebuild41
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-db/repmgr/ChangeLog b/dev-db/repmgr/ChangeLog
new file mode 100644
index 000000000000..edf2d53791b5
--- /dev/null
+++ b/dev-db/repmgr/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/repmgr
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/repmgr/ChangeLog,v 1.1 2015/08/02 16:11:45 robbat2 Exp $
+
+*repmgr-3.0.1 (02 Aug 2015)
+
+ 02 Aug 2015; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +repmgr-3.0.1.ebuild:
+ Initial commit, based on ebuild from https://github.com/uu/ubuilds/blob/master
+ /dev-db/repmgr/repmgr-9999.ebuild.
diff --git a/dev-db/repmgr/metadata.xml b/dev-db/repmgr/metadata.xml
new file mode 100644
index 000000000000..ed88a4488c95
--- /dev/null
+++ b/dev-db/repmgr/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>betelguese@gentoo.org</email>
+ </maintainer>
+ <use>
+ </use>
+</pkgmetadata>
diff --git a/dev-db/repmgr/repmgr-3.0.1.ebuild b/dev-db/repmgr/repmgr-3.0.1.ebuild
new file mode 100644
index 000000000000..234ad758b818
--- /dev/null
+++ b/dev-db/repmgr/repmgr-3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/repmgr/repmgr-3.0.1.ebuild,v 1.1 2015/08/02 16:11:45 robbat2 Exp $
+
+EAPI=5
+inherit eutils
+DESCRIPTION="PostgreSQL Replication Manager"
+HOMEPAGE="http://www.repmgr.org/"
+SRC_URI="http://www.repmgr.org/download/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-db/postgresql-9.3[server]"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+src_compile() {
+ emake USE_PGXS=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" USE_PGXS=1 install
+ find $D -ls
+ export PGSLOT="$(postgresql-config show)"
+ einfo "PGSLOT: ${PGSLOT}"
+ PGBINDIR=${PGBASEDIR}/bin/
+ PGCONTRIB=/usr/share/postgresql-${PGSLOT}/contrib/
+ dodir $PGCONTRIB $PGBINDIR
+ insinto $PGCONTRIB
+ doins sql/repmgr2_repmgr3.sql
+ dosym $PGBINDIR/repmgr /usr/bin/repmgr94
+ dosym $PGBINDIR/repmgrd /usr/bin/repmgrd94
+ dodoc CREDITS HISTORY COPYRIGHT LICENSE TODO *.md *.rst
+ insinto /etc
+ newins repmgr.conf.sample repmgr.conf
+ fowners postgres:postgres /etc/repmgr.conf
+ ewarn "Remember to modify /etc/repmgr.conf"
+}