summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-26 19:26:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-26 19:26:05 +0000
commit6feda826faa4958028511617489eaf72909cf265 (patch)
tree1a07d7962183c4f8bdf86900dbff45f1bd9f7bdf /dev-db
parentAdding 8.5 alpha (diff)
downloadgentoo-2-6feda826faa4958028511617489eaf72909cf265.tar.gz
gentoo-2-6feda826faa4958028511617489eaf72909cf265.tar.bz2
gentoo-2-6feda826faa4958028511617489eaf72909cf265.zip
Adding 8.5 alpha
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql-docs/ChangeLog8
-rw-r--r--dev-db/postgresql-docs/files/postgresql-8.5-common.patch69
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.5_alpha3.ebuild59
3 files changed, 135 insertions, 1 deletions
diff --git a/dev-db/postgresql-docs/ChangeLog b/dev-db/postgresql-docs/ChangeLog
index 9999c30e9c8b..f583d5160e3b 100644
--- a/dev-db/postgresql-docs/ChangeLog
+++ b/dev-db/postgresql-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/postgresql-docs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.36 2010/01/07 18:15:12 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.37 2010/01/26 19:26:05 patrick Exp $
+
+*postgresql-docs-8.5_alpha3 (26 Jan 2010)
+
+ 26 Jan 2010; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-docs-8.5_alpha3.ebuild, +files/postgresql-8.5-common.patch:
+ Adding 8.5_alpha
07 Jan 2010; Steve Dibb <beandog@gentoo.org>
postgresql-docs-7.3.21.ebuild, postgresql-docs-7.4.26.ebuild,
diff --git a/dev-db/postgresql-docs/files/postgresql-8.5-common.patch b/dev-db/postgresql-docs/files/postgresql-8.5-common.patch
new file mode 100644
index 000000000000..4f4090eeaf7c
--- /dev/null
+++ b/dev-db/postgresql-docs/files/postgresql-8.5-common.patch
@@ -0,0 +1,69 @@
+=== configure.in
+==================================================================
+--- configure.in 2009-06-27 02:14:47.000000000 +0200
++++ configure.in 2009-07-09 15:05:02.000000000 +0200
+@@ -19,10 +19,6 @@
+
+ AC_INIT([PostgreSQL], [8.4.0], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.63], [], [m4_fatal([Autoconf version 2.63 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2009, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
+=== src/include/storage/s_lock.h
+==================================================================
+--- src/include/storage/s_lock.h 2009-01-01 18:24:01.000000000 +0100
++++ src/include/storage/s_lock.h 2009-07-09 15:03:08.000000000 +0200
+@@ -298,6 +298,29 @@
+
+ #endif /* __s390__ || __s390x__ */
+
++#if defined(__sh__)
++#define HAS_TEST_AND_SET
++
++typedef unsigned char slock_t;
++
++#define TAS(lock) tas(lock)
++
++static __inline__ int
++tas(volatile slock_t *lock)
++{
++ register int _res = 1;
++
++ __asm__ __volatile__(
++ "tas.b @%1\n\t"
++ "movt %0\n\t"
++ "xor #1,%0"
++: "=z"(_res)
++: "r"(lock)
++: "t","memory");
++ return _res;
++}
++
++#endif /* __sh__ */
+
+ #if defined(__sparc__) /* Sparc */
+ #define HAS_TEST_AND_SET
+=== src/makefiles/Makefile.darwin
+==================================================================
+--- src/makefiles/Makefile.darwin 2008-11-14 11:22:47.000000000 +0100
++++ src/makefiles/Makefile.darwin 2009-07-09 15:07:11.000000000 +0200
+@@ -5,7 +5,15 @@
+ CFLAGS_SL =
+
+ ifdef PGXS
++ifdef PGXS_IN_SERVER
++ifndef PGXS_WITH_SERVER
++BE_DLLLIBS= -bundle_loader $(top_builddir)/src/backend/postgres
++else
++BE_DLLLIBS= -bundle_loader ${PGXS_WITH_SERVER}
++endif
++else
+ BE_DLLLIBS= -bundle_loader $(bindir)/postgres
++endif
+ else
+ BE_DLLLIBS= -bundle_loader $(top_builddir)/src/backend/postgres
+ endif
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.5_alpha3.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.5_alpha3.ebuild
new file mode 100644
index 000000000000..3f7ffd6314c5
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-8.5_alpha3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.5_alpha3.ebuild,v 1.1 2010/01/26 19:26:05 patrick Exp $
+
+EAPI=2
+
+inherit versionator autotools
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+# Nothing to test here per 232157
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+
+MY_PV=${PV/_/}
+SRC_URI="mirror://postgresql/source/${MY_PV}/postgresql-${MY_PV}.tar.bz2"
+S=${WORKDIR}/postgresql-${MY_PV}
+
+
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE=""
+
+DEPEND="app-text/openjade
+ app-text/docbook-sgml-dtd:4.2
+ app-text/docbook-dsssl-stylesheets"
+
+src_prepare() {
+ epatch "${FILESDIR}/postgresql-${SLOT}-common.patch"
+ eautoconf || die "Failed to eautoconf"
+}
+
+src_compile() {
+ cd doc
+ emake html || die
+}
+
+src_install() {
+ dodir /usr/share/doc/${PF}/html
+ #tar -zxf "${S}/doc/postgres.tar.gz" -C "${D}/usr/share/doc/${PF}/html"
+ cd "${S}/doc"
+ docinto FAQ_html
+ #dodoc src/FAQ/* # no longer there?
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto html
+ dodoc src/sgml/html/*.html
+ docinto
+ dodoc TODO
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ {
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\""
+ } >"${D}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}