summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2005-01-25 23:09:46 +0000
committerTom William Payne <twp@gentoo.org>2005-01-25 23:09:46 +0000
commit80f20751c73f366b35d330468187268d1c83747f (patch)
treeac688114916a651b972a26cb0ae9c7a354f35e1f /dev-db
parentpyxml-0.8.3-r1 marked stable on x86. (diff)
downloadgentoo-2-80f20751c73f366b35d330468187268d1c83747f.tar.gz
gentoo-2-80f20751c73f366b35d330468187268d1c83747f.tar.bz2
gentoo-2-80f20751c73f366b35d330468187268d1c83747f.zip
Version bump. Bug # 79305.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/Manifest4
-rw-r--r--dev-db/phpmyadmin/files/digest-phpmyadmin-2.6.11
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.6.1.ebuild95
4 files changed, 105 insertions, 2 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 5102151eab58..caaea6e114de 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.80 2005/01/11 17:25:05 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.81 2005/01/25 23:09:46 twp Exp $
+
+*phpmyadmin-2.6.1 (26 Jan 2005)
+
+ 26 Jan 2005; Tom Payne <twp@gentoo.org> +phpmyadmin-2.6.1.ebuild:
+ Version bump. Bug # 79305.
11 Jan 2005; Tom Payne <twp@gentoo.org> -phpmyadmin-2.6.0_p2.ebuild,
-phpmyadmin-2.6.0_p3.ebuild, phpmyadmin-2.6.1_rc1.ebuild:
diff --git a/dev-db/phpmyadmin/Manifest b/dev-db/phpmyadmin/Manifest
index 8a2377c0ccf9..95ba470dbb0b 100644
--- a/dev-db/phpmyadmin/Manifest
+++ b/dev-db/phpmyadmin/Manifest
@@ -1,7 +1,9 @@
+MD5 6f4c9897d3e4191175bb28bd7a982dda phpmyadmin-2.6.1.ebuild 2599
MD5 d0ac5e24e09567b4888c6ee2fbd88b3e phpmyadmin-2.6.1_rc1.ebuild 2593
-MD5 e851bd1469e82acf51ad1a1e3cd809a3 ChangeLog 11293
+MD5 a6c474ec5dafa9bd03cbaaad7c6acbd7 ChangeLog 11367
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
MD5 4badbcc4cd669e6f934d5c993ff9ae4e files/digest-phpmyadmin-2.6.1_rc1 74
+MD5 c4e16f440d397574f36ec04130d54ba0 files/digest-phpmyadmin-2.6.1 70
MD5 56dcb2efb84915a521c18a004f96d37c files/postinstall-en.txt 506
MD5 85a86432c3f64acb068a7d2cfab311a9 files/config.inc.php-2.5.6.patch 5525
MD5 c6a79ab6f3c9e6d657a5bee36b1f6565 files/phpmyadmin-config.patch 4857
diff --git a/dev-db/phpmyadmin/files/digest-phpmyadmin-2.6.1 b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.6.1
new file mode 100644
index 000000000000..bf51b198b185
--- /dev/null
+++ b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.6.1
@@ -0,0 +1 @@
+MD5 eaa23b48760f2b31a8725bf85b0acecd phpMyAdmin-2.6.1.tar.bz2 1544628
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.6.1.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.6.1.ebuild
new file mode 100644
index 000000000000..6f16f61dfda0
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.6.1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.6.1.ebuild,v 1.1 2005/01/25 23:09:46 twp Exp $
+
+inherit eutils webapp
+
+MY_PV=${PV/_p/-pl}
+MY_PV=${PV/_rc/-rc}
+MY_P=phpMyAdmin-${MY_PV}
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~ppc ~hppa ~sparc ~x86 ~amd64 ~mips"
+IUSE=""
+DEPEND=">=net-www/apache-1.3
+ >=dev-db/mysql-3.23.32 <dev-db/mysql-5.1
+ virtual/php
+ sys-apps/findutils
+ !<=dev-db/phpmyadmin-2.5.6"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/config.inc.php-2.5.6.patch
+
+ # Remove .cvs* files and CVS directories
+ find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+}
+
+src_compile() {
+ einfo "Setting random user/password details for the controluser"
+
+ local pmapass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
+ mv config.inc.php ${T}/config.inc.php
+ sed -e "s/@pmapass@/${pmapass}/g" \
+ ${T}/config.inc.php > config.inc.php
+ sed -e "s/@pmapass@/${pmapass}/g" \
+ ${FILESDIR}/mysql-setup.sql.in-2.5.6 > ${T}/mysql-setup.sql
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="ANNOUNCE.txt CREDITS Documentation.txt RELEASE-DATE-${PV} TODO ChangeLog LICENSE README"
+
+ # install the SQL scripts available to us
+ #
+ # unfortunately, we do not have scripts to upgrade from older versions
+ # these are things we need to add at a later date
+
+ webapp_sqlscript mysql ${T}/mysql-setup.sql
+
+ # handle documentation files
+ #
+ # NOTE that doc files go into /usr/share/doc as normal; they do NOT
+ # get installed per vhost!
+
+ dodoc ${docs}
+ for doc in ${docs} INSTALL; do
+ rm -f ${doc}
+ done
+
+ # Copy the app's main files
+
+ einfo "Installing main files"
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ # Identify the configuration files that this app uses
+
+ webapp_configfile ${MY_HTDOCSDIR}/config.inc.php
+
+ # Identify any script files that need #! headers adding to run under
+ # a CGI script (such as PHP/CGI)
+ #
+ # for phpmyadmin, we *assume* that all .php files that don't end in
+ # .inc.php need to have CGI/BIN support added
+
+ for x in `find . -name '*.php' -print | grep -v 'inc.php'` ; do
+ webapp_runbycgibin php ${MY_HTDOCSDIR}/$x
+ done
+
+ # there are no files which need to be owned by the web server
+
+ # add the post-installation instructions
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ # all done
+ #
+ # now we let the eclass strut its stuff ;-)
+
+ webapp_src_install
+}