summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-04-26 23:06:41 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-04-26 23:06:41 +0000
commit8bb4cba6e01a2fcb1d206330bc55e8fb41d91c5a (patch)
tree158bdbea8a28f7d54d79d70878182b2d5284130a /dev-db
parentMarked ~hppa (bug #175749). (diff)
downloadgentoo-2-8bb4cba6e01a2fcb1d206330bc55e8fb41d91c5a.tar.gz
gentoo-2-8bb4cba6e01a2fcb1d206330bc55e8fb41d91c5a.tar.bz2
gentoo-2-8bb4cba6e01a2fcb1d206330bc55e8fb41d91c5a.zip
inherit java-ant-2 to make JAVA_PKG_STRICT happy and stylistic cleanup.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/henplus/ChangeLog7
-rw-r--r--dev-db/henplus/henplus-0.9.7.ebuild25
2 files changed, 15 insertions, 17 deletions
diff --git a/dev-db/henplus/ChangeLog b/dev-db/henplus/ChangeLog
index c8a8baab4be8..2c40fdc1ac94 100644
--- a/dev-db/henplus/ChangeLog
+++ b/dev-db/henplus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/henplus
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.14 2006/10/17 21:47:39 caster Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.15 2007/04/26 23:06:41 betelgeuse Exp $
+
+ 26 Apr 2007; Petteri Räty <betelgeuse@gentoo.org> henplus-0.9.7.ebuild:
+ inherit java-ant-2 to make JAVA_PKG_STRICT happy and stylistic cleanup.
*henplus-0.9.7 (17 Oct 2006)
diff --git a/dev-db/henplus/henplus-0.9.7.ebuild b/dev-db/henplus/henplus-0.9.7.ebuild
index 9ba50bd71d57..2bd65b7d2a72 100644
--- a/dev-db/henplus/henplus-0.9.7.ebuild
+++ b/dev-db/henplus/henplus-0.9.7.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/henplus-0.9.7.ebuild,v 1.1 2006/10/17 21:47:39 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/henplus-0.9.7.ebuild,v 1.2 2007/04/26 23:06:41 betelgeuse Exp $
-inherit java-pkg-2 eutils
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 eutils java-ant-2
DESCRIPTION="Java-based multisession SQL shell for databases with JDBC support."
-HOMEPAGE="http://${PN}.sf.net"
+HOMEPAGE="http://henplus.sf.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc source"
+IUSE=""
COMMON_DEPEND="=dev-java/commons-cli-1*
dev-java/libreadline-java"
RDEPEND=">=virtual/jre-1.3
${COMMON_DEPEND}"
DEPEND=">=virtual/jdk-1.3
- dev-java/ant-core
- source? ( app-arch/zip )
${COMMON_DEPEND}"
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -29,23 +28,19 @@ src_unpack() {
epatch "${FILESDIR}/${P}-build.xml.patch"
cd lib
- rm -v *.jar build/*.jar
+ rm -v *.jar build/*.jar || die
java-pkg_jar-from commons-cli-1 commons-cli.jar
java-pkg_jar-from libreadline-java libreadline-java.jar
}
-src_compile() {
- eant jar $(use_doc)
-}
-
src_install () {
java-pkg_dojar "build/${PN}.jar"
java-pkg_dolauncher ${PN} -pre "${FILESDIR}/${PN}.pre" \
--main henplus.HenPlus
- dodoc README
- dohtml doc/HenPlus.html
+ dodoc README || die
+ dohtml doc/HenPlus.html || die
use doc && java-pkg_dojavadoc javadoc/api
use source && java-pkg_dosrc "src/${PN}"