summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:30:29 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:30:29 +0000
commita20f876b132a36d97e752fb0c9c033af6edd81f5 (patch)
tree3538cb238dce943d662efd904fe2d67ab64adbf3 /dev-db
parentinitial commit (diff)
downloadgentoo-2-a20f876b132a36d97e752fb0c9c033af6edd81f5.tar.gz
gentoo-2-a20f876b132a36d97e752fb0c9c033af6edd81f5.tar.bz2
gentoo-2-a20f876b132a36d97e752fb0c9c033af6edd81f5.zip
initial commit
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/lib_mysqludf_ta/ChangeLog10
-rw-r--r--dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild68
-rw-r--r--dev-db/lib_mysqludf_ta/metadata.xml9
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_ta/ChangeLog b/dev-db/lib_mysqludf_ta/ChangeLog
new file mode 100644
index 000000000000..7411433c6e54
--- /dev/null
+++ b/dev-db/lib_mysqludf_ta/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/lib_mysqludf_ta
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_ta/ChangeLog,v 1.1 2011/10/19 12:30:29 sbriesen Exp $
+
+*lib_mysqludf_ta-0.1 (19 Oct 2011)
+
+ 19 Oct 2011; Stefan Briesenick <sbriesen@gentoo.org>
+ +lib_mysqludf_ta-0.1.ebuild, +metadata.xml:
+ initial commit
+
diff --git a/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild b/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild
new file mode 100644
index 000000000000..df9b0cff0c0c
--- /dev/null
+++ b/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_ta/lib_mysqludf_ta-0.1.ebuild,v 1.1 2011/10/19 12:30:29 sbriesen Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs autotools
+
+MY_REV="a8e623c" # checkout revision
+MY_USR="joaocosta" # user name
+
+MY_P="${MY_USR}-${PN}-${MY_REV}"
+
+DESCRIPTION="MySQL UDFs with technical analysis functions"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_ta/"
+SRC_URI="https://github.com/${MY_USR}/${PN}/tarball/${MY_REV} -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+
+ # fix Makefile.am
+ sed -i -e "s|\(-shared\)|\1 -avoid-version|g" Makefile.am
+
+ # convert to UTF-8
+ iconv -f LATIN1 -t UTF-8 < README > README~
+ mv -f README~ README
+
+ edos2unix README
+ eautoreconf
+}
+
+src_compile() {
+ econf --with-pic --disable-static --libdir="${MYSQL_PLUGINDIR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README sampledb.sql
+
+ # remove obsolete *.la file
+ rm -f -- "${D}${MYSQL_PLUGINDIR}"/*.la
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_ta/metadata.xml b/dev-db/lib_mysqludf_ta/metadata.xml
new file mode 100644
index 000000000000..abc550987baf
--- /dev/null
+++ b/dev-db/lib_mysqludf_ta/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
+</pkgmetadata>